Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Проблема с подключением PCMCIA картой Com портов RS-COM 2P  (Прочитано 2533 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Shest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Люди нужна помощь начинающему юзверю.
Имеем PCMCIA карту конвертер com портов.
http://www.argosy.com.tw/product-detial.php?prod_id=56
Система при установке пишет следующее
dmseg:
[91712.584203] pcmcia_socket pcmcia_socket0: pccard: PCMCIA card inserted into slot 0
[91712.584585] pcmcia 0.0: pcmcia: registering new device pcmcia0.0
[91712.584727] pcmcia 0.0: firmware: requesting RS-COM-2P.cis
[91712.600411] pcmcia 0.0: firmware: requesting RS-COM-2P.cis
[91712.661831] parport_cs: parport_pc_probe_port() at 0x23e8, irq 3 failed
OS Ubuntu 9.10
Как запустить вообще данную плату. В чем вообще грабли и где копать - ну очень нужно.
Заранее спасибо.
« Последнее редактирование: 16 Февраль 2010, 12:56:12 от Shest »

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
карта хочет firmware RS-COM-2P.cis
похоже, в штатном ядре 2.6.31 его нету. у меня в 2.6.33 оно нашлось:
/lib/firmware/2.6.33-020633rc8-generic/cis/RS-COM-2P.cis
/lib/firmware/2.6.33-020633rc6-generic/cis/RS-COM-2P.cis

попробуйте поставить ядро отсюда: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33-rc8/

Оффлайн Shest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
карта хочет firmware RS-COM-2P.cis
похоже, в штатном ядре 2.6.31 его нету. у меня в 2.6.33 оно нашлось:
/lib/firmware/2.6.33-020633rc8-generic/cis/RS-COM-2P.cis
/lib/firmware/2.6.33-020633rc6-generic/cis/RS-COM-2P.cis

попробуйте поставить ядро отсюда: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33-rc8/
Спасибо за совет. После установки ядра добавились
[  125.876441] pcmcia 0.0: pcmcia: registering new device pcmcia0.0
[  125.877151] pcmcia 0.0: firmware: requesting cis/RS-COM-2P.cis
[  125.936232] 0.0: ttyS0 at I/O 0x23e8 (irq = 3) is a 16550A
[  125.937413] 0.0: ttyS1 at I/O 0x22e8 (irq = 3) is a 16550A
два устройства ttyS0 и ttyS1 но не совсем понятно почему оба ком порта повисли на одно прерывание-это нормально?.
И почему то в новом ядре слетел драйвер для видео карты и перестановка драйверов ничего не дала, пришлось запускать старое ядро;(
Xorg.conf
(Нажмите, чтобы показать/скрыть)
Xorg.0.log здесь:
(Нажмите, чтобы показать/скрыть)

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
потому что вместе с ядром надо было поставить и заголовки ядра оттуда же, тогда dkms пересобрал бы модуль ядра nvidia при перезагрузке

Оффлайн Shest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
потому что вместе с ядром надо было поставить и заголовки ядра оттуда же, тогда dkms пересобрал бы модуль ядра nvidia при перезагрузке
Я установил
 linux-headers-2.6.33-020633rc8_2.6.33-020633rc8_all.deb
 linux-source-2.6.33_2.6.33-020633rc8_all.deb
под sudo запустил nautilus и из под него запустил оба эти пакета. Может я где ошибся?

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
в названии файла указано что это.
помимл метапакета linux-headers-2.6.33-020633rc8-generic_2.6.33-020633rc8_all.deb нужен ещё linux-headers-2.6.33-020633rc8-generic_2.6.33-020633rc8_i386.deb или linux-headers-2.6.33-020633rc8-generic_2.6.33-020633rc8_amd64.deb

Оффлайн Shest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
в названии файла указано что это.
помимл метапакета linux-headers-2.6.33-020633rc8-generic_2.6.33-020633rc8_all.deb нужен ещё linux-headers-2.6.33-020633rc8-generic_2.6.33-020633rc8_i386.deb или linux-headers-2.6.33-020633rc8-generic_2.6.33-020633rc8_amd64.deb
Выбор ранее не выбранного пакета linux-headers-2.6.33-020633rc8-generic.
(Чтение базы данных ... на данный момент установлено 262919 файлов и каталогов.)
Распаковывается пакет linux-headers-2.6.33-020633rc8-generic (из файла .../linux-headers-2.6.33-020633rc8-generic_2.6.33-020633rc8_i386.deb)...
Настраивается пакет linux-headers-2.6.33-020633rc8-generic (2.6.33-020633rc8) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms
 * Running DKMS auto installation service for kernel 2.6.33-020633rc8-generic                                                                                   
 *  nvidia (173.14.20)...                                                       nvidia (173.14.20): Installing module.
.......(bad exit status: 10)
  Build failed.  Installation skipped.
                                                                         [fail]
 *  vboxdrv (3.1.2)...                                                          vboxdrv (3.1.2): Installing module.
.......(bad exit status: 10)
  Build failed.  Installation skipped.
                                                                         [fail]
 *  vboxnetadp (3.1.2)...                                                       vboxnetadp (3.1.2): Installing module.
.......(bad exit status: 10)
  Build failed.  Installation skipped.
                                                                         [fail]
 *  vboxnetflt (3.1.2)...                                                       vboxnetflt (3.1.2): Installing module.
.......(bad exit status: 10)
  Build failed.  Installation skipped.
                                                                         [fail]
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common
Во каких ошибок мне навыдавало:(


Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
в var/lib/dkms/nvidia/*/build есть make.log -- там сказано, что произошло. аналогично и для виртуалбокса.
последний, похоже, достаточно просто обновить -- 3.1.4 дружит с ядром 2.6.33

Пользователь решил продолжить мысль 16 Февраль 2010, 16:39:53:
а согласно вот этому https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/394262, видеодрайвер достаточно обновить. есть возможность, или видеокарта старая?
« Последнее редактирование: 16 Февраль 2010, 16:39:53 от dmig »

Оффлайн Shest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
в var/lib/dkms/nvidia/*/build есть make.log -- там сказано, что произошло. аналогично и для виртуалбокса.
последний, похоже, достаточно просто обновить -- 3.1.4 дружит с ядром 2.6.33

Пользователь решил продолжить мысль 16 Февраль 2010, 16:39:53:
а согласно вот этому https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/394262, видеодрайвер достаточно обновить. есть возможность, или видеокарта старая?
Это make.log
DKMS make.log for nvidia-185.18.36 for kernel 2.6.33-020633rc8-generic (i686)
Втр Фев 16 16:47:42 MSK 2010
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Ошибка 1
Этот драйвер nvidia-185.18.36 замечательно работал под предыдущим ядром, с Компизом дружил. Драйвер вроде самый свежий из подходящих для моей карты. VBox не так актуален, использую VMWare для виртуализации. И драйвера из Система--Администрирование--Драйвера устройств  не ставятся, выдают ту же ошибку.

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
ls -d /usr/src/linux-* что покажет?

Оффлайн Shest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
ls -d /usr/src/linux-* что покажет?
/usr/src/linux-headers-2.6.31-14
/usr/src/linux-headers-2.6.31-14-generic
/usr/src/linux-headers-2.6.31-17
/usr/src/linux-headers-2.6.31-17-generic
/usr/src/linux-headers-2.6.31-19
/usr/src/linux-headers-2.6.31-19-generic
/usr/src/linux-headers-2.6.33-020633rc8
/usr/src/linux-headers-2.6.33-020633rc8-generic
/usr/src/linux-source-2.6.33.tar.bz2

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
так, вроде всё нужное есть...
надо попробовать руками: sudo dkms install -m nvidia -k 2.6.33-020633rc8 -v <смотреть в /var/lib/dkms/nvidia/>

Оффлайн Shest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
так, вроде всё нужное есть...
надо попробовать руками: sudo dkms install -m nvidia -k 2.6.33-020633rc8 -v <смотреть в /var/lib/dkms/nvidia/>
Error! Could not locate nvidia.ko for module nvidia in the DKMS tree.
You must run a dkms build for kernel 2.6.33-020633rc8-generic (i686) first.

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
Ну? И что непонятно?
указать параметру -k версию 2.6.33-020633rc8-generic

Оффлайн Shest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Ну? И что непонятно?
указать параметру -k версию 2.6.33-020633rc8-generic
я вот так и запускал: sudo dkms install -m nvidia -k 2.6.33-020633rc8-generic -v 185.18.36
 :-[

 

Страница сгенерирована за 0.065 секунд. Запросов: 22.