Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: не запускается KDE  (Прочитано 1172 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн eerome

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
не запускается KDE
« : 24 Февраль 2010, 19:26:36 »
После выбора системы в Грабе, происходит какая то проверка на ошибки, после чего появляется на экране следующее:


А при запуске команд выводит:


помогите решить!
« Последнее редактирование: 24 Февраль 2010, 20:00:04 от eerome »

Оффлайн -=TARAS=-

  • Участник
  • *
  • Сообщений: 108
    • Просмотр профиля
Re: не запускается KDE
« Ответ #1 : 24 Февраль 2010, 20:04:53 »
Ну для начала скажи что делал? После чего перестал запускаться? Я не думаю что сам по себе.

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: не запускается KDE
« Ответ #2 : 24 Февраль 2010, 20:10:58 »
Mount of filesystem failed означает то, что невозможно подключить одну или более файловых систем. Обычно из-за:
1. Серьёзных ошибок в файловой системе
2. Сменился UUID раздела из за пользования редакторами разделов.
3. Один из системных дисков украли или ему просто кирдык.

Оффлайн eerome

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается KDE
« Ответ #3 : 24 Февраль 2010, 20:12:48 »
ничего не делал, свет выключили, комп вырубился, после чего по работал в винде, перегрузил на Ubuntu, и тут такое...

з.ы. кстати, после выполнения fsck -Ay и дальнейшей перезагрузки, мельком появился экран загрузки КДЕ, но тут же экран стал черным и ничего не происходит.
Такое было и до этого, но после нескольких перезагрузок проходило, почему не проходит сейчас не пойму

Пользователь решил продолжить мысль 24 Февраль 2010, 20:14:24:
Mount of filesystem failed означает то, что невозможно подключить одну или более файловых систем. Обычно из-за:
1. Серьёзных ошибок в файловой системе
2. Сменился UUID раздела из за пользования редакторами разделов.
3. Один из системных дисков украли или ему просто кирдык.

2 и 3 пункты отпадают.

А как исправить ошибки в ФС?
« Последнее редактирование: 24 Февраль 2010, 20:14:24 от eerome »

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: не запускается KDE
« Ответ #4 : 24 Февраль 2010, 20:26:52 »
fsck -Ay должно было помочь. Кстати, а какая ФС используется?

Сейчас именно кеды не грузятся? Возможно, что в профиль кедовский затесалось что-то нехорошее. Я как босота гномовская, кеды не имею и конкретнее, что делать не могу сказать.

Оффлайн eerome

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается KDE
« Ответ #5 : 24 Февраль 2010, 20:30:45 »
Я не знаю как запустить в такой ситуации Гном.
ФС-Ext4

fsck -Ay - помогло, но теперь я не имею доступ к консоли, и передо мной просто черный экран.

Оффлайн gantellus

  • Старожил
  • *
  • Сообщений: 1276
    • Просмотр профиля
Re: не запускается KDE
« Ответ #6 : 24 Февраль 2010, 20:42:46 »
в грабе выбрать recovery mode, и воспользоваться testdisk

или грузиться с livecd и заюзать testdisk уже там
Придумайте ещё более дружественный интерфейс, и мир породит ещё более тупого юзера (с)
С2Duo 2.4 Ghz, Geforce 8800, Maya 44 PCI

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: не запускается KDE
« Ответ #7 : 24 Февраль 2010, 20:43:31 »
ctrl+alt+f1?
alt+sysrq+e?
Или в грабе recovery mode выбрать?


Пользователь решил продолжить мысль 24 Февраль 2010, 20:45:02:
воспользоваться testdisk
Это зачем? Фс в порядке, MFT жива.
« Последнее редактирование: 24 Февраль 2010, 20:45:02 от Mam(O)n »

Оффлайн eerome

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается KDE
« Ответ #8 : 24 Февраль 2010, 20:50:17 »
по сочетанию клавиш ничего не происходит.
А вот так у меня выглядит Recovery Menu:

Оффлайн suslikk

  • Старожил
  • *
  • Сообщений: 2362
    • Просмотр профиля
Re: не запускается KDE
« Ответ #9 : 24 Февраль 2010, 22:19:04 »
Метод туп, но все же предложу... Перенесите куда-нибудт файл /etc/fstab, и перезагрузитесь, посмотрите, что мосле этого скажет
Нарисуй свой город на openstreetmap.org

Оффлайн eerome

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается KDE
« Ответ #10 : 25 Февраль 2010, 11:06:56 »
как это сделать?

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: не запускается KDE
« Ответ #11 : 25 Февраль 2010, 13:36:20 »
Метод глуп. Этого лучше не делать.

Тут вот невидно то, на что ругается загрузчик. Но из обрывков слов видно, что фигурирует слово swap. Если все фс в fstab уже были прочеканы fsck -Ay то могу предположить, что полетела метка раздела свопа. Я бы в этом случае грузанулся бы с LiveCD, посмотрел /etc/fstab, который на жестком диске, дал бы команды blkid, чтобы посмотреть UUID-ы разделов и сравнить с fstab, дал бы fdisk -l, чтоб определить имя раздела свопа и переметил бы своп-раздел командой mkswap /dev/раздел_свопа

Оффлайн nick87720z

  • Участник
  • *
  • Сообщений: 167
    • Просмотр профиля
Re: не запускается KDE
« Ответ #12 : 25 Февраль 2010, 14:05:41 »
осторожно, новичек! (в смысле, сам с этим не сталкивался)
У вас не выполнялось ничего серьезного, когда выключили свет? Например, обновление...
Если смонтируется из под LiveCD, то можно попробовать монтировать на целевой системе. Если не удастся, попробовать взять строчки из livecd-шного fstab. Если и тогда не удастся, зайти туда с livecd через chroot и попробовать восстановить initramfs: sudo update-initramfs -k all

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: не запускается KDE
« Ответ #13 : 25 Февраль 2010, 14:22:19 »
livecd-шного fstab.
Там ничего нет такого, что относилось бы не к livecd

попробовать восстановить initramfs:
А он и не портился. Ядро то грузится.

Оффлайн eerome

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается KDE
« Ответ #14 : 26 Февраль 2010, 13:11:16 »
Выполнил все выше описанные действия, эффекта никакого, все так же перед запуском графической оболочки черный экран, и ни на какие действия не реагирует, кроме как ктрл-альт-делл.

Какой командой можно убрать KDE, и что бы загрузился Gnome?

 

Страница сгенерирована за 0.093 секунд. Запросов: 22.