Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Connected! написал, а лиса пишет, что сервер не найден. Прошу помощи...  (Прочитано 1006 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Юркий

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Долго прикручивал starnet к ubuntu 9.10. наконец-то pppoe-start и - о, чудо - connected вижу в терминале. Но Mozilla выдает server not found. В чем может быть причина?

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
DNS?

Покажи

ping 213.180.204.8
ping ya.ru

Оффлайн Юркий

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
В общем, следовал четко инструкциям , данным провайдером на сайте. DNS не нужно было прописывать. Ниже инструкции, выполненные мной:


Настройка VPN соединения - Linux
Установить пакет PPPoE - Roaring Penguin
Локальная ссылка для скачивания: rp-pppoe.tar.gz

Добавить в файл /etc/ppp/chap-secrets строку:

    Login * Password *

        * Заменить Login на "Пользователь" - (указан в Паспорте абонента)
        * Заменить Password на "Пароль" – (указан в Паспорте абонента)

              Внимание! Данный пароль действует 24 часа с момента первого входа.

    Пример строки: 12345-1 * mypassword *

Добавить в файл /etc/ppp/options строку:

    require-mschap-v2

И файл /etc/ppp/pppoe.conf должен выглядеть так:
Важно!
Значение для строки "CONNECT_TIMEOUT" не может быть менее "60"!

    ETH='iface'
    USER='login'
    DEMAND=no
    DNSTYPE=NOCHANGE
    PEERDNS=no
    DNS1=
    DNS2=
    DEFAULTROUTE=yes
    CONNECT_TIMEOUT=60
    CONNECT_POLL=2
    ACNAME=
    SERVICENAME=servicename
    PING="."
    CF_BASE=`basename $CONFIG`
    PIDFILE="/var/run/$CF_BASE-pppoe.pid"
    SYNCHRONOUS=no
    CLAMPMSS=1412
    LCP_INTERVAL=20
    LCP_FAILURE=3
    PPPOE_TIMEOUT=80
    FIREWALL=NONE
    LINUX_PLUGIN=
    PPPOE_EXTRA=""
    PPPD_EXTRA=""

    * Заменить iface на Ваш интерфейс (например, rl0)
    * Заменить servicename на starnetXXX

          (где XXX трехзначный номер, с лидирующими нулями, вашего массива)
          Например: starnet001, starnet076, starnet173
          Слово starnet следует вводить маленькими буквами!

    * Заменить login на "Пользователь" - (указан в Паспорте абонента)


Запуск VPN вручную:

    pppoe-start

Остановка VPN вручную:

    pppoe-stop

Гарри Кашпировский

  • Гость
Достаточно было бы pppoeconf набрать.
А дальше pon dsl-provider/poff dsl-provider
Каждый идет своим путём :)

Оффлайн Юркий

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
но лиса сервер не находит, а pppoe.config тоже не находит ... кабель провайдера((

Оффлайн podkovyrsty

  • Старожил
  • *
  • Сообщений: 1547
  • Content-Type: alternative
    • Просмотр профиля
cat /etc/ppp/chap-secrets
cat /etc/ppp/options
cat /etc/ppp/pppoe.conf
Шаг за шагом можно достичь цели.

Оффлайн SvolochDzen

  • Активист
  • *
  • Сообщений: 299
    • Просмотр профиля
привет...
Вот у меня тоже такая почти проблема.... Настраивал модем 3G по всем известному способу.... опишу по очередности...
 1- ​sudo apt-get update && sudo apt-get install udev-extras
 2 -  echo 'SUBSYSTEM=="usb", SYSFS{idProduct}=="1446", SYSFS{idVendor}=="12d1", RUN+="/lid/udev/modem-modeswitch --vendor0x12d1 --product 0x1446 --type option-zerocd"' |sudo tee /etc/udev/rules.d/45-huawei1550.rules
 3 -  Ставим в очередности.

1) libxplc0.3.13_0.3.13-1_i386.deb
2) libwvstreams4.4-base_4.4.1-1.1_i386.deb
3) libwvstreams4.4-extras_4.4.1-1.1_i386.deb
4) libuniconf4.4_4.4.1-1.1_i386.deb
5) wvdial_1.60.1+nmu2_i386.deb
6) gnome-ppp_0.3.23-1_i386

После того как установим нужные нам программы изменим файл /etc/wvdial.conf примерно так:

[Dialer usb]
Modem Type = USB Modem
Baut = 460800
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0
Init3 = AT+CGDCONT=1,"IP","internet.оператор.домен"
Phone = *99***1#
Username = @internet.оператор
Password = оператор
Dial Attempts = 5
Dial Command = ATM1L3DT
Auto Reconnect = on
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = off
Idle Seconds = 0
Auto DNS = on


Просто так изменить файл   /etc/wvdial.conf не получилось. изменял через команду :   sudo gedit /etc/wvdial.conf
 И всё.... интернет сам автоматически подключился.... Но вот проблемка одна есть
При каждом входе ( то есть втыкание модема в порт а дальше он автовкл... ) соединение происходит, Но браузер не всегда может показать соединение( он же FIREFOX ) , Выдает что мол не получилось подсоединиться в тому ил иному сайту....
И дело такое происходит не только с браузером, но и с аськой... тоже показывает мол Local host not.......
опять заново вынимаю модем, и повторно втыкаю... Иногда все таки интернет срабатывает, а иногда опять нет..... Но соединение есть всегда...
Можете тоже подсказать что не так....? :-\

 

Страница сгенерирована за 0.057 секунд. Запросов: 23.