Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Подозрительно пропадает Сеть по Wi-FI  (Прочитано 2824 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Blur

  • Автор темы
  • Любитель
  • *
  • Сообщений: 59
    • Просмотр профиля
Доброго вечера всем!
Очень прошу помочь с серьезной проблемой:
Имеется офис на 12 Компьютеров. Решил я его полность перевести на Ubuntu 10.04. Рассказал людям приемущества, все красиво описал...
Перевел уже 5 машинок различной конфигурации. Небольшие косяки вылазили: То расшаренный принтер после перезагрузки не видится сетевыми ПК (лечится добавлением "sudo service smbd restart" в конец /etc/init.d/cups),
то косяки Самбы вылазят. Через день вроде все устаканилось: Самба рыщет сеть, сетевые принтеры без проблем печатают.
НО! У всех без исключения машинок периодически (1 раз в 1-2 часа ) пропадает wi-fi, причем так, что Network Manager говорит, что соединение есть. Тоесть коннект к AP сохраняется, но ни сеть, ни Инет не работает.
У 3-х машинок Wi-Fi адаптер Asus WL-167G (чип Ralink 2571), у 2-х - Dlink DWA-110 (чип тот же, Ralink 2571).
Лечится все простым переподключением к Wi-Fi сети, и снова на час-два.
Начитался про хреновость Убунтовского Network Manager`a. Выход - установить Wicd. Сказано - сделано:
sudo apt-get remove network-manager-gnome
sudo apt-get remove network-manager
sudo apt-get install wicd
Настроил, но.... Проблема сохранилась! С такой же периодичностью отваливается Инет, Wicd говорит, что подключение к Точке доступа есть. Переподключаемся - работает.
В качестве точек доступа используются роутеры Linksys WR54, DHCP отключен, шифрование WPA2. Точек имеется 3, работают все на одном канале.

Команда, помогите мне не упасть в грязь лицом перед сотрудниками)
Еще один вариант - настроить все через wpa_supplicant, но я уже сомневаюсь, сработает или нет.
« Последнее редактирование: 19 Май 2010, 23:23:43 от Blur »

Оффлайн stui91

  • Любитель
  • *
  • Сообщений: 71
  • ubuntu 10.04 / osX 10.8.2 / windows7
    • Просмотр профиля
Re: Подозрительно пропадает Сеть по Wi-FI
« Ответ #1 : 19 Май 2010, 22:49:51 »
а мб банальный перегрев адаптера? иногда такое случается...

Оффлайн Blur

  • Автор темы
  • Любитель
  • *
  • Сообщений: 59
    • Просмотр профиля
Re: Подозрительно пропадает Сеть по Wi-FI
« Ответ #2 : 19 Май 2010, 22:58:38 »
а мб банальный перегрев адаптера? иногда такое случается...
Спасибо за ответ, НО... одинаковый трабл на пяти машинах. Wi-FI адаптеры построены на одном и томи же чипе RT2571....
Ради интереса поставил в одну из них карточку D-link DWA 510 (чип Ralink RT2641). Проблема осталась

Оффлайн agimoura

  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля
Re: Подозрительно пропадает Сеть по Wi-FI
« Ответ #3 : 19 Май 2010, 23:47:17 »
Хм...

У меня была похожая проблема ещё на 9.10 с адаптером на чипе RT2573... Вылечилось установкой более свежего ядра отсюда ...

На 10.04 этой проблемы не наблюдалось...



Оффлайн stui91

  • Любитель
  • *
  • Сообщений: 71
  • ubuntu 10.04 / osX 10.8.2 / windows7
    • Просмотр профиля
Re: Подозрительно пропадает Сеть по Wi-FI
« Ответ #4 : 19 Май 2010, 23:49:22 »
а дрова из коробки?
у меня на буке карта атерос после обновления дров с сайта ahttp://www.aircrack-ng.org/doku.php?id=install_drivers постабильнее стал работать


или если попробвать скорость вифи фиксировать?
sudo iwconfig wlan0 rate 1M fixed


Оффлайн Blur

  • Автор темы
  • Любитель
  • *
  • Сообщений: 59
    • Просмотр профиля
Re: Подозрительно пропадает Сеть по Wi-FI
« Ответ #5 : 19 Май 2010, 23:55:56 »
а дрова из коробки?
у меня на буке карта атерос после обновления дров с сайта ahttp://www.aircrack-ng.org/doku.php?id=install_drivers постабильнее стал работать


или если попробвать скорость вифи фиксировать?
sudo iwconfig wlan0 rate 1M fixed
Да, дрова из коробки. Насчет фиксации скорости - утром буду пробовать

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.