Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Помогите настроить роутинг  (Прочитано 2779 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dahaka

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: Помогите настроить роутинг
« Ответ #15 : 22 Сентябрь 2010, 02:05:55 »
3. С НАТом никогда не стыкался.. Сейчас погуглю что он из себя представляет)
Если схема подключения, описанная в первом посте не изменилась, то на PC1 объединяй два eth интерфейса в бридж и будет тебе и гигабит между PC1-PC4 и PC4 будет в общем сегменте с остальными и не надо будет городить нат на PC1.

ВОТ! Как раз такого ответа я и ждал! :D Так, собственно, и должно было реализоваться(в смысле через мост). Всё проверенно на вирт. машинах - работает. На реальной же - вот такая вот проблема получается. Подняв мост ещё как-то всё функционирует(хоть и медленно), но если подключить какой-то ноут к гигабитной карте на РС1, то ложится сеть. Имеет ли место грешить на драйвера? Копал в сторону почему utorrent не пускает, нашел что надо включить UPnP. Включил, но ничего не изменилось. Есть варианты решения данного вопроса? На данный момент так и оставил проброс порта по адресам. Или всё же на роутер стоит грешить? Я о нем немного почитал, кривоватая прошивка(бывает даже и PPPoE иногда сам отключает).
« Последнее редактирование: 22 Сентябрь 2010, 02:08:23 от Dahaka »

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Помогите настроить роутинг
« Ответ #16 : 22 Сентябрь 2010, 10:28:01 »
Подняв мост ещё как-то всё функционирует(хоть и медленно), но если подключить какой-то ноут к гигабитной карте на РС1, то ложится сеть. Имеет ли место грешить на драйвера?
В теории ничего не должно лагать. На практике же мне не на чем проверять. Может конфликт ip адресов у тебя получился? Из за этого возможны лаги. Как настраивал?


Копал в сторону почему utorrent не пускает, нашел что надо включить UPnP. Включил, но ничего не изменилось. Есть варианты решения данного вопроса? На данный момент так и оставил проброс порта по адресам. Или всё же на роутер стоит грешить? Я о нем немного почитал, кривоватая прошивка(бывает даже и PPPoE иногда сам отключает).
Что значит не пускает? UPNP статус на роутере есть?

Оффлайн Dahaka

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: Помогите настроить роутинг
« Ответ #17 : 23 Сентябрь 2010, 06:13:23 »
1. Лучше все же вывести свой ИП из диапазона ДХЦП
2. Реально непонятно зачем проброс этих портов. Полагаю, что просто ошибся в терминах и они у тебя просто открыты.
3. Когда решишь с этим делай на пс1 либо НАТ (если только мнтернет раздать) либо иначе. НО! определись с вышесказанным
1.Сделано.
2.Не ошибся. Теперь, как ни странно, но работает. Хотя всё же хочется очень понять почему не работало. (как и почему работает описал далее)
3.Почитал про НАТ здесь http://ru.wikibooks.org/wiki/%D0%9F%D0%BE%D1%80%D1%82/NAT. Получается у меня в любом случае НАТ. Я ж не провайдер чтоб выдавать себе белые адреса). Или в чем заключалась суть?

Mam(O)n, всё перенастроил с нуля. Вроде, всё работает :o (как ни странно.. до этого было точно так же настроено). Интернет работает на ура. Сеть, не совсем уверенно, но работает) В смысле долго подымается сеть и есть задержки между переходам по машинкам.. А ноут с Ubuntu, периодически не виден в сети. Сама ж Ubuntu компьютеры в сети видит, но не может на них зайти(пишет Не удалось получить местоположение)

На роутере в UPNP есть только Вкл./Откл. Стоит естественно Вкл. В Справке написано что позволяет ОС Windows автоматически настраивать устройство для работы различных интернет-приложений. Что тогда будет делать Ubuntu  в этом случае?

После всех этих манипуляций, интернет начал быстрее подыматься на РС_1.

Как настроено: на РС_1 две карты:100Мбит и 1Гбит соединены в мост. На 100Мбит вбил статику, которая не входит в диапазон DHCP(диапазон 192.168.1.100-192.168.1.150), вбил 192.168.1.160.

UPD: теперь, вЫключив проброс портов для utorrent и icq наблюдаю следующую картину: icq заводится с пол пинка(хотя раньше надо было ждать пару минут после загрузки); utorrent так же быстренько начинает работать, но при этом горит красным (статус) и говорит что не настроен фаерволл/маршрутизатор. По тесту порта, естественно, говорит что порт закрыт. Может для него таки необходимо пробрасывать порт?
« Последнее редактирование: 23 Сентябрь 2010, 08:07:28 от Dahaka »

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Помогите настроить роутинг
« Ответ #18 : 23 Сентябрь 2010, 09:25:15 »
Как настроено: на РС_1 две карты:100Мбит и 1Гбит соединены в мост. На 100Мбит вбил статику, которая не входит в диапазон DHCP(диапазон 192.168.1.100-192.168.1.150), вбил 192.168.1.160.
Ну под вопросом "как настроено" я имел ввиду конфиги, информационные выводы команд и пр. техническую информацию. Но раз всё работает, тады ладно.

Может для него таки необходимо пробрасывать порт?
Да, надо. Этим и должен был заняться utorrent по протоколу UPNP. Но раз не фурычит та, тогда ручками.... Кстати, а может у тебя там файрволл блочит upnp?

Оффлайн Dahaka

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: Помогите настроить роутинг
« Ответ #19 : 12 Октябрь 2010, 21:40:18 »
Фаервол программный не пользую, только тот что на роутере. Ну уже не суть важно. Всё работает, вроде, работает. По крайней мере пока критических проблем с сетью не возникало. Спасибо!

З.Ы. Извиняюсь что долго не было.

 

Страница сгенерирована за 0.133 секунд. Запросов: 22.