Форум русскоязычного сообщества Ubuntu


Автор Тема: xubuntu 7.04 на ноуте HP510  (Прочитано 1070 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн atz2085

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
xubuntu 7.04 на ноуте HP510
« : 20 Июнь 2007, 16:58:57 »
Q: плохо выглядят шрифты.
A: так происходит из-за того, что ubuntu ставит 1280x768 вместо 1280x800. Лечится подключением дополнительных репозиториев и установкой пакета 915resolution: пакет делает временный хак, до того, как проблему поправят концептуально.

Q: не работает тачпад.
A: это баг в ядре дистрибутивного диска, обновитесь из интернета. На момент написания статьи пофиксенное и скомпилённое ядро было доступно на сайте одного из разработчиков: http://use.perl.org/%7Edgl/journal/33263

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: xubuntu 7.04 на ноуте HP510
« Ответ #1 : 20 Июнь 2007, 17:04:44 »
Лечится подключением дополнительных репозиториев и установкой пакета 915resolution: пакет делает временный хак, до того, как проблему поправят концептуально.
Все нужные репозитории в 7.04 подключены по умолчанию, ЕМНИП. Более того, проблема уже поправлена концептуально в новом драйвере для графических чипов интель, доступном в репозиториях universe в виде пакета xserver-xorg-video-intel.

Оффлайн atz2085

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: xubuntu 7.04 на ноуте HP510
« Ответ #2 : 20 Июнь 2007, 17:58:45 »
Спасибо!
Снёс 915resolution и поменял xserver-xorg-video-i810 на xserver-xorg-video-intel.
Всё работает, и так оно лучше.
Правда, перестал запускаться gxine (запускается и сразу пропадает, из процессов - тоже). Сижу-разбираюсь...
Ставил новый и сносил старый xserver по-простому: в Synaptic галочку снял и на другой поставил.
ps. знаю команду dmesg | grep something
а как посмотреть, что выдаёт gxine и проверить, насколько корректно поставился новый xserver?

Оффлайн atz2085

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: xubuntu 7.04 на ноуте HP510
« Ответ #3 : 20 Июнь 2007, 18:07:20 »
то-же самое и с tvtime...

Оффлайн atz2085

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: xubuntu 7.04 на ноуте HP510
« Ответ #4 : 20 Июнь 2007, 18:20:47 »
...проверил: глючит только при включенном GL Desktop.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: xubuntu 7.04 на ноуте HP510
« Ответ #5 : 20 Июнь 2007, 18:26:41 »
Можно попробовать погонять разные опции вывода. У меня помнится mplayer при настройках "по умолчанию" тоже отказывался работать, при смене настроек удавалось запустить.

Оффлайн atz2085

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: xubuntu 7.04 на ноуте HP510
« Ответ #6 : 20 Июнь 2007, 19:11:47 »
я понял что, но не знаю - где. GUI-face то он показывает только на секунду, значит, придётся крутить его конфиги.
По ходу ещё кое-что проверил - "концептуально" драйвер intel всё-таки не поправили: он не может работать только при glx, ему нужен параллельно ещё и dri. Иначе рисует абсолютно белый куб. Помнится, у nvidia, если оно работает напрямую (начиная с версии драйвера 8.x), то надо только glx, dri следует отключать. А у интел - надо оба.
Т.е. 3D-ускоренно рисуются только спецэффекты, а содержимое окон - через dri.
Или как-то так (цитировал по памяти).
Весело сменил шило на мыло ). Не то, чтобы мне gxine был уж очень нужен... да и tvtime - тоже... )) Зато повод кучу лишнего видео с харда удалить ))).
А с опциями видеовывод вы правы. Camorama (тоже видеоприложение) работает совершенно нормально. Наверное, я просто подожду апдейты.
Но 1280х800 действительно поправили.

 

Страница сгенерирована за 0.053 секунд. Запросов: 22.