Форум русскоязычного сообщества Ubuntu


Автор Тема: О монтировании ресурсов Samba  (Прочитано 530 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн smart__

  • Автор темы
  • Любитель
  • *
  • Сообщений: 77
    • Просмотр профиля
    • ООО "ИнфоЦентр"
О монтировании ресурсов Samba
« : 21 Июнь 2010, 09:20:50 »
Вопрос назрел неожиданно для самого себя, а именно :: с недавних пор перестали подтыкаться ресурсы, описанные в файле fstab. То сработает, то нет.
Исходные данные для размышлений:
1. Ubuntu 10.04.
2. Сеть (wi-fi) настроена через апплет.
3. Используется CIFS при монтировании.
4. Ядро - 2.6.35-rc3.

Раньше все было без проблем - захожу в учетку, инициализируется соединение с wi-fi, происходит автомонтирование. А теперь почти постоянно приходится выполнять "sudo mount -a". Очень достало, но своими мозгами и гуглами до причины не докопался.
« Последнее редактирование: 21 Июнь 2010, 10:42:49 от smart__ »

Оффлайн sciko

  • Активист
  • *
  • Сообщений: 854
    • Просмотр профиля
Re: О монтировании ресурсов Samba
« Ответ #1 : 21 Июнь 2010, 10:11:08 »
А что в логах?

Оффлайн smart__

  • Автор темы
  • Любитель
  • *
  • Сообщений: 77
    • Просмотр профиля
    • ООО "ИнфоЦентр"
Re: О монтировании ресурсов Samba
« Ответ #2 : 21 Июнь 2010, 10:41:53 »
Мммм, какой именно лог посмотреть? [что-то о них я и не подумал]
Или попарсить dmesg?

Пользователь решил продолжить мысль 21 Июнь 2010, 10:43:15:
Я поправил исходные данные для размышления - забыл указать, что использую CIFS.

Оффлайн sciko

  • Активист
  • *
  • Сообщений: 854
    • Просмотр профиля
Re: О монтировании ресурсов Samba
« Ответ #3 : 21 Июнь 2010, 10:46:40 »
Думаю имеет смысл грепнуть весь /var/log на предмет егогов и варнингов.

Оффлайн smart__

  • Автор темы
  • Любитель
  • *
  • Сообщений: 77
    • Просмотр профиля
    • ООО "ИнфоЦентр"
Re: О монтировании ресурсов Samba
« Ответ #4 : 21 Июнь 2010, 10:51:29 »
Эх-эх-эх, попробую вечером...

Пользователь решил продолжить мысль 21 Июнь 2010, 08:53:54:
Могу добавить на данный момент одно - периодически до появления заставки Ubuntu выкидывает мессаги -- "cifs_mount failed w/return code = -101". Но раньше все монтировалось даже с такими сообщениями. Гугл ответа на ошибку -101 тоже не дал.

Пользователь решил продолжить мысль 21 Июнь 2010, 22:52:29:
Теперь еще лучше -- все шары подтыкаются, но при рестарте\выключении Ubuntu очень надолго задумывается при попытке отмонтирования. Причем если я сделаю "sudo umount -a" до выключения - все проходит гладко.
Причем в /etc/rc[0,6].d/ я повысил номер скрипта отмонтирования выше скрипта выключения сети.
На сладкое - строчка из /etc/fstab: //192.168.1.2/Films /home/smart/mount/films cifs iocharset=utf8,auto,rw,user=Guest,password=guest,uid=1000,gid=1000,_netdev 0 0
« Последнее редактирование: 21 Июнь 2010, 22:52:29 от smart__ »

Оффлайн smart__

  • Автор темы
  • Любитель
  • *
  • Сообщений: 77
    • Просмотр профиля
    • ООО "ИнфоЦентр"
Re: О монтировании ресурсов Samba
« Ответ #5 : 19 Июль 2010, 17:17:59 »
Так никто и не придумал ответа, видимо...

 

Страница сгенерирована за 0.066 секунд. Запросов: 23.