Форум русскоязычного сообщества Ubuntu


Автор Тема: Автозагрузка в 10.04 - скрипт alsactl  (Прочитано 1849 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн syrink

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
  • ...and again, and again, and...
    • Просмотр профиля
Чтобы у меня корректно работал звук (наушники/колонки), приходится писать каждый раз alsactl restore - из однажды сохраненных параметров, поскольку gamix роняет ползунок при перезагрузке. Каким образом можно автоматизировать ввод команды alsactl restore при загрузке? Стандартный запуск приложений что-то не работает.
Once upon a time, far far away...

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2225
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Re: Автозагрузка в 10.04 - скрипт alsactl
« Ответ #1 : 22 Июня 2010, 20:30:45 »
впиши эту команду в /etc/rc.local до exit 0
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн syrink

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
  • ...and again, and again, and...
    • Просмотр профиля
Re: Автозагрузка в 10.04 - скрипт alsactl
« Ответ #2 : 23 Июня 2010, 11:47:42 »
Не помогло. Другие команды исполняются, а alsactl restore не хочет. Чем эта команда особенная?

P.S>я правильно все делаю?
Once upon a time, far far away...

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2225
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Re: Автозагрузка в 10.04 - скрипт alsactl
« Ответ #3 : 23 Июня 2010, 13:35:11 »
Да, написано верно.
Хм, странно.
Так, может тогда перед alsactl restore добавить sleep 15.

sleep 15
alsactl restore
exit0

Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн syrink

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
  • ...and again, and again, and...
    • Просмотр профиля
Re: Автозагрузка в 10.04 - скрипт alsactl
« Ответ #4 : 23 Июня 2010, 15:24:50 »
Сейчас попробую и отпишусь.
------------------------------------------
Нет, не помогло. Думаю, дело в команде... Но странно то, что когда просто руками я запускаю терминал и ввожу alsactl restore - все работает, а когда пихаю в автозагрузку - не работает.
« Последнее редактирование: 23 Июня 2010, 15:32:25 от syrink »
Once upon a time, far far away...

 

Страница сгенерирована за 0.058 секунд. Запросов: 23.