Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Соединение появляется через раз - ошибка: No pppd is running. None stopped.  (Прочитано 1593 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн John2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Суть проблемы: при запуске системы Ubuntu 10.04 LTS, соединение с локальной сетью появляется через раз - как повезёт. Воспользовался советами из этой темы: https://forum.ubuntu.ru/index.php?topic=62589.0
Применил некоторые команды оттуда. Вот результат:
(Нажмите, чтобы показать/скрыть)
Как видно из этого ответа: /usr/bin/poff: No pppd is running.  None stopped.
что-то не так с pppd. Подскажите, пожалуйста, как можно решить проблему?
Заранее благодарен!

Оффлайн censor

  • Старожил
  • *
  • Сообщений: 1126
    • Просмотр профиля
cat /etc/network/interfaces

Оффлайн Application

  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля

Оффлайн John2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Спасибо за ответы! Докладываю:
cat /etc/network/interfaces
Файл interfaces редактировал сам по описанию одного из пользователей нашего провайдера:
auto lo
 iface lo inet loopback
 up route add -net 10.0.0.0/8 gw 10.0.145.254
 up route add -net 192.168.0.0/16 gw 10.0.145.254
 up route add -net 172.16.0.0/12 gw 10.0.145.254
 up route -host 195.69.244.2 gw 10.0.145.254
 

 auto tunnel
 iface tunnel inet ppp
 provider onet
Вопрос прежде всего в том, что выход (на локальный сайт, к примеру) или есть или нет.
То есть,  если говорить простыми словами - на панели сверху показан значок в виде двух стрелочек, можно смело запускать скрипты по VPN соединению - работать точно будет.
А если выдаёт "No network connection" - то пытаться включать бесполезно.

ps |grep pp
Из этого честно говоря ничего не понял - но попытался выполнить. Результат:john@john-desktop:~$ sudo ps |grep pp
john@john-desktop:~$ sudo pon onet
john@john-desktop:~$ sudo /etc/init.d/networking restart
 * Reconfiguring network interfaces...                          /usr/bin/poff: No pppd is running.  None stopped.
Ignoring unknown interface eth0=eth0.
Что далее делать - никак не доходит.

Оффлайн Application

  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
ps - выводит процессы запущеный, как диспечер задач в винде, а |grep pp делает фильтрацию на все процессы, в которых встречается рр.... у тя не запускается демон pppd, это раз, во вторых, у тя в конфиге с интерфейсами, нету локального, как я понял он в NM у тебя записан???? если так, то глянь настрйоки сети в NM....

Оффлайн censor

  • Старожил
  • *
  • Сообщений: 1126
    • Просмотр профиля
1. я бы не стал совмещать настройку сети из interfaces и NetworkManager, либо то либо другое.
2. впн соединение настроено в interfaces соответственно при перезапуске сети скрипт пытается отключить все интерфейсы в том числе и не запущенный iface .... ppp

чтобы ошибка больше не появлялась, можешь убрать конфиг впн из intarfaces и настроить через NetworkManager

и убери этот ужас
 up route add -net 10.0.0.0/8 gw 10.0.145.254
 up route add -net 192.168.0.0/16 gw 10.0.145.254
 up route add -net 172.16.0.0/12 gw 10.0.145.254
 up route -host 195.69.244.2 gw 10.0.145.254
если действительно есть необходимость в этох маршрутах, напиши нормальный скрипт и сохрани его в /etc/network/if-up.d/

Оффлайн Application

  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
вообще NM конкретная хрень! вчера снёс его и настроил через interface, как часы всё работает)

Оффлайн John2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Всем спасибо за ответы!

Вобщем, проблема похоже решена. Необходимо было как следует настроить Auto eth0 через Network Connections. Вкладка Wired -> Auto eth0 -> Editing Auto eth0 -> IPv4 Settings -> Method: Manual - здесь конкретно указал :
IP address
Netmask
Gateway
и
DNS servers

После этого устанавливается соединение через скрипт по созданию впн соединения. Однако даже с этими настройками, иногда этот скрипт зависал. Тогда я вместо "Method: Manual" ставил "Method: Automatic (DHCP)" - тогда снова работало.
Со временем бывало снова пропадало. Тогда вновь ставил "Method: Manual".
Как бы там ни было - интернет вроде работает.

« Последнее редактирование: 05 Июля 2010, 15:08:24 от John2 »

 

Страница сгенерирована за 0.089 секунд. Запросов: 23.