Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не могу запустить Вэб-интерфейс Deluge  (Прочитано 5815 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ___WereMax___

  • Автор темы
  • Участник
  • *
  • Сообщений: 200
  • Бубен -самая нужная вещь СИС-админа
    • Просмотр профиля
Стоит Deluge 1.3.0-rc1 с графической оболочкой, хочу, чтобы была еще плюсом и вэб-интерфейс.

При вводе в терминале deluge --ui web:
пишет:
[ERROR   ] 10:16:42 config:427 Error backing up old config..И так стоит..

В графической оболочке:
В разделе WebUI ставлю галочки, меняю порт, нажимаю применить, закрываю..... Потом опять захожу в параметры и вижу, что мои изменения не применились (как ни одна галочка не стояла, так и не стоит и порт 8112).

В чем проблема?

Оффлайн Sam Stone

  • Старожил
  • *
  • Сообщений: 1129
    • Просмотр профиля
Re: Не могу запустить Вэб-интерфейс Deluge
« Ответ #1 : 03 Июля 2010, 11:15:40 »
Пакет deluge-web установлен?
Jellyfish 5.19.0-43-generic

Оффлайн ___WereMax___

  • Автор темы
  • Участник
  • *
  • Сообщений: 200
  • Бубен -самая нужная вещь СИС-админа
    • Просмотр профиля
Re: Не могу запустить Вэб-интерфейс Deluge
« Ответ #2 : 03 Июля 2010, 12:05:55 »
да, пакет deluge-web установлен.

wolfpr

  • Гость
Re: Не могу запустить Вэб-интерфейс Deluge
« Ответ #3 : 03 Июля 2010, 16:02:10 »
Удали папку с старыми настройками!! Она лежит в /home/{твой пользователь}/.config/
У меня она здесь /home/pavel/.config/
Удалишь папку Deluge!! Может заработает!!!

Оффлайн ___WereMax___

  • Автор темы
  • Участник
  • *
  • Сообщений: 200
  • Бубен -самая нужная вещь СИС-админа
    • Просмотр профиля
Re: Не могу запустить Вэб-интерфейс Deluge
« Ответ #4 : 03 Июля 2010, 16:12:52 »
Удали папку с старыми настройками!! Она лежит в /home/{твой пользователь}/.config/
У меня она здесь /home/pavel/.config/
Удалишь папку Deluge!! Может заработает!!!

Удалил - не заработало  :'( :'(
Но я заметил, что порт он оставил тот же, что и был до удаления... я так понимаю, что это может означать, что настройку WebUI он хранит где-то в другом месте, только вот где?

Оффлайн Sam Stone

  • Старожил
  • *
  • Сообщений: 1129
    • Просмотр профиля
Re: Не могу запустить Вэб-интерфейс Deluge
« Ответ #5 : 03 Июля 2010, 17:09:06 »
man deluge
deluge --ui=webПотом через браузер цепляться на нужный порт.
Jellyfish 5.19.0-43-generic

wolfpr

  • Гость
Re: Не могу запустить Вэб-интерфейс Deluge
« Ответ #6 : 03 Июля 2010, 19:44:55 »
Если не пойдет как говорил Sam Stone. 
У  меня на версии 1.2.3 запускается командой deluge-web. 

Если и так не пойдет. То попробуй зайти в настройки deluge и на вкладке интерфейс убрать галочку классический. потом перегрузи в deluge.  Это свойство означает запуск демон. Потом опять командой deluge-web.  потомо пробуй  зайти http://localhost:8112!!  Так  вроди должен заработать!!

Ну а вообще!! я так понимаю ты хочешь управлять загрузками через инет или сеть!! web инетерфейс не лучший вариант( по крайней мере в версии 1.2.3) если будешь управлять через инет, т.к. до версии 1.2 был простым и легким (мало весил), а после он стал весить 3мб. т.е. после перехода по адресу тебе придеться загрузить станицу размером 3мб. тем более он не очень работает круто. хотя поставленные задачи выполняет!!.
Не знаю как обстоят дела в новой версии.
Вообще я эту проблемму решел управление делюгом через делюг. Вообщем если надо пиши в асю или в личку!!
« Последнее редактирование: 03 Июля 2010, 20:23:13 от wolfpr »

Оффлайн ___WereMax___

  • Автор темы
  • Участник
  • *
  • Сообщений: 200
  • Бубен -самая нужная вещь СИС-админа
    • Просмотр профиля
Re: Не могу запустить Вэб-интерфейс Deluge
« Ответ #7 : 04 Июля 2010, 10:41:07 »
сама цель всего этого:
1 пока поднять у меня на компе все это, чтобы работала и графика и вэб.
2 в небольшой домашней локалке стоит сервер (через него мы в инет ходим), он всегда в сети... хочу сделать общий торрент для всех в локали, чтобы зря 4 компа не работали дабы раздавать, а только итак включенный сервер.

итак чего я добился:
1 все галочки ставь - не ставь и порты меняй-не меняй, после нажатия ок и применять, закрываю, потом открываю параметры, а там все как было до этого....короче ничего не применяется...
2 понял, что команды deluge --ui=web и deluge-web - одно и тоже, так как выдают одни и те же ошибки.
3 при запушенной графике после ввода этих команд ничего не происходит.... просто моргает курсор ввода (строки Я@Моя компа:~$ не появляеться) и при переходе га адрес http://localhost:8112 - сразу ошибка.
4 при убитой графикепри переходе на адрес ОПЕРА стоит "вечно" и отправляет запрос на локалхост и все, а после ввода команд старта вэб интерфейса вылетает следующее:
(Нажмите, чтобы показать/скрыть)

Видимо порт чем-то занят, но чем? - хз, если опера на него не коннектиться... и сканирование портов говорит, что этот порт "бездействует" - мистика!!

А... ну еще маленькая проблемка... почти по теме))) у меня этот Делуж после перезапуска "теряет" метки у пары раздач и несколько постоянно перепроверяет.... тож не понятно че с ним?
« Последнее редактирование: 04 Июля 2010, 10:44:11 от ___WereMax___ »

 

Страница сгенерирована за 0.045 секунд. Запросов: 23.