Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: SAMBA - права доступа  (Прочитано 17660 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн afis

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
SAMBA - права доступа
« : 07 Июля 2010, 05:40:53 »
Не могу настроить доступ к расшаренным папкам.
1) Изначально стоит security = share. В папку с guest ok = yes можно зайти и делать что угодно. Если guest ok = no, то зайти можно под определённым юзером. Создавал учётные записи для SAMBA - под ними заходит. Под моей рабочей - нет. И если защёл, то всё только для чтения! Ничего не могу удалить (writeble естественно = yes). Шары отличаются только guest ok. Как мне сделать авторизованный доступ с полными правами?
2) Win7 хотя бы предлагает ввести логин пароль, XP - вообще говорит что нет доступа для папки с guest ok =no. С чем это может быть связано?
3) Как пользователя-то сменить? Я вхожу с виндовой машини на шару и не могу перевойти под пругой записью.
4) При установке security = user машини, уже вошедшие в шару, свободно читают шару. При попытке перейти вверх на машину (напр. \\MyComp или \\192.168.0.11) требует логин/пароль (чот и ожидалось), но не принимает ВООБЩЕ ни одну учётную запись! Зато можно вернуться в папку шары (например \\MyComp\Docs) и продолжить работать!

Я уже третий день параметры и так и этак меняю, не могу добиться нужного функционала! С этими правами директорий, кучей настроек... такое ощущение, что строешь карточный домик.

Оффлайн dima81

  • Активист
  • *
  • Сообщений: 378
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #1 : 12 Июля 2010, 23:37:22 »
Ситуация почит аналогичная, вначале не виделись шары. Решилось сутановкай IP в автоматический режим и переименованием группы на свою  HOME. Теперь хотя бы Windows и Ubuntu стали видеть шары друг друга, так же можно с них переписывать файлы, а вот записать нельзя. Непонимаю почему.
Прикладываю конфиг настройки самбы:
(Нажмите, чтобы показать/скрыть)
xubuntu 14.04.3
nout Lenovo B590

Оффлайн censor

  • Старожил
  • *
  • Сообщений: 1126
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #2 : 12 Июля 2010, 23:53:37 »
да прекратите вы уже засирать форум комментариями в конфигах юзайте
sed -r "/^([#;]|$)/d" /etc/samba/smb.conf
« Последнее редактирование: 13 Июля 2010, 00:15:19 от censor »

Оффлайн afis

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #3 : 13 Июля 2010, 02:48:07 »
Мне ничего не пришлось менять в установке IP. Да и странно это. Совсем разные задачи. К тому же  меня кагбэ сервер, ему положено статический IP иметь. После запуска машины у меня тоже шары не работали. Всё решилось перезапуском самбы - добавил пару строк в /etc/rc.local:
sleep 20
service smbd restart

Проблема в том, что мне надо иметь и свободные шары (без залогинивания, с полным доступом) и закрытые. Не получается настроить.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28381
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #4 : 13 Июля 2010, 03:39:19 »
да прекратите вы уже засирать форум комментариями в конфигах юзайте
sed -r "/^([#;]|$)/d" /etc/samba/smb.conf

Зачем это? testparm достаточно.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн censor

  • Старожил
  • *
  • Сообщений: 1126
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #5 : 13 Июля 2010, 06:52:39 »
да прекратите вы уже засирать форум комментариями в конфигах юзайте
sed -r "/^([#;]|$)/d" /etc/samba/smb.conf

Зачем это? testparm достаточно.
для самбы да, а другие конфиги?
« Последнее редактирование: 13 Июля 2010, 07:03:02 от censor »

Оффлайн dima81

  • Активист
  • *
  • Сообщений: 378
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #6 : 13 Июля 2010, 07:05:34 »
Обьясните пожалуйста чем отличается добавление шары через наутилус по правой клавише (общий доступ и т.д.- в конфиге самбы её не появляется !!!) и прописывание шары непосредственно в конфиге самбы.

Зачем два разных пути создания шар? Как правильно создавать шары?

ЗЫ: форум уже облазил и гуглил
xubuntu 14.04.3
nout Lenovo B590

Оффлайн censor

  • Старожил
  • *
  • Сообщений: 1126
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #7 : 13 Июля 2010, 07:12:45 »
чтобы изменить основной конфиг, нужны права root, наутилус запускается от имени обычного пользователя и для расшаривания используется команда доступная непривилегированному пользователю
net usershare add
еще для настройки шар может использоваться команда
net share
но для ее работы в основном конфиге должны быть опции
include registry
registry shares = Yes
« Последнее редактирование: 13 Июля 2010, 07:14:47 от censor »

Оффлайн dima81

  • Активист
  • *
  • Сообщений: 378
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #8 : 13 Июля 2010, 07:23:16 »
У меня имеются 2 папки.
1-я вписана в smb.conf
вот что говорит testparm /etc/samba/smb.conf
(Нажмите, чтобы показать/скрыть)
Вот что записано в конфиге для папки temp_ubuntu:
(Нажмите, чтобы показать/скрыть)

В винде XP папка temp_ubuntu видна и открывается, но записать в неё ничего нельзя.


Для 2-й папки (torrent) через наутилус в общем доступе включено: опубликовать, изменять файлы, гостевой доступ.
В винде XP папка torrent  видна, открывается и в неё спокойно можно копировать файлы.

Вчем прикол то?
« Последнее редактирование: 13 Июля 2010, 07:27:06 от dima81 »
xubuntu 14.04.3
nout Lenovo B590

Оффлайн censor

  • Старожил
  • *
  • Сообщений: 1126
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #9 : 13 Июля 2010, 07:29:02 »
/etc/samba/smb.conf
[global]
   workgroup = WORKGROUP
   server string = %h server
   include = /etc/samba/dhcp.conf
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   security = share
   registry shares = yes
   include = registry
   encrypt passwords = true
   guest account = ftp
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
[homes]
   comment = Home Directories
   browseable = no
   read only = yes
   create mask = 0700
   directory mask = 0700
   valid users = %S
[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = yes
   read only = yes
   create mask = 0700
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = yes

net conf list
[public]
path = /home/samba/pubic/
comment = Общий каталог
guest ok = yes
read only = no
browseable = yes
directory mask = 1777
create mask = 1777


Оффлайн dima81

  • Активист
  • *
  • Сообщений: 378
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #10 : 15 Июля 2010, 17:22:59 »
Не даёт записать в папку ничего, ничего уже не понимаю.

[seti]
path = /mnt/work/test_seti
        comment = Общий каталог
guest ok = yes
read only = no
browseable = yes
directory mask = 1777
create mask = 1777

Пишет:
Отказано в доступе
« Последнее редактирование: 15 Июля 2010, 19:04:32 от dima81 »
xubuntu 14.04.3
nout Lenovo B590

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28381
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #11 : 15 Июля 2010, 19:14:10 »
Кто пишет? Как подключаешь каталог к чему?
testparm где?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн dima81

  • Активист
  • *
  • Сообщений: 378
    • Просмотр профиля
Re: SAMBA - права доступа
« Ответ #12 : 15 Июля 2010, 21:20:15 »
Ну как бы на 3 поста выше testparam есть, привожу еще раз:
(Нажмите, чтобы показать/скрыть)

Пытаюсь скопировать файл в папку (в ubuntu - на ней же эта папка и находится), в nautilus:
Сеть - Сеть Windows - WORKGROUP - NOUT - seti
Пишет: Отказано в доступе

В винде установленной в VBOX, при копировании в эту же папку пишет:
Нет доступа или файл уже используется.


Расшаренная папка в наутилусе (по правой клавише - открыть общий доступ и запись файлов, как то так)  видна в винде и в неё можно копировать, но она на отображается в smb.conf --- так и должно быть?

ЗЫ: Не обращайте внимания, что так странно создаю сеть между виртуалкой. Просто учусь настраивать шары.
        
xubuntu 14.04.3
nout Lenovo B590

 

Страница сгенерирована за 0.047 секунд. Запросов: 23.