Форум русскоязычного сообщества Ubuntu


Автор Тема: VirtualBox требует libcurl.so.4  (Прочитано 5308 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн P1tBull

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
VirtualBox требует libcurl.so.4
« : 09 Августа 2010, 18:06:14 »
После неудачных экспериментов с OpenLdap в системе перестал запускаться VirtualBox.
Цитировать
sudo VirtualBox
VirtualBox: Error -610 in supR3HardenedMainInitRuntime!
VirtualBox: dlopen("/usr/lib/virtualbox/VBoxRT.so",) failed: libcurl.so.4: cannot open shared object file: No such file or directory

VirtualBox: Tip! It may help to reinstall VirtualBox.
Где найти эту библиотеку?
Ubuntu 10.04

Оффлайн Renaissance

  • Старожил
  • *
  • Сообщений: 2121
    • Просмотр профиля
Re: VirtualBox требует libcurl.so.4
« Ответ #1 : 09 Августа 2010, 18:07:23 »
Synaptic.
Цитировать
VirtualBox: Tip! It may help to reinstall VirtualBox.
Это не для прикола написано.

Оффлайн P1tBull

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: VirtualBox требует libcurl.so.4
« Ответ #2 : 09 Августа 2010, 18:15:59 »
нехочет он переставлять без этих библиотек.
Цитировать
dpkg -i virtualbox-3.2_3.2.8-64453~Ubuntu~lucid_amd64.deb
(Reading database ... 139199 files and directories currently installed.)
Preparing to replace virtualbox-3.2 3.2.8-64453~Ubuntu~lucid (using virtualbox-3.2_3.2.8-64453~Ubuntu~lucid_amd64.deb) ...
Unpacking replacement virtualbox-3.2 ...
dpkg: dependency problems prevent configuration of virtualbox-3.2:
 virtualbox-3.2 depends on libcurl3 (>= 7.16.2-1); however:
  Package libcurl3 is not installed.
 virtualbox-3.2 depends on libqt4-opengl (>= 4:4.5.3); however:
  Package libqt4-opengl is not installed.
dpkg: error processing virtualbox-3.2 (--install):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for desktop-file-utils ...
Processing triggers for python-support ...
Errors were encountered while processing:
 virtualbox-3.2
Цитировать
apt-get install libcurl3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  virtualbox-3.2: Depends: libqt4-opengl (>= 4:4.5.3) but it is not going to be installed
                  Recommends: libsdl-ttf2.0-0 but it is not going to be installed
                  Recommends: pdf-viewer
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Пользователь решил продолжить мысль 09 Августа 2010, 18:33:59:
оказываться надо было все сразу ставить.
Цитировать
sudo apt-get install libcurl3 libqt4-opengl
и все обратно стало запускаться )
« Последнее редактирование: 09 Августа 2010, 18:33:59 от P1tBull »

 

Страница сгенерирована за 0.04 секунд. Запросов: 23.