Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Падает скорость на интерфейсах  (Прочитано 1951 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн coolman

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
  • :)
    • Просмотр профиля
Падает скорость на интерфейсах
« : 14 Августа 2010, 22:40:33 »
Ubuntu 10.04 server  через какой-то промежуток времени падает скорость на локальном интерфейсе
при перезапуске
 /etc/init.d/networking restart
все ок становится,

Мне сказали какой-то толи буфер переполняется, или очередь, подскажите как его очищать(команду хоть в cron добавлю), если такое имеет место быть.
Памяти на сервере 8 гиг, используется в основном не больше гига.
На всяк случай настройки которые менял:

(Нажмите, чтобы показать/скрыть)


в инет выхожу так:

iptables -t nat -A POSTROUTING -s $NETWORK -o $OUT -j MASQUERADE
iptables -t filter -A FORWARD -s 192.168.0.2 -o $OUT -j ACCEPT
« Последнее редактирование: 14 Августа 2010, 22:47:30 от coolman »
iptables

Оффлайн Sam Stone

  • Старожил
  • *
  • Сообщений: 1129
    • Просмотр профиля
Re: Падает скорость на интерфейсах
« Ответ #1 : 15 Августа 2010, 11:34:06 »
После падения скорости последние строк 30-50 из сислога покажи.
Jellyfish 5.19.0-43-generic

Оффлайн coolman

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
  • :)
    • Просмотр профиля
Re: Падает скорость на интерфейсах
« Ответ #2 : 15 Августа 2010, 13:57:18 »
После падения скорости последние строк 30-50 из сислога покажи.
логи почистил, в крон поставил  /etc/init.d/networking restart
каждые 6 часов, вроде все ок
Есть какие-нибудь предположения?

iptables

Оффлайн Sam Stone

  • Старожил
  • *
  • Сообщений: 1129
    • Просмотр профиля
Re: Падает скорость на интерфейсах
« Ответ #3 : 15 Августа 2010, 14:02:20 »
в таком случае это свет венеры отражается от верхних слоев атмосферы и блокирует доступ в инет.
Jellyfish 5.19.0-43-generic

Оффлайн coolman

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
  • :)
    • Просмотр профиля
Re: Падает скорость на интерфейсах
« Ответ #4 : 18 Августа 2010, 09:01:28 »
в таком случае это свет венеры отражается от верхних слоев атмосферы и блокирует доступ в инет.
я так и знал,  может это все пришельцы?
 вот кстати чтото похожее:
https://forum.ubuntu.ru/index.php?topic=72783.0

eth0 в инет
eth1 в локалку
одна 100 другая на гиг, не помню какая из них )
 вот в логах у меня
(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль 18 Августа 2010, 19:37:39:
короче в логах на эту тему ни чего нету, но я заметил, это происходит по вечерам когда очень много подключений, или если торрент включеным подержать какое-то время

« Последнее редактирование: 19 Августа 2010, 13:13:47 от coolman »
iptables

Оффлайн coolman

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
  • :)
    • Просмотр профиля
Re: Падает скорость на интерфейсах
« Ответ #5 : 20 Августа 2010, 09:33:58 »
(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль 20 Августа 2010, 09:42:36:
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 20 Августа 2010, 09:42:36 от coolman »
iptables

Оффлайн MaratSh

  • Участник
  • *
  • Сообщений: 204
  • Всё пройдёт...
    • Просмотр профиля
Re: Падает скорость на интерфейсах
« Ответ #6 : 20 Августа 2010, 09:59:08 »
А патч-корды/розетки/сетевые карты в порядке?

Оффлайн coolman

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
  • :)
    • Просмотр профиля
Re: Падает скорость на интерфейсах
« Ответ #7 : 23 Августа 2010, 16:43:01 »
А патч-корды/розетки/сетевые карты в порядке?

да вроде нормально, главное это случается с переменным успехом
ifconfig

eth0      Link encap:Ethernet  HWaddr******
          inet addr:*****  Bcast:******  Mask:*****
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31972990 errors:0 dropped:0 overruns:0 frame:0
          TX packets:34015045 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1401662343 (1.4 GB)  TX bytes:1399323130 (1.3 GB)
          Interrupt:18
не вижу аномалий, голову уже сломал, пинг кстати подпрыгивает до шлюза,с 1 до 16 в этот момент, а иногда пинг норм, а скорость все равно маленькая, провайдер говорит что у них все ок

ping **** -i 0.01 -c 200 -s 1300
200 packets transmitted, 200 received, 0% packet loss, time 1986ms
rtt min/avg/max/mdev = 2.500/8.767/16.793/4.179 ms, pipe 2
« Последнее редактирование: 23 Августа 2010, 16:45:55 от coolman »
iptables

Оффлайн mikinik

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Падает скорость на интерфейсах
« Ответ #8 : 07 Сентября 2010, 01:57:42 »
тоже самое на 10.04 десктопной :(

Оффлайн mikinik

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Падает скорость на интерфейсах
« Ответ #9 : 09 Сентября 2010, 03:52:21 »
обновил ядро до 2.6.35, теперь все в норме, скорость не падает.  :D

 

Страница сгенерирована за 0.035 секунд. Запросов: 23.