Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Проблема с Creative Sound Blaster X-Fi Audio  (Прочитано 7436 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Зелёный

  • Автор темы
  • Новичок
  • *
  • Сообщений: 1
  • Зелёный человек
    • Просмотр профиля
Проблема с Creative Sound Blaster X-Fi Audio
« : 26 Июль 2007, 21:37:25 »
Здравствуйте!..
Купил себе аудиокарту Creative Sound Blaster X-Fi Audio. Проблема в том, что архитектура ALSA для неё не подходит. :'( А на официальном сайте драйверов под Linux нет. Может быт есть какое-нибудь решение этой проблемы?.. Заранее спасибо.

Оффлайн andrew_bye

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 2698
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #1 : 06 Октябрь 2007, 20:51:34 »
Проблема с аудиокартой Creative Sound Blaster X-Fi AudioExtreme Audio в Kubuntu 7.04 решается следующим образом:
1. С http://www.alsa-project.org/ нужно скачать alsa-driver-1.0.14 (это файл alsa-driver-1.0.14.tar.bz2).
2. Распаковываем вышеуказанный архив (например, кликнув правой кнопкой мыши по файлу и выбрав в контекстном меню: Распаковать->Распаковать в эту папку), в результате должна образоваться папка alsa-driver-1.0.14
3. Запускаем терминал (K Menu->Система->Консоль (Терминал)), в котором набираем следующие команды:
sudo apt-get install linux-headers-`uname -r` build-essential gcc
cd путь к папке alsa-driver-1.0.14.
./configure
make
sudo make install
sudo ./snddevices
4. После окончания всех процедур в терминале выполняем перезагрузку системы.

После перезагрузки системы должен появиться звук. Если звук не появился, то необходимо кликнуть по значку Громкость (находится в Системном лотке), далее кликнуть в Микшер и выставить уровни громкости (возможно они будут стоять на нуле), а также на вкладке Выключатели кликнуть по точке напротив IEC958, если она желтого, а не болотно-зеленого цвета.

Буду надеяться, что мой совет помог :)

Оффлайн Fliker-09

  • Активист
  • *
  • Сообщений: 338
  • Linux rocks and KDE too!
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #2 : 15 Октябрь 2007, 12:42:35 »
Просто суперский ответ! Я не думал что такая карта может работать под линухой. Но у меня есть вопрос. Работает ли после всех этих махинаций аппаратное ускорение звука?

Оффлайн SeaJey

  • Активист
  • *
  • Сообщений: 770
  • Electronic Knight
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #3 : 15 Октябрь 2007, 15:08:21 »
Ещё драйвер oss-linux её держит.
Цитировать
Работает ли после всех этих махинаций аппаратное ускорение звука?
Простой ответ - посмотри, попробуй, сообщи о впечатлениях :)
Но как-то терзают меня смутные сомнения...

Оффлайн Fliker-09

  • Активист
  • *
  • Сообщений: 338
  • Linux rocks and KDE too!
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #4 : 16 Октябрь 2007, 17:31:01 »
Ну попробовать не получатся потому что данной картишки у меня нету, я просто подумываю о её покупке ;).

Оффлайн andrew_bye

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 2698
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #5 : 26 Октябрь 2007, 01:09:28 »
Цитировать
не думал что такая карта может работать под линухой
X-Fi Extreme Audio работает под Линукс по той простой причине, что собственно говоря X-Fi'ем и не является. Данная карта по своей сути есть подшаманеный Sound Blaster Audigy SE, который поддерживается ALSA.
Цитировать
Работает ли после всех этих махинаций аппаратное ускорение звука?
Судя по всему работает, поскольку у меня в Open Arena проблем с подтормаживанием звука не возникало.

Оффлайн KurtCobainUfa

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #6 : 28 Октябрь 2007, 22:47:21 »
Проблема с аудиокартой Creative Sound Blaster X-Fi AudioExtreme Audio в Kubuntu 7.04 решается следующим образом:
1. С http://www.alsa-project.org/ нужно скачать alsa-driver-1.0.14 (это файл alsa-driver-1.0.14.tar.bz2).
2. Распаковываем вышеуказанный архив (например, кликнув правой кнопкой мыши по файлу и выбрав в контекстном меню: Распаковать->Распаковать в эту папку), в результате должна образоваться папка alsa-driver-1.0.14
3. Запускаем терминал (K Menu->Система->Консоль (Терминал)), в котором набираем следующие команды:
sudo apt-get install linux-headers-`uname -r` build-essential gcc
cd путь к папке alsa-driver-1.0.14.
./configure
make
sudo make install
sudo ./snddevices
4. После окончания всех процедур в терминале выполняем перезагрузку системы.

После перезагрузки системы должен появиться звук. Если звук не появился, то необходимо кликнуть по значку Громкость (находится в Системном лотке), далее кликнуть в Микшер и выставить уровни громкости (возможно они будут стоять на нуле), а также на вкладке Выключатели кликнуть по точке напротив IEC958, если она желтого, а не болотно-зеленого цвета.

Буду надеяться, что мой совет помог :)

Все делал как указано только к lsa-driver-1.0.15
После команды udo apt-get install linux-headers-`uname -r` build-essential gcc  вывел мне
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Уже установлена самая новая версия linux-headers-2.6.22-14-generic.
E: Не удалось найти пакет build-essential

после ./configure выдал
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

make ------>

make all-deps
make[1]: Entering directory `/home/rustik/alsa-driver-1.0.15'
make[1]: Nothing to be done for `all-deps'.
make[1]: Leaving directory `/home/rustik/alsa-driver-1.0.15'

Please, run the configure script as first...

sudo make install ---->

i
f [ -L /include/sound ]; then \
                rm -f /include/sound; \
                ln -sf /home/rustik/alsa-driver-1.0.15/include/sound /include/sound; \
        else \
                эрэм эрэф /include/sound; \
                install -d -m 755 -g root -o root /include/sound; \
                for f in include/sound/*.h; do \
                        install -m 644 -g root -o root $f /include/sound; \
                done \
        fi
install: cannot stat `include/sound/*.h': No such file or directory
make: *** [install-headers] Error 1
sudo ./snddevices ----->

Creating mixer?...done.
Creating sequencer...done.
Creating midi0?...done.
Creating dsp?...done.
Creating audio?...done.
Creating sndstat...done.
Creating music...done.
Creating dmmidi?...done.
Creating dmfm?...done.
Creating amixer?...done.
Creating adsp?...done.
Creating amidi?...done.
Creating admmidi?...done.
rm: cannot remove `/dev/snd': Is a directory
Creating snd/control?...done.
Creating snd/seq...done.
Creating snd/timer...done.
Creating snd/hw??...done.
Creating snd/midi??...done.
Creating snd/pcm??p...done.
Creating snd/pcm??c...done.
Creating aload?...done.
Creating aloadSEQ...done.

Далее я перезагрузился через sudo reboot.

А звук не стал ((((. Помогите бедному ламеру в чем касяк ???

Оффлайн SeaJey

  • Активист
  • *
  • Сообщений: 770
  • Electronic Knight
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #7 : 29 Октябрь 2007, 00:36:36 »
Всё просто - пока ./configure не скажет, что всё ОК к make и make install не переходи.

И сначала установи build-essential - тебе просто компилить нечем!
Может у тебя не все репозитории раскомментированы - посмотри в Источниках приложений.
И вообще, почитай о чём здесь люди пишут.

Смотри  фразу, на которую ругнулся конфиг, заходи в synaptic, поиск по полю и названию, вбиваешь имя библиотеки.
Пробегаешься по получившемуся списку, отмечаешь нужный пакет и обязательно пакет с суффиксом -dev

Повторяешь ./configure

Оффлайн KurtCobainUfa

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #8 : 29 Октябрь 2007, 08:13:55 »
СПасибо добрые люди ))))))
ЗЫ Хароший тут народ на форуме

Оффлайн KurtCobainUfa

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #9 : 31 Октябрь 2007, 14:24:05 »
The file /usr/src/linux/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).

Народ как эту проблему решить ?

Оффлайн SeaJey

  • Активист
  • *
  • Сообщений: 770
  • Electronic Knight
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #10 : 31 Октябрь 2007, 19:24:36 »
Зайди в synaptic, поиск по слову linux-headers.
Не знаю какое у тебя ядро используется, устанавливай хидеры на него похожие.

Оффлайн sisxak

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #11 : 21 Ноябрь 2007, 12:21:14 »
Проблема с аудиокартой Creative Sound Blaster X-Fi AudioExtreme Audio в Kubuntu 7.04 решается следующим образом:
1. С http://www.alsa-project.org/ нужно скачать alsa-driver-1.0.14 (это файл alsa-driver-1.0.14.tar.bz2).
2. Распаковываем вышеуказанный архив (например, кликнув правой кнопкой мыши по файлу и выбрав в контекстном меню: Распаковать->Распаковать в эту папку), в результате должна образоваться папка alsa-driver-1.0.14
3. Запускаем терминал (K Menu->Система->Консоль (Терминал)), в котором набираем следующие команды:
sudo apt-get install linux-headers-`uname -r` build-essential gcc
cd путь к папке alsa-driver-1.0.14.
./configure
make
sudo make install
sudo ./snddevices
4. После окончания всех процедур в терминале выполняем перезагрузку системы.

После перезагрузки системы должен появиться звук. Если звук не появился, то необходимо кликнуть по значку Громкость (находится в Системном лотке), далее кликнуть в Микшер и выставить уровни громкости (возможно они будут стоять на нуле), а также на вкладке Выключатели кликнуть по точке напротив IEC958, если она желтого, а не болотно-зеленого цвета.

Буду надеяться, что мой совет помог :)
А есть ли разница KDE GNOME????

Оффлайн andrew_bye

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 2698
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #12 : 22 Ноябрь 2007, 00:47:58 »
Цитировать
А есть ли разница KDE GNOME? ???
В приведенном мною способе разница между KDE и GNOME будет заключатся только в программе-микшере: в KDE это KMix, а в GNOME, если не ошибаюсь, это GNOME ALSA Mixer.

Оффлайн F.l.i.p.i.X

  • Новичок
  • *
  • Сообщений: 35
  • Другие бы нашли смысл, а мы нашли причину...©
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #13 : 15 Март 2008, 14:57:51 »
checking for C compiler default output file name... configure: error: C compiler cannot create executables
какой пакет устраняет именно эту ошибку?
Простите, што не в тему. Спасибо заранее

Оффлайн andrew_bye

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 2698
    • Просмотр профиля
Re: Проблема с Creative Sound Blaster X-Fi Audio
« Ответ #14 : 15 Март 2008, 15:08:57 »
checking for C compiler default output file name... configure: error: C compiler cannot create executables
какой пакет устраняет именно эту ошибку?
Простите, што не в тему. Спасибо заранее

При установке какого именно пакета возникает данная ошибка?

 

Страница сгенерирована за 0.065 секунд. Запросов: 22.