Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: PHP + PHP APC == Apache не переваривает *.php  (Прочитано 1728 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн thunderamur

  • Автор темы
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6849
    • Просмотр профиля
PHP + PHP APC == Apache не переваривает *.php
« : 26 Августа 2010, 11:45:13 »
Собсно, заморочился установкой акселлератора для Битрикса, поставил АРС, настроил его как он просил, попробовал и на те - браузер предложил сохранить скрипт, т.е. апач его не переварил почему-то...

вопрос - что делать то?

возможно из-за того, что у меня стоит пых от Кармика (нужно, чтобы работал Зенд Оптимайзер), а апач от Люсид... пробую поставить и Апач от Кармика.

Оффлайн [DarkNet]Alpha

  • Активист
  • *
  • Сообщений: 987
  • Эмоциональный эльдар
    • Просмотр профиля
    • EBM-радио
Re: PHP + PHP APC == Apache не переваривает *.php
« Ответ #1 : 26 Августа 2010, 11:52:41 »
sudo apt-get install libapache2-mod-php5 libapache2-mod-ruby php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl(https://forum.ubuntu.ru/index.php?topic=25668.0)
У меня после установки этих пакетов заработало нормально.

Оффлайн thunderamur

  • Автор темы
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6849
    • Просмотр профиля
Re: PHP + PHP APC == Apache не переваривает *.php
« Ответ #2 : 26 Августа 2010, 12:59:50 »
т.е. ты тоже ставил APC и у тебя тоже была описанная мной проблема?

просто по ссылке, что ты дал не освещается установка APC.

Пользователь решил продолжить мысль 26 Августа 2010, 18:08:52:
Короче если ставить всё из репозитория Люсид - работает, если же ставить всё (все пакеты апача, все пакеты пыха, только мускуль не ставил старый, т.к. он тут какбе не причём вроде) из Кармика, то вылазит проблема описанная выше. А пых нужен именно от Кармика, т.к. с новым пхп5.3 не умеет работать ЗендОптимайзер, поэтому приходится юзать пхп5.2 из Кармика.

Какие мысли, народ?
« Последнее редактирование: 26 Августа 2010, 18:08:52 от Thunde® »

Оффлайн vanish

  • Любитель
  • *
  • Сообщений: 70
  • Life Is Good
    • Просмотр профиля
Re: PHP + PHP APC == Apache не переваривает *.php
« Ответ #3 : 26 Августа 2010, 18:09:19 »
Странная у вас ситуация. Всегда делаю две вещи 1)aptitude install php-apc 2)в php.ini прописать extension = /путь к apc.so/apc.so И все. После ребута апача бегает как милинький

Оффлайн thunderamur

  • Автор темы
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6849
    • Просмотр профиля
Re: PHP + PHP APC == Apache не переваривает *.php
« Ответ #4 : 26 Августа 2010, 18:12:43 »
Странная у вас ситуация. Всегда делаю две вещи 1)aptitude install php-apc 2)в php.ini прописать extension = /путь к apc.so/apc.so И все. После ребута апача бегает как милинький
таки и у мну также, когда юзаю репозиторий родной для Люсид, а ежели от Кармика, то вот такая байда. Попробуй установить пых5.2 и посмотри что будет, без php-apc, всё работает, после его установки всё - каюк.

Оффлайн agimoura

  • Активист
  • *
  • Сообщений: 325
    • Просмотр профиля
Re: PHP + PHP APC == Apache не переваривает *.php
« Ответ #5 : 26 Августа 2010, 18:19:49 »
Таки давно говорю, поставить готовый настроенный серверный пакет XAMPP и не иметь головных болей с ЛОКАЛЬНЫМ сервером.... И до лампочки - лусид, кармик или что-то там ещё!...  ;)

Оффлайн thunderamur

  • Автор темы
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6849
    • Просмотр профиля
Re: PHP + PHP APC == Apache не переваривает *.php
« Ответ #6 : 26 Августа 2010, 19:53:44 »
я вот посмотрел нет там php-apc, однако есть eAccelerator

хз, мб и правда для локальной работы сойдёт... Только вопрос: он не медленнее работает, чем труЪ установка компонентов по отдельности? А то для меня скорость критична.
« Последнее редактирование: 26 Августа 2010, 19:56:16 от Thunde® »

 

Страница сгенерирована за 0.055 секунд. Запросов: 23.