Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Проблемы с dnsmasq на Ubuntu 7.04  (Прочитано 1330 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jadio

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Проблемы с dnsmasq на Ubuntu 7.04
« : 31 Июль 2007, 12:45:43 »
Здравствуйте.

Сразу прошу простить за ламерство. Прочитал на оф. сайте, что Ubuntu — для всех, поэтому начал её использовать. По соглашению с разработчиком, имею право на ламерство :) Надеюсь и тут не осудят.

Поднял шлюз таким образом:
1. eth1 — локальная сеть провайдера, статический ip (10.100.1.12, mask 255.255.0.0, gateway 10.100.0.1), интернет по PPPoE (через pppoeconf);
2. eth0 — домашняя сеть (ip 192.168.0.1, mask 255.255.255.0);
3. установил ipmasq и dnsmasq (sudo art-get install ipmasq dnsmasq);
4. подключил комп под WinXP к eth0, настроил на нем сеть (ip 192.168.0.101 mask 255.255.255.0 gateway 192.168.0.1 dns 192.168.0.1).

В итоге на ubuntu работает интернет полноценно, а на XP одни сайты открываются, а другие нет (XP голая, никаких фаерволов и пр.)? а то и те, что открывались перестают открываться.

PPPoE создается на ubuntu при загрузке. DNS оказывается почему-то 127.0.0.1. Делаю sudo poff dsl-provider, pon dsl provider — появляются нормальные dns`ы (10.100.0.5 и 80.224.244.250). Может это имеет отношение к делу.

Пожалуйста, помогите конкретными рекомендациями.
 
P.S. В "Поиске" решения не нашёл. Если неправильно ищу, посоветуйте как правльно, пожалуйста.
« Последнее редактирование: 01 Август 2007, 21:56:20 от jadio »

Оффлайн keir

  • Новичок
  • *
  • Сообщений: 41
  • Аватара из мос. зоопарка :)
    • Просмотр профиля
Попробуйте dnsmask заменить на bind9 на шлюзе и на компе с XP укажите единственный dns - ip своего шлюза.

Оффлайн jadio

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Вроде бы настроил dnsmasq. Работает. Но только некоторое время.

Перезагружаю ubuntu. Некоторое время инет есть и на ubuntu, и на WinXP. Потом на компе с WinXP пропадает: не открывает сайты, аська и всё остальное, что уже соединилось по ip -- работает и дальше.

Оффлайн jadio

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Попробуйте dnsmask заменить на bind9 на шлюзе и на компе с XP укажите единственный dns - ip своего шлюза.
DNS так и указан. bind9 пока настраивать боязно, но видимо придётся из-за поведения dnsmasq.

 

Страница сгенерирована за 0.052 секунд. Запросов: 22.