Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: [Решено] Atheros AR8132 - зависание системы при копировании больших файлов  (Прочитано 4147 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн U2O

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
Сабж. Проблема дала о себе знать при копировании по LAN Ubuntu-Ubuntu коло 30 Гб фотографий, общим колличеством > 10.000 файлов
После старта копирования проходит 5-10 минут и система виснет намертво.

Пробовал отключать драйвера на графику, acpi, менять фс ext3->ext4, не использовать шифрование... ни один из советов на форуме не дал результата.
Читал о каком-то баге linux-ядра с угрозой для рейд-массивов.

Помогите кож-мож  :-[
« Последнее редактирование: 14 Сентября 2010, 00:20:42 от H2O »

mithrusc

  • Гость
где модель ноутбука? логи? что это вообще такое

Оффлайн truegeek

  • FPGA Designer
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 4214
  • аЦкий схемотехник
    • Просмотр профиля
через как копировали то? ssh? samba?
почему вы решили что виснет ВСЯ система?

Оффлайн U2O

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
Спасибо за отзывы!
Лапоть EeePC. Копировал через SAMBA. Между десктопами аналогичных ошибок не возникало. Сегодня поставил 8,04 - копирование прошло гладко.
Тесты железа не обнаружили неполадок ни в RAM ни в HDD. Видимо неустраненные баги в 10.04. Что именно виснет сказать затрудняюсь, не реагируют клава, мишь.

Скажите пожалуйста, какие именно логи смотреть?

Пользователь решил продолжить мысль 10 Сентября 2010, 17:22:00:
Перерыл полинтернета, видимо баги с новым ядром. В поисках обратил внимание, что скорость передачи файлов на лапоть составляет всего 7мб/сек, что не вполне нормально для высокоскоростного интерфейса...
« Последнее редактирование: 12 Сентября 2010, 01:21:23 от H2O »

mithrusc

  • Гость
Цитировать
Скажите пожалуйста, какие именно логи смотреть?
ну хотябы /var/log/messages и kern или kernel как там щас
7мб..маловато, вообще создается впечатление что у самого протокола ограничение в 10Мб/c. Ядро? ну если твердо решили что оно попробуйте обновить. Может еще попробовать eeebuntu какую нибудь, мне лично не понравилось как ubuntu работает на eeepc (я говорю о багах управления охлаждением)

Оффлайн U2O

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
7мб..маловато, вообще создается впечатление что у самого протокола ограничение в 10Мб/c.
Между десктопами скорость достигает 18Мб/сек.

В логах kernel во время сбоев ничего подозрительного не нашел.

Поставил еще раз 8.04 - со второго раза зависла! Eeebuntu/Федора 13 - аналогично, значит проблема не в версии ядра и не в багах конкретного дистрибутива.
Попробую заинсталить оффтопик с флешки - попробую как поведет себя с официальными дровами.

Но вообще, протестировав еще раз озу/винт с помощью спец.утилит а также проведя ряд тестовых операций по копированию/поиску файлов по шаблону внутри девайса, прихожу к выводу, что виноваты не мать или винт а вероятно сам LAN-порт. У людей похожие проблемы возникают при работе с сетью, подключенной через тот-же высокоскоростной интерфейс. Продолжаю красноглазить...

Кстати, как отловить ошибки работы LAN-интерфейса?
« Последнее редактирование: 12 Сентября 2010, 01:45:32 от H2O »

mithrusc

  • Гость
Цитировать
что виноваты не мать или винт
а вот это зря исключаете, было пару подобных случаев когда машина рандомно зависала при операциях работы с данными, перемещеннии копировании, копирование с использованием USB или сети вызывало более частые зависания (в чипе больше использовалось функций)
В обоих случаях оказывался виноват чип мамки(южник) и/или дешевая схема питания(деградация чипа). Погуглите по модели может найдете что нибудь обычно если производитель ставит некачественные детали оно всплывает, не сразу но всплывает )
а дефекты памяти не всегда можно выявить тестами, memtest86 гоняли? погоняйте его пару часов. Еще бы я контакты планки памяти протер
« Последнее редактирование: 12 Сентября 2010, 21:14:14 от mithrusc »

Оффлайн U2O

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
А дело оказалось в следующих багах, которые нашел только сейчас:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/576876
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/572249

Там, кстати кому надо, есть временное решение - задание параметра pci=nomsi
Второй раз успешно произвожу копирование и никаких зависаний не происходит. На изложенном решении, предварительно подкорректировав название темы, думаю можно считать вопрос закрытым.

Спасибо!

Оффлайн sergeykrlv

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
У меня тоже самое но только на нетбуке ACER ONE 260 (AOD260)
WIFI норм пашет, а вот LAN работать отказывается.
Ставил модуль, eth0 появился, но при подключении кабеля к свитчу все виснет на глухо.

 

Страница сгенерирована за 0.054 секунд. Запросов: 23.