Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: ubuntu 10.10 не загружается после обновления  (Прочитано 4670 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vol

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Здравствуйте.

Недавно установил ubuntu 10.10 и обновил ее с помощью программы обновления.

После обновления система запросила перезагрузку и не запустилась!

При загрузке выдаются следующие ошибки:

...
...
...
killed
mount: mounting /dev on /root/dev failled: No such file or directory
mount: mounting /sys on /root/sys failled: No such file or directory
mount: mounting /proc on /root/proc failled: No such file or directory
Target filesystem doesn't have requested /sbin/init
No init found. Try passing init= bootarg

BusyBox v1.15.3 (Ubuntu 1:1.15.3-1ubuntu5) built in shell (ash)

Смысл ошибок мне ясен, но что с ними делать и в каком направлении капать понятия не имею?
Может лучше мне поставить другую версию ubuntu?

Помогите с решением проблемы.
Заранее спасибо!

Beldieff

  • Гость
Re: ubuntu 10.10 не загружается после обновления
« Ответ #1 : 21 Октябрь 2010, 12:31:07 »


Смысл ошибок мне ясен, но что с ними делать и в каком направлении капать понятия не имею?


что не ясно то?

Оффлайн progroz

  • Активист
  • *
  • Сообщений: 284
    • Просмотр профиля
multi флешка - это просто
conky - склад

Оффлайн vol

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: ubuntu 10.10 не загружается после обновления
« Ответ #3 : 21 Октябрь 2010, 14:35:18 »
https://forum.ubuntu.ru/index.php?topic=119392.0

Там рекомендуют для начала проверить диск fsck

Загружаюсь с лайвСД.
Захожу System-->Administration-->Disk Utility

Там мне пишут:
Device: /dev/sda1
Partition label: -
Mount Point: Not Mounted

В терминале пишу:
sudo fsck /dev/sda1

В ответ получаю:
Device or resource busy while trying to open /dev/sda1
Filesystem mounted or opened excklusively by another program

Хотя раздел не примонтирован и дисковую утилиту я закрывал.
Как мне в этом случае проверить диск на наличие ошибок в файловой системе?

Решил попробовать примонтировать диск:
sudo mkdir /mnt/mydisk
sudo mount /dev/sda1 /mnt/mydisk

На что вообще не получаю никакой реакции - внизу мигает курсор!

Народ, что мне делать?

Оффлайн Softwayer

  • Активист
  • *
  • Сообщений: 706
  • Arch Linux
    • Просмотр профиля
Re: ubuntu 10.10 не загружается после обновления
« Ответ #4 : 21 Октябрь 2010, 20:50:22 »
Попробуй проверить Дисковой утилитой…

Оффлайн vol

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: ubuntu 10.10 не загружается после обновления
« Ответ #5 : 21 Октябрь 2010, 22:49:25 »
Попробуй проверить Дисковой утилитой…

Чем только не пробовал! Не помогало!

Пользователь решил продолжить мысль 21 Октябрь 2010, 22:58:55:
Решил свю проблему. Оказалось все очень просто!
Ошибка "mount: mounting /dev on /root/dev failled: No such file or directory" не зря предупреждает, что такого файла или дирректории нету. :-)

когда стал в отладчике (BusyBox) проверять путь /root/dev - там не оказалось папки dev.
Я ее создал с помощью команды mkdir. После проверил чтобы /dev монтировалась в /root/dev и перезагрузился.

Далее ubuntu сделала все сама и через пару перезагрузок у меня стало все работать как прежде!

Спасибо всем за участие! :-)
« Последнее редактирование: 21 Октябрь 2010, 22:58:55 от vol »

Оффлайн muhh

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: ubuntu 10.10 не загружается после обновления
« Ответ #6 : 26 Октябрь 2010, 19:39:41 »
не получается перезагрузиться из бизибокса по команде reboot. получаю выход из бизибокса и одинокий курсор. =(
если просто выключить ноут кнопкой питания и включить заново - пропадают созданные папки

Оффлайн Pavel798

  • Активист
  • *
  • Сообщений: 396
    • Просмотр профиля
Re: ubuntu 10.10 не загружается после обновления
« Ответ #7 : 15 Ноябрь 2010, 10:02:54 »
Совершенно те же симптомы в 10.04.
И решить проблему не получается.
Создать нужные директории не удаётся - они, вроде бы создаются, но после перезагрузки их нет, может быть из за того, что бизибокс не хочет выключаться корректно.

вот тут https://forum.ubuntu.ru/index.php?topic=121087.0
обсуждается, вроде бы, аналогичная проблема.
Народ удивляется, что /dev хочет монтироваться в /root , а не в /
Мне тоже это кажется странным.
Но как заставить при загрузке /dev монтироваться правильно?

 

Пользователь решил продолжить мысль 15 Ноябрь 2010, 11:09:18:
не получается перезагрузиться из бизибокса по команде reboot. получаю выход из бизибокса и одинокий курсор. =(
если просто выключить ноут кнопкой питания и включить заново - пропадают созданные папки
Такое поведение, похоже, как раз и связано с тем, что на диск записать не получается ничего.
Не совсем понятно, как ТС сумел победить эту проблему.

Пользователь решил продолжить мысль 15 Ноябрь 2010, 23:45:15:
Проблема решена.
Выяснилось, что безумное поведение команды mount, неизвестный неубиваемый процесс, который использует несмонтированный диск, странное поведение fsck, палимпсеста и т.д. - всё это специфические глюки Юбунты 10.04, 10.10, а так же Линукс Минт 10.
А
fsck -y /dev/sda5,
запущенный из под Puppy Linux, в полпинка вылечил глючный раздел ext4.
Свинство, конечно, редкостное. Чуть ли не сутки я на это убил. 
Зато, теперь всё работает, крутится - вертится, танцует и поёт.

Спасибо.
« Последнее редактирование: 15 Ноябрь 2010, 23:53:30 от Pavel798 »

Оффлайн ANtlord

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: ubuntu 10.10 не загружается после обновления
« Ответ #8 : 21 Январь 2011, 18:03:38 »
Всем привет, в общем у меня была подобная проблема, но только ОС зависала после GRUB'a. Никаких сообщений ничего такого.
Решение: зашел в безопасный режим Ubuntu (через recovery mode если кто не в курсе), поставил дрова на видео через него. И все отлично!
P.S. Видеокарта ATI HD4500. Драйвера проприетарные.
P.P.S. Решил написать тут, потому что не могу создавать темы :-] А тут проблема вроде похожа. Если что сори.

Оффлайн Andrymax

  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
Re: ubuntu 10.10 не загружается после обновления
« Ответ #9 : 05 Февраль 2011, 16:07:52 »
"Решил свю проблему. Оказалось все очень просто!
Ошибка "mount: mounting /dev on /root/dev failled: No such file or directory" не зря предупреждает, что такого файла или дирректории нету. :-)

когда стал в отладчике (BusyBox) проверять путь /root/dev - там не оказалось папки dev.
Я ее создал с помощью команды mkdir. После проверил чтобы /dev монтировалась в /root/dev и перезагрузился.

Далее ubuntu сделала все сама и через пару перезагрузок у меня стало все работать как прежде!

Спасибо всем за участие! :-) "

 Черт, а у меня раздел не монтируется ...

ЗЫ  Снес уже системный раздел, да переставил... так как его не примонтировать, ни отмантиоровать (пишет - не примонтирован, ну понятно..), и доступа нет и ни одна Ubunt-овская прога не может исправить. И проверить нельзя - пишет  - занят ...      
Снес под Win 7 стандартными средствами  :)  Так что тема открыта до сих пор.
« Последнее редактирование: 06 Февраль 2011, 13:29:54 от Andrymax »
Не бойся делать то, в чем ничего не понимаешь. Ноев ковчег построили дилетанты. Профи построили Титаник.

Оффлайн susnake

  • Участник
  • *
  • Сообщений: 103
    • Просмотр профиля
Re: ubuntu 10.10 не загружается после обновления
« Ответ #10 : 11 Апрель 2011, 20:38:33 »
Andrymax, аналогично. Может я кривой, но у меня не получилось создать и смонтировать раздел. Другие способы то же не проканали. ХЗ почему. Поэтому я поступил по-ламерски:
  • Скачал win
  • записал на болванку
  • Загрузил с него установку
  • Форматнул весь хард (благо вся важная инфа на флешке есть)
  • Установил заново Ubuntu.
  • Работает!  :D
Но у меня скорей всего /dev и /sys отвалились из-за того, что я ставил Макбунту и наверняка как-то криво поставил  

Оффлайн Cardot

  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
Re: ubuntu 10.10 не загружается после обновления
« Ответ #11 : 11 Апрель 2011, 21:50:10 »
  • Скачал win
  • записал на болванку
  • Загрузил с него установку
  • Форматнул весь хард (благо вся важная инфа на флешке есть)
  • Установил заново Ubuntu.
  • Работает!  :D

а зачем первые шага? :o а чем не понравилось Ubuntu на флешку/диск записать? их нет у вас ???

 

Страница сгенерирована за 0.064 секунд. Запросов: 22.