Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: [РЕШЕНО] x-server без монитора  (Прочитано 12320 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KOT_09

  • Автор темы
  • Любитель
  • *
  • Сообщений: 61
    • Просмотр профиля
[РЕШЕНО] x-server без монитора
« : 04 Ноябрь 2010, 22:01:28 »
Привет. есть встроенное видео nvidia gf6100, но если монитор не подключен во время загрузки компа иксы не включаются, а так как управляю в основном с VNC, то иеет место быть проблема). Как ее исправить? Спасибо.
« Последнее редактирование: 06 Февраль 2011, 20:29:53 от RazrFalcon »

Оффлайн tarabo

  • Активист
  • *
  • Сообщений: 460
    • Просмотр профиля
Re: x-server без монитора
« Ответ #1 : 05 Ноябрь 2010, 00:27:45 »
+1 Тоже интересует.
Lenovo ThinkPad E520, Core i5 2,5GHz, 8Gb RAM, AMD Radeon HD6630, Ubuntu 12.04 LTS amd64, OCZ Vertex 3 60GB + Seagate Momentus 750GB 7200rpm 16MB

Оффлайн gva230

  • Активист
  • *
  • Сообщений: 981
  • GUI-овый линуксоид
    • Просмотр профиля
    • Моя дикая страничка
Re: x-server без монитора
« Ответ #2 : 05 Ноябрь 2010, 00:42:01 »
А если "пустой" кабель в видюху воткнуть? Можно ещё одну "вилку" от кабеля, отрезать. :) Или переходник какой-нибудь DVI - D-SUB. Комп должен "подумать", что монитор подключен.
« Последнее редактирование: 05 Ноябрь 2010, 00:44:32 от gva230 »
Kubuntu - наше фсё! :Ь

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5085
    • Просмотр профиля
Re: x-server без монитора
« Ответ #3 : 05 Ноябрь 2010, 00:46:19 »
а питание? моник то и так подключен, а вот если с кнопки питание отключить то всё финиш

p.s. наверно если правильней то там не питание нужно т.е. не просто сигнал, а х.з. как там правильно вообщем считать инфу о монике (его параметрах)
« Последнее редактирование: 05 Ноябрь 2010, 00:54:47 от gregory5 »

Оффлайн Scorry

  • Активист
  • *
  • Сообщений: 842
    • Просмотр профиля
Re: x-server без монитора
« Ответ #4 : 05 Ноябрь 2010, 00:55:33 »
Привет. есть встроенное видео nvidia gf6100, но если монитор не подключен во время загрузки компа иксы не включаются, а так как управляю в основном с VNC, то иеет место быть проблема). Как ее исправить? Спасибо.
ssh?

Оффлайн agoomboom

  • Участник
  • *
  • Сообщений: 172
    • Просмотр профиля
Re: x-server без монитора
« Ответ #5 : 05 Ноябрь 2010, 01:22:14 »
Без иксов!
ssh!
220~
RJ45

Оффлайн alecsartania

  • Старожил
  • *
  • Сообщений: 1561
  • УМка.
    • Просмотр профиля
Re: x-server без монитора
« Ответ #6 : 05 Ноябрь 2010, 09:42:33 »
Столкнулся с проблемой, на объекте нужно было поставить машину, в которой крутилась программа с GUI, и подключаться к ней удаленно через VNC. Все поставил, все настроил – работает как надо. Принесли на место включили и… И все. Ни ответа ни привета. Только пинги и SSH. Зашел на машину по ssh, смотрю логи, и вижу строчку:

Fatal server error:
no screens found


В предыдущих версиях Ubuntu я с таким не сталкивался. Но ничего особо страшного в этом нет. Оказывается проблема в том, что Ubuntu 9.10 Karmic  использует KMS (kernel mode-setting). Он то и пытается определить железку, а не находя монитора – отказывает в загрузке X’ов.

Чтобы решить эту проблему нужно сделать следующее.

Для GRUB 1 редактируем файл:
ubuntu@ubuntu:~$ sudo nano /boot/grub/menu.lst

Добавляем nomodeset (через пробел) в строку:
kopt="... quiet splash"

получается
kopt="... quiet splash nomodeset"

Для GRUB 2 редактируем файл:
ubuntu@ubuntu:~$ sudo nano /etc/default/grub

Добавляем nomodeset (через пробел) в строку:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

получается
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Далее обязательно делаем update-grub, чтобы обновить изменения.

Это еще не все, теперь надо создать файл /etc/X11/xorg.conf со следующим содержимым:
Section "Device"
Identifier "Configured Video Device"
Driver  "vesa"
Option  "NoDDC"
Option  "IgnoreEDID" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Modeline "1280x1024" 108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync
Option  "ConnectedMonitor" "LCD"
Option  "PreferredMode" "1280x1024"
Horizsync 31.00-81.00
Vertrefresh 56.00-75.00
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor  "Configured Monitor"
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
Device  "Configured Video Device"
EndSection

Теперь перегружаемся и радуемся:
Дома Linux mint 15 ||  Ubuntu 14.04  / Минт 17.03
Работа: Linux Mint 18(Ub 16.04)

Оффлайн tarabo

  • Активист
  • *
  • Сообщений: 460
    • Просмотр профиля
Re: x-server без монитора
« Ответ #7 : 05 Ноябрь 2010, 09:53:15 »
Спасибо, буду пробовать.
Lenovo ThinkPad E520, Core i5 2,5GHz, 8Gb RAM, AMD Radeon HD6630, Ubuntu 12.04 LTS amd64, OCZ Vertex 3 60GB + Seagate Momentus 750GB 7200rpm 16MB

Оффлайн KOT_09

  • Автор темы
  • Любитель
  • *
  • Сообщений: 61
    • Просмотр профиля
Re: x-server без монитора
« Ответ #8 : 05 Ноябрь 2010, 11:08:04 »
alecsartania
Спасибо огромное, помогло.

П.С, теперь надо в название указать Solved?

П.П.С. а чтобы изменить расширение экрана надо редактировать строчку Option  "PreferredMode" "1280x1024" ?
« Последнее редактирование: 05 Ноябрь 2010, 11:12:12 от KOT_09 »

Оффлайн alecsartania

  • Старожил
  • *
  • Сообщений: 1561
  • УМка.
    • Просмотр профиля
Re: x-server без монитора
« Ответ #9 : 05 Ноябрь 2010, 11:22:09 »
alecsartania
Спасибо огромное, помогло.

П.С, теперь надо в название указать Solved?

П.П.С. а чтобы изменить расширение экрана надо редактировать строчку Option  "PreferredMode" "1280x1024" ?
там две с трочки с разрешением ..
лучше давать из набора что покажет команда xrandr
Дома Linux mint 15 ||  Ubuntu 14.04  / Минт 17.03
Работа: Linux Mint 18(Ub 16.04)

Оффлайн tayfur

  • Участник
  • *
  • Сообщений: 226
  • SamsungQ1 Ubuntu 10.4, Asus1015BX Mint14/Fedora17
    • Просмотр профиля
    • Хомяк
Re: x-server без монитора
« Ответ #10 : 06 Ноябрь 2010, 03:27:50 »
alecsartania
Спасибо огромное, помогло.

П.С, теперь надо в название указать Solved?

П.П.С. а чтобы изменить расширение экрана надо редактировать строчку Option  "PreferredMode" "1280x1024" ?
А разве нельзя при подключении задать размер рабочего стола? В виндовой RDP можно в файле конфигурации задать практически любое разрешение, в rdesktop в строке вызова тоже задаётся.
Облака.. сделай бекап
Copy 20Gb +5Gb за рефа,
Яша.диск 11Gb +0.5Gb за рефа, и тебе бекап и мне +Gb :)

Оффлайн tarabo

  • Активист
  • *
  • Сообщений: 460
    • Просмотр профиля
Re: x-server без монитора
« Ответ #11 : 07 Ноябрь 2010, 19:14:47 »
alecsartania
Спасибо огромное, помогло.

П.С, теперь надо в название указать Solved?

П.П.С. а чтобы изменить расширение экрана надо редактировать строчку Option  "PreferredMode" "1280x1024" ?
А разве нельзя при подключении задать размер рабочего стола? В виндовой RDP можно в файле конфигурации задать практически любое разрешение, в rdesktop в строке вызова тоже задаётся.
Чего-то ты не в тему выстрелил.
Lenovo ThinkPad E520, Core i5 2,5GHz, 8Gb RAM, AMD Radeon HD6630, Ubuntu 12.04 LTS amd64, OCZ Vertex 3 60GB + Seagate Momentus 750GB 7200rpm 16MB

Оффлайн tayfur

  • Участник
  • *
  • Сообщений: 226
  • SamsungQ1 Ubuntu 10.4, Asus1015BX Mint14/Fedora17
    • Просмотр профиля
    • Хомяк
Re: x-server без монитора
« Ответ #12 : 08 Ноябрь 2010, 10:44:42 »
alecsartania
Спасибо огромное, помогло.

П.С, теперь надо в название указать Solved?

П.П.С. а чтобы изменить расширение экрана надо редактировать строчку Option  "PreferredMode" "1280x1024" ?
А разве нельзя при подключении задать размер рабочего стола? В виндовой RDP можно в файле конфигурации задать практически любое разрешение, в rdesktop в строке вызова тоже задаётся.
Чего-то ты не в тему выстрелил.
Может не в тему. Разве не клиентская часть решает в каком разрешении рабочий стол запустить? Юзаю Ubuntu машину через win RDP, задать можно любое разрешение стола. На Ubuntu стоит xrdp. Если юзать с Linux машины через rdesktop тоже в командной строке указывается любое разрешение. Или тут обсуждается способ с подключением к "физическому" столу?
Облака.. сделай бекап
Copy 20Gb +5Gb за рефа,
Яша.диск 11Gb +0.5Gb за рефа, и тебе бекап и мне +Gb :)

Оффлайн KOT_09

  • Автор темы
  • Любитель
  • *
  • Сообщений: 61
    • Просмотр профиля
Re: x-server без монитора
« Ответ #13 : 08 Ноябрь 2010, 10:59:04 »
alecsartania
Спасибо огромное, помогло.

П.С, теперь надо в название указать Solved?

П.П.С. а чтобы изменить расширение экрана надо редактировать строчку Option  "PreferredMode" "1280x1024" ?
А разве нельзя при подключении задать размер рабочего стола? В виндовой RDP можно в файле конфигурации задать практически любое разрешение, в rdesktop в строке вызова тоже задаётся.
Чего-то ты не в тему выстрелил.
Может не в тему. Разве не клиентская часть решает в каком разрешении рабочий стол запустить? Юзаю Ubuntu машину через win RDP, задать можно любое разрешение стола. На Ubuntu стоит xrdp. Если юзать с Linux машины через rdesktop тоже в командной строке указывается любое разрешение. Или тут обсуждается способ с подключением к "физическому" столу?
Клиентская часть конечно решает! но если изначальное расширение и прописанное в клиенте не совпадают, то картинка, как правило, получается вытянутой или приплюснутой.

Оффлайн tarabo

  • Активист
  • *
  • Сообщений: 460
    • Просмотр профиля
Re: [Solved] x-server без монитора
« Ответ #14 : 08 Ноябрь 2010, 11:42:47 »
Мы вроде как за VNC говорили а не за RDP. VNC не устанавливает разрешение экрана на серверной машине.
Lenovo ThinkPad E520, Core i5 2,5GHz, 8Gb RAM, AMD Radeon HD6630, Ubuntu 12.04 LTS amd64, OCZ Vertex 3 60GB + Seagate Momentus 750GB 7200rpm 16MB

 

Страница сгенерирована за 0.117 секунд. Запросов: 22.