Форум русскоязычного сообщества Ubuntu


Автор Тема: UBUNTU 7.04 не видит второй сетевухи!  (Прочитано 1202 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн начавший

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
UBUNTU 7.04 не видит второй сетевухи!
« : 12 Сентябрь 2007, 23:34:04 »
не назначает прерывания шелезяке (((

root@ubu:~# ifconfig eth2
eth2      Link encap:Ethernet  HWaddr 00:80:1E:13:73:E2
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Base address:0x6000

при поднятии руками матерится так вот!

root@ubu:~# ifconfig eth2 up
SIOCSIFFLAGS: Device or resource busy
root@ubu:~#

А потом прочел про совместимости и прочее
у меня карточка первая RTL 8139D
А вот вторая D-link DFE-520TX,
Скажите кто еще под убу 7,04 юзает Длинк, мож и проблем нету?
но на всякий попробую два RTL поставить мож полечится.
жду отзывов.
« Последнее редактирование: 12 Сентябрь 2007, 23:43:21 от начавший »

Оффлайн Envel

  • Участник
  • *
  • Сообщений: 166
    • Просмотр профиля
Re: UBUNTU 7.04 не видит второй сетевухи!
« Ответ #1 : 13 Сентябрь 2007, 00:45:21 »
обычно первая карточка eth0, вторая - eth1. А у вас что???

Оффлайн начавший

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: UBUNTU 7.04 не видит второй сетевухи!
« Ответ #2 : 13 Сентябрь 2007, 11:42:34 »
обычно первая карточка eth0, вторая - eth1. А у вас что???
Первая eth0
потом смотря как поставлю вторую (в какой слот)
либо eth1 либо eth2

я их пихаю во все слоты, посему они иногда вот так и назначаются )
поставил и вторую RTL 8139D такая же проблема... назначает прерывание 0 и потом на него же и матерится...
« Последнее редактирование: 13 Сентябрь 2007, 11:52:27 от начавший »

Оффлайн ceval

  • Активист
  • *
  • Сообщений: 778
  • Минск, Беларусь
    • Просмотр профиля
    • On-line журнал o Linux
Re: UBUNTU 7.04 не видит второй сетевухи!
« Ответ #3 : 14 Сентябрь 2007, 14:45:10 »
Ну если прерывания по посмотри в биосе назначь другое прывания, тут больше конфликт по железу

Оффлайн xmig

  • Любитель
  • *
  • Сообщений: 98
    • Просмотр профиля
Re: UBUNTU 7.04 не видит второй сетевухи!
« Ответ #4 : 14 Сентябрь 2007, 16:32:26 »
Прерывания уже давно раздаются автоматом. У меня была похожая проблема, решилась исправлением конфигурации в
/etc/network/interfaces

Оффлайн начавший

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: UBUNTU 7.04 не видит второй сетевухи!
« Ответ #5 : 16 Сентябрь 2007, 22:04:29 »
Прерывания уже давно раздаются автоматом. У меня была похожая проблема, решилась исправлением конфигурации в
/etc/network/interfaces
Кинь пожалуйста кусок конфига в студию, если там можно назначить прерывание сетевухе, а то я перелопатил кучу карточек, результатов не добился.

Оффлайн zzipper

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: UBUNTU 7.04 не видит второй сетевухи!
« Ответ #6 : 16 Сентябрь 2007, 22:12:00 »
У меня такая же проблема. Находит Dlink как VIA чото там... Может дело в дровах? Никак не могу найти пакет дров. На диске от карты есть, но не получается скомпилировать.

Оффлайн начавший

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: UBUNTU 7.04 не видит второй сетевухи!
« Ответ #7 : 16 Сентябрь 2007, 23:24:26 »
У меня такая же проблема. Находит Dlink как VIA чото там... Может дело в дровах? Никак не могу найти пакет дров. На диске от карты есть, но не получается скомпилировать.
я посмотрел по совместимости, тут где то ссылка была, заменил сетевуху, но прикол в том что обе сразу не работают (
либо дает прерывание первой либо второй, если установлены обе, а если ставлю по очереди то работают что что эта

Оффлайн IgorR

  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Re: UBUNTU 7.04 не видит второй сетевухи!
« Ответ #8 : 17 Сентябрь 2007, 07:49:32 »
Отредактируй строку запуска ядра в /boot/grub/menu.lst, нужно добавить параметр pci=routeirq который говорит ядру назначать устройствам pci дефолтные прерывания.
http://faq.altlinux.ru/index.php?action=listq&nf=1&qid=566

Оффлайн начавший

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: UBUNTU 7.04 не видит второй сетевухи!
« Ответ #9 : 17 Сентябрь 2007, 11:48:55 »
Отредактируй строку запуска ядра в /boot/grub/menu.lst, нужно добавить параметр pci=routeirq который говорит ядру назначать устройствам pci дефолтные прерывания.
http://faq.altlinux.ru/index.php?action=listq&nf=1&qid=566
Это поможет биосу назначить прерывание?
при загрузке машина говорит что одной сетевухе назначено прерывание 11 а второй NA так же как и видяхе впрочем.....
щас проверю!

 

Страница сгенерирована за 0.059 секунд. Запросов: 22.