Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Ошибка не даёт обновляться системе  (Прочитано 1658 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Ошибка не даёт обновляться системе
« : 19 Декабрь 2010, 13:44:52 »
Инет копал, пробовал всё что нашёл, проблема не решена. Возникла после не совсем удачного обновления системы, точно не помню, во обновлял в два этапа, тоесть был один разрыв. Прошу помощи опытных.

sudo apt-get upgrade
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install'.
Пакеты, имеющие неудовлетворённые зависимости:
  packagekit: Зависит: libpackagekit-glib2-12 (= 0.5.7-0ubuntu2) но 0.5.7-0ubuntu2.2 уже установлен
  packagekit-backend-apt: Зависит: python-packagekit (= 0.5.7-0ubuntu2) но 0.5.7-0ubuntu2.2 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.

sudo apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
Будут установлены следующие дополнительные пакеты:
  e2fsprogs libpackagekit-glib2-12 packagekit packagekit-backend-apt
  packagekit-backend-smart python-packagekit
Предлагаемые пакеты:
  gpart e2fsck-static
Пакеты, которые будут обновлены:
  e2fsprogs libpackagekit-glib2-12 packagekit packagekit-backend-apt
  packagekit-backend-smart python-packagekit
обновлено 6, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 298 пакетов не обновлено.
не установлено до конца или удалено 8 пакетов.
Необходимо скачать 1 447kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0B.
Хотите продолжить [Д/н]? Д
Получено:1 http://archive.ubuntu.com/ubuntu/ lucid-updates/main packagekit 0.5.7-0ubuntu2.2 [201kB]
Получено:2 http://archive.ubuntu.com/ubuntu/ lucid-updates/main libpackagekit-glib2-12 0.5.7-0ubuntu2.2 [163kB]
Получено:3 http://archive.ubuntu.com/ubuntu/ lucid-updates/universe packagekit-backend-smart 0.5.7-0ubuntu2.2 [84,7kB]
Получено:4 http://archive.ubuntu.com/ubuntu/ lucid-updates/main packagekit-backend-apt 0.5.7-0ubuntu2.2 [97,6kB]
Получено:5 http://archive.ubuntu.com/ubuntu/ lucid-updates/main python-packagekit 0.5.7-0ubuntu2.2 [93,2kB]
Получено:6 http://archive.ubuntu.com/ubuntu/ lucid-updates/main e2fsprogs 1.41.11-1ubuntu2.1 [808kB]
Получено 1 447kБ за 23с (62,8kБ/c)                                             
(Чтение базы данных ... на данный момент установлено 379367 файлов и каталогов.)
Подготовка к замене пакета packagekit 0.5.7-0ubuntu2 (используется файл .../packagekit_0.5.7-0ubuntu2.2_amd64.deb) ...
dpkg: не удалось обработать параметр /var/cache/apt/archives/packagekit_0.5.7-0ubuntu2.2_amd64.deb (--unpack):
 файл триггеров ci содержит директиву с неизвестным синтаксисом
Подготовка к замене пакета libpackagekit-glib2-12 0.5.7-0ubuntu2.1 (используется файл .../libpackagekit-glib2-12_0.5.7-0ubuntu2.2_amd64.deb) ...
Распаковывается замена для пакета libpackagekit-glib2-12 ...
Подготовка к замене пакета packagekit-backend-smart 0.5.7-0ubuntu2.1 (используется файл .../packagekit-backend-smart_0.5.7-0ubuntu2.2_amd64.deb) ...
Распаковывается замена для пакета packagekit-backend-smart ...
Подготовка к замене пакета packagekit-backend-apt 0.5.7-0ubuntu2 (используется файл .../packagekit-backend-apt_0.5.7-0ubuntu2.2_amd64.deb) ...
dpkg: не удалось обработать параметр /var/cache/apt/archives/packagekit-backend-apt_0.5.7-0ubuntu2.2_amd64.deb (--unpack):
 слишком длинная строка или отсутствующая новая строка в /var/lib/dpkg/info/packagekit-backend-apt.triggers
Подготовка к замене пакета python-packagekit 0.5.7-0ubuntu2.1 (используется файл .../python-packagekit_0.5.7-0ubuntu2.2_all.deb) ...
Распаковывается замена для пакета python-packagekit ...
Подготовка к замене пакета e2fsprogs 1.41.11-1ubuntu2 (используется файл .../e2fsprogs_1.41.11-1ubuntu2.1_amd64.deb) ...
Распаковывается замена для пакета e2fsprogs ...
Обрабатываются триггеры для man-db ...
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/packagekit_0.5.7-0ubuntu2.2_amd64.deb
 /var/cache/apt/archives/packagekit-backend-apt_0.5.7-0ubuntu2.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Оффлайн KPN

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #1 : 19 Декабрь 2010, 13:54:14 »
sudo apt-get clean

Оффлайн Vitsliputsli

  • Старожил
  • *
  • Сообщений: 1244
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #2 : 19 Декабрь 2010, 13:57:47 »
А если удалить эти сбойные пакеты и заново закачать?
sudo apt-get clean && sudo apt-get -f install

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #3 : 19 Декабрь 2010, 18:48:45 »
Спасибо, но не помогло.
sudo apt-get clean && sudo apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
Будут установлены следующие дополнительные пакеты:
  packagekit packagekit-backend-apt
Пакеты, которые будут обновлены:
  packagekit packagekit-backend-apt
обновлено 2, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 298 пакетов не обновлено.
не установлено до конца или удалено 11 пакетов.
Необходимо скачать 298kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0B.
Хотите продолжить [Д/н]? Д
Получено:1 http://archive.ubuntu.com/ubuntu/ lucid-updates/main packagekit-backend-apt 0.5.7-0ubuntu2.2 [97,6kB]
Получено:2 http://archive.ubuntu.com/ubuntu/ lucid-updates/main packagekit 0.5.7-0ubuntu2.2 [201kB]
Получено 298kБ за 6с (49,0kБ/c)                                               
(Чтение базы данных ... на данный момент установлено 379367 файлов и каталогов.)
Подготовка к замене пакета packagekit-backend-apt 0.5.7-0ubuntu2 (используется файл .../packagekit-backend-apt_0.5.7-0ubuntu2.2_amd64.deb) ...
dpkg: не удалось обработать параметр /var/cache/apt/archives/packagekit-backend-apt_0.5.7-0ubuntu2.2_amd64.deb (--unpack):
 слишком длинная строка или отсутствующая новая строка в /var/lib/dpkg/info/packagekit-backend-apt.triggers
Подготовка к замене пакета packagekit 0.5.7-0ubuntu2 (используется файл .../packagekit_0.5.7-0ubuntu2.2_amd64.deb) ...
dpkg: не удалось обработать параметр /var/cache/apt/archives/packagekit_0.5.7-0ubuntu2.2_amd64.deb (--unpack):
 файл триггеров ci содержит директиву с неизвестным синтаксисом
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/packagekit-backend-apt_0.5.7-0ubuntu2.2_amd64.deb
 /var/cache/apt/archives/packagekit_0.5.7-0ubuntu2.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

И я не только не могу обновить систему, но и любое приложение поставить не могу, ни через терминал, ни через менеджеры ПО. Ещё есть соображения? Может как то насильно возможно снести кривовставшие паеты?

Оффлайн kosteek

  • Участник
  • *
  • Сообщений: 193
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #4 : 19 Декабрь 2010, 18:54:46 »
Хе. Зайди в синаптик, после ругани перейди на Специальные фильтры - С ошибками. И удали пакеты с ломанными зависимостями.

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #5 : 19 Декабрь 2010, 19:14:06 »
вся проблема то и заключается в том, что удалить не удаётся.

Синаптик не может. Через терминал тоже не выходит
sudo apt-get remove packagekit
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Пакеты, которые будут УДАЛЕНЫ:
  packagekit
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 298 пакетов не обновлено.
не установлено до конца или удалено 7 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 2 605kB.
Хотите продолжить [Д/н]? Д
(Чтение базы данных ... на данный момент установлено 379366 файлов и каталогов.)
Удаляется пакет packagekit ...
dpkg: не удалось обработать параметр packagekit (--remove):
 файл триггеров ci содержит директиву с неизвестным синтаксисом
При обработке следующих пакетов произошли ошибки:
 packagekit
E: Sub-process /usr/bin/dpkg returned an error code (1)


Пользователь решил продолжить мысль 20 Декабрь 2010, 16:11:46:
какие у кого соображения?
« Последнее редактирование: 20 Декабрь 2010, 16:11:46 от ZeVC »

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #6 : 12 Январь 2011, 00:47:46 »
До сих пор не решил проблему, мне сейчас срочно нужно расшарить инет проводной по WIFI, нужно поставить пакеты, а я, как писал выше, немогу. Неужели нужно сносить систему и с нуля ставить??? Это же не винда в конце то концов! Прошу очень оказать помощь.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net

Оффлайн А_л_е_к_с_е_й

  • Активист
  • *
  • Сообщений: 590
  • Kubuntu 15.04 x64 KDE 5.2.1 Qt 5.4.0
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #8 : 12 Январь 2011, 00:59:19 »
ну почти так же как по ссылке выше, найди свой пакет в синаптике пкм по нему - свойства установленные файлы. И ручками это все удалить

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #9 : 12 Январь 2011, 02:59:58 »
Благодарю! что мне нужно удалить из этого?
/.
/etc
/etc/PackageKit
/etc/PackageKit/CommandNotFound.conf
/etc/PackageKit/PackageKit.conf
/etc/PackageKit/Vendor.conf
/etc/bash_completion.d
/etc/bash_completion.d/pk-completion.bash
/etc/dbus-1
/etc/dbus-1/system.d
/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
/usr
/usr/bin
/usr/bin/pkcon
/usr/bin/pkmon
/usr/lib
/usr/lib/packagekit
/usr/lib/packagekit/pk-command-not-found
/usr/lib/pm-utils
/usr/lib/pm-utils/sleep.d
/usr/lib/pm-utils/sleep.d/95packagekit
/usr/sbin
/usr/sbin/packagekitd
/usr/share
/usr/share/PackageKit
/usr/share/PackageKit/pk-upgrade-distro.sh
/usr/share/dbus-1
/usr/share/dbus-1/system-services
/usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service
/usr/share/doc
/usr/share/doc/packagekit
/usr/share/doc/packagekit/AUTHORS
/usr/share/doc/packagekit/NEWS.gz
/usr/share/doc/packagekit/README
/usr/share/doc/packagekit/README.Debian
/usr/share/doc/packagekit/TODO
/usr/share/doc/packagekit/changelog.Debian.gz
/usr/share/doc/packagekit/copyright
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/pkcon.1.gz
/usr/share/man/man1/pkmon.1.gz
/usr/share/mime
/usr/share/mime/packages
/usr/share/mime/packages/packagekit-catalog.xml
/usr/share/mime/packages/packagekit-package-list.xml
/usr/share/polkit-1
/usr/share/polkit-1/actions
/usr/share/polkit-1/actions/org.freedesktop.packagekit.policy
/var
/var/cache
/var/cache/PackageKit
/var/cache/PackageKit/downloads
/var/lib
/var/lib/PackageKit
/var/lib/PackageKit/transactions.db

Оффлайн А_л_е_к_с_е_й

  • Активист
  • *
  • Сообщений: 590
  • Kubuntu 15.04 x64 KDE 5.2.1 Qt 5.4.0
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #10 : 12 Январь 2011, 03:17:19 »
 в /var/lib/dpkg/status удали все касается этого пакета, система будет думать что пакет удален. Все должно заработать, ну а удалять все что касаеться этого пакета там же написано в каких папках лежит, помечать все в вашем списке слишком долго  :)

Оффлайн easy2002

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2786
  • Мурманск
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #11 : 12 Январь 2011, 09:12:51 »
cat -v '/var/lib/dpkg/info/packagekit.triggers'чего пишет?
Tempora mutantur et nos mutantur in illis

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #12 : 12 Январь 2011, 16:28:01 »
cat -v '/var/lib/dpkg/info/packagekit.triggers'чего пишет?

вот: rg.mortbay.io.bio.SocketEndPoint</A>

Оффлайн easy2002

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2786
  • Мурманск
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #13 : 12 Январь 2011, 17:31:49 »
cat -v '/var/lib/dpkg/info/packagekit.triggers'чего пишет?

вот: rg.mortbay.io.bio.SocketEndPoint</A>


sudo gedit /var/lib/dpkg/info/packagekit.triggersпоправь на
interest /usr/lib/packagekit-backendпотом -
sudo apt-get -f install
Tempora mutantur et nos mutantur in illis

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Ошибка не даёт обновляться системе
« Ответ #14 : 12 Январь 2011, 22:41:28 »
огромнейшее спасибо каждому отозвавшемуся, система выздоровела!

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.