Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Проблема с USB NTFS диском в KDE  (Прочитано 2332 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн romandoctor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Проблема с USB NTFS диском в KDE
« : 18 Сентябрь 2007, 21:58:57 »
Люблю  KDE. Поставил из репозитария KDE desktop. Всё отлично работает и настраивается, кроме USB NTFS диска 400ГБ. При включени коробки с диском KDE ловит его, выбрасывает окошко с меню, что типа делать: открывать или картинки показать. Когда тыкаю чтобы открыл корневой каталог, диск исчезает напрочь. В гноме всё работает замечательно. Кроме того, в кедах отлично автоматически монтируетя при подключении  USB диск 100Гб Fat32. Гуглил, нашел только, что это глюк KDE, методов устранения не предлагалось.

Оффлайн Densakh

  • Участник
  • *
  • Сообщений: 125
    • Просмотр профиля
Re: Проблема с USB NTFS диском в KDE
« Ответ #1 : 21 Сентябрь 2007, 08:28:51 »
Да, это глюк КДЕ. Я тоже к этому пришел. Выход нашел один - пользовать ГНОМА ;D Тоже его недолюбливал - но в нем все работает. Уже привык и к КДЕ не тянет ;)
Ubuntu 8.04, Win Vista.

Оффлайн romandoctor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Re: Проблема с USB NTFS диском в KDE
« Ответ #2 : 21 Сентябрь 2007, 21:55:05 »
Гном я тоже люблю, но в кедах мне лучше просто.

При попытке монтирования ручками получается
romandoctor@romandoctor-desktop:~$ sudo mount /dev/sdd1
Password:
mount: невозможно найти /dev/sdd1 в /etc/fstab или /etc/mtab
romandoctor@romandoctor-desktop:~$

Я и понимаю, что ему невозможно, он же usb и в fstab ему делать нечего.

Как его ручками-то попробовать грамотно?

Оффлайн uptime

  • Новичок
  • *
  • Сообщений: 9
  • drinker with computing problems
    • Просмотр профиля
Re: Проблема с USB NTFS диском в KDE
« Ответ #3 : 22 Сентябрь 2007, 03:17:16 »
mkdir /media/usb-ntfs-400
sudo mount -t ntfs-3g /dev/sdd1 /media/usb-ntfs-400

чего маунт в фстаб то лезет? Файловую систему узнать хочет, куды монтировать и прочие опции (:
Успехов!
uptime>smtp>ru

Оффлайн romandoctor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Re: Проблема с USB NTFS диском в KDE
« Ответ #4 : 22 Сентябрь 2007, 21:15:26 »
Спасибо огромное, замонтировался. Я даже почти понял, что сделал при помощи этой команды. А вот что нужно дописать, чтобы он монтировался автоматом при включении?

Оффлайн ColdEgo

  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Проблема с USB NTFS диском в KDE
« Ответ #5 : 28 Декабрь 2007, 02:15:37 »
Спасибо огромное, замонтировался. Я даже почти понял, что сделал при помощи этой команды. А вот что нужно дописать, чтобы он монтировался автоматом при включении?
Полагаю, достаточно установить ntfs-config и разрешить запись на NTFS через ntfs-3g (он добавит соответстующую policy для hal). И чтобы не ругался на "hal-storage-removable-mount-all-options refused uid 1000" убрать галку в свойствах "mount as user".

Хуже другое....Автоматом-то NTFS-ный раздел на USB-драйве монтируется в Кедах...только вот русских файлов и папок нихрена не видит... :(((
Если юзать Disk Manager для монтирования NTFS-раздела - все отлично читается и пишется. Всего лишь потому, что он умеет добавлять опцию монтирования "locale=ru_UA.UTF-8" (см. http://www.ntfs-3g.org/support.html#locale).
Проверил /usr/share/hal/fdi/policy/10osvendor/20-storage-metods.fdi :
 
Цитировать
<!-- allow these mount options for ntfs -->
      <match key="volume.fstype" string="ntfs">
   <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">
     <append key="volume.mount.valid_options" type="strlist">utf8</append>   
     <append key="volume.mount.valid_options" type="strlist">uid=</append>
     <append key="volume.mount.valid_options" type="strlist">gid=</append>
     <append key="volume.mount.valid_options" type="strlist">umask=</append>
     <append key="volume.mount.valid_options" type="strlist">locale=</append>
   </match>
- опция локали должна быть, но в KDE ее не видно и соотв. выставить нельзя... Баг KDE? Или баг policy?
Linux Mint 17.3 "Rosa" (Intel Core i5 M520, 4GB RAM, Nvidia Quadro NVS 3100M)
Registered linux user #439313

Оффлайн max5555

  • Любитель
  • *
  • Сообщений: 98
    • Просмотр профиля
    • Ubuntu-forward, Украина
Re: Проблема с USB NTFS диском в KDE
« Ответ #6 : 12 Апрель 2008, 04:59:53 »
Большое спасибо, ColdEgo, по крайней мере я хоть разобрался в глюках. Ведь автоматически смонтированный NTFS не только не видит файлы с кириллическими именами, но и отказывается их копировать, а я, блин при испытаниях как раз кажется и гонял русский файл и уже почти совсем запутался...

Кажется вот здесь: KDE, монтирование дисков, кодировка человек разобрался в чем дело и вроде бы как в KDE4 проблема будет решена.
« Последнее редактирование: 12 Апрель 2008, 05:03:56 от max5555 »

Оффлайн pizzdos

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Проблема с USB NTFS диском в KDE
« Ответ #7 : 14 Октябрь 2008, 18:48:43 »
решал у себя ету проблему по етому мануалу
http://tty.org.ru/node/13

 

Страница сгенерирована за 0.07 секунд. Запросов: 22.