Форум русскоязычного сообщества Ubuntu


Автор Тема: firestarter падает ppp0  (Прочитано 3032 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн S@B@K@

  • Автор темы
  • Любитель
  • *
  • Сообщений: 76
    • Просмотр профиля
firestarter падает ppp0
« : 20 Сентябрь 2007, 10:31:40 »
после установки firestarter`a и настройки на шару инета(ppp0) по локалке wifi (ath0) падает ppp0 и не поднимается, пока не остановлю firestarter.
в чем может быть косяк?

Оффлайн denvist

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: firestarter падает ppp0
« Ответ #1 : 20 Сентябрь 2007, 10:58:39 »
Да нафиг тебе firestarter?
Разберись с IPTABLES - больше будешь знать.

Лично я без опыта настройки разобрался (ну более-менее) за 2 дня, всё пашет - инет и почта раздается
Ubuntu Gutsy Gibbon RC

Оффлайн DJArty

  • Участник
  • *
  • Сообщений: 199
    • Просмотр профиля
Re: firestarter падает ppp0
« Ответ #2 : 20 Сентябрь 2007, 12:16:11 »
firestarter работает (хотя вроде обещали доделать) только с одним интерфейсом, при этом например, либо сетка работает либо модем )

Оффлайн S@B@K@

  • Автор темы
  • Любитель
  • *
  • Сообщений: 76
    • Просмотр профиля
Re: firestarter падает ppp0
« Ответ #3 : 20 Сентябрь 2007, 12:56:30 »
2denvist
так и с iptables пытался настроить напрямую...
iptables -t nat -A POSTROUTING -s 192.168.0.0/16 -o ppp0 -j MASQUERADE
но ничего не вышло..
может подскажете, как дать инет в локалку, какие правила надо написать?
2DJArty
уже понял :)

Оффлайн Nick F0x

  • Активист
  • *
  • Сообщений: 317
  • Или ты имеешь мир, или наоборот, третьего не дано.
    • Просмотр профиля
    • f0x.ru
Re: firestarter падает ppp0
« Ответ #4 : 20 Сентябрь 2007, 13:36:02 »
firestarter работает (хотя вроде обещали доделать) только с одним интерфейсом, при этом например, либо сетка работает либо модем )
что-то в ваших речах не то, всё работает на ура, и с модемом и сеткой

Оффлайн DJArty

  • Участник
  • *
  • Сообщений: 199
    • Просмотр профиля
Re: firestarter падает ppp0
« Ответ #5 : 20 Сентябрь 2007, 14:39:05 »
что-то в ваших речах не то
ну может уже и сделали что, но с полгода-год назад пакеты что не касались контроллируемого им интерфейса (одного на выбор) не пропускались
Даже скрипты отдельные умельцы писали чтоб стартер переключался то на один то на другой интерфейс в зависимости от того откуда пакеты идут
« Последнее редактирование: 20 Сентябрь 2007, 14:45:11 от DJArty »

Оффлайн denvist

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: firestarter падает ppp0
« Ответ #6 : 20 Сентябрь 2007, 17:37:43 »
2denvist
так и с iptables пытался настроить напрямую...
iptables -t nat -A POSTROUTING -s 192.168.0.0/16 -o ppp0 -j MASQUERADE
но ничего не вышло..
может подскажете, как дать инет в локалку, какие правила надо написать?
Я вообще настроил так:
Инет раздается пользователям через squid. Это вообще просто. Авторизация по IP
Мыло пользователи получают с помощью iptables, смотри в конфе проброс NAT.
Ну и соответственно, в почтовых программах настройка - 192.168.0.1:8110 и 192.168.0.1.:8025

[вложение удалено Администратором]
« Последнее редактирование: 20 Сентябрь 2007, 20:44:13 от denvist »
Ubuntu Gutsy Gibbon RC

Оффлайн S@B@K@

  • Автор темы
  • Любитель
  • *
  • Сообщений: 76
    • Просмотр профиля
Re: firestarter падает ppp0
« Ответ #7 : 21 Сентябрь 2007, 13:31:21 »
2denvist
Спасибо огромное!!!! :)
поднял squid и все работает. :)

Оффлайн denvist

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: firestarter падает ppp0
« Ответ #8 : 21 Сентябрь 2007, 14:48:11 »
как грится - курите маны =)
ты еще к squid прикрути squidguard чтобы рулить кому куда можно ходить, я с этим пока не разбирался, нет времени
Ubuntu Gutsy Gibbon RC

Оффлайн S@B@K@

  • Автор темы
  • Любитель
  • *
  • Сообщений: 76
    • Просмотр профиля
Re: firestarter падает ppp0
« Ответ #9 : 22 Сентябрь 2007, 13:07:04 »
та мне это в принципе не надо?? просто надо было дать инет на ноут по wifi :)

Оффлайн Switcher

  • Участник
  • *
  • Сообщений: 203
    • Просмотр профиля
Re: firestarter падает ppp0
« Ответ #10 : 22 Сентябрь 2007, 14:11:27 »
2 S@B@K@:
В принципе, правило для iptables верное, может забыл форвардинг пакетов включить?
#echo 1 > /proc/sys/net/ipv4/ip_forward

 

Страница сгенерирована за 0.055 секунд. Запросов: 22.