Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Почему в Ubuntu репозиториях хранятся старые версии программ  (Прочитано 502 раз)

0 Пользователей и 1 Гость просматривают эту тему.

soldies

  • Автор темы
  • Гость
Почему в Ubuntu репозиториях хранятся неверорятно старые версии программ?
И почему нечего нельзя поставить из исходников? Ведь на оф. сайтах хранятся не DEB пакеты а именно исходники, а при компиляции исходников всегда ошибки и информации по решению этих ошибок не в README не в INSTALL файлах нет!
Подскажите как вы решаете проблемы с установкой нового ПО.

Оффлайн 4life

  • Участник
  • *
  • Сообщений: 118
  • I am Linux
    • Просмотр профиля
Какие именно продукты вам нужны? С такой проблемой не сталкивался, на ланчпаде есть всё.
« Последнее редактирование: 04 Январь 2011, 18:14:08 от 4life »

Оффлайн hippi90

  • Активист
  • *
  • Сообщений: 433
    • Просмотр профиля
Для компиляции из исходников нужны developer-версии пакетов. Смотрим на что ругается configure/make и ставим соответствующие пакеты, и всё соберется.

soldies

  • Автор темы
  • Гость
К примеру мне нужен новый Rhythmbox я его нашел на https://launchpad.net/rhythmbox и на сайте проекта gnome так вот там и там лежат исходники версии  0.13.2
Но при компиляции он кричит
(Нажмите, чтобы показать/скрыть)

Оффлайн hippi90

  • Активист
  • *
  • Сообщений: 433
    • Просмотр профиля
Попробовать sudo apt-get build-dep rhythmbox

Оффлайн Renaissance

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2121
    • Просмотр профиля
0.13.2 на 10.04 не установится, он слишком привязан к новым индикаторам в Маверике.

soldies

  • Автор темы
  • Гость
0.13.2 на 10.04 не установится, он слишком привязан к новым индикаторам в Маверике.
А вот за информацию спасибо!

 

Страница сгенерирована за 0.053 секунд. Запросов: 22.