Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: stop deamon autostart problem (vsftpd)  (Прочитано 2700 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн daggerok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
stop deamon autostart problem (vsftpd)
« : 10 Январь 2011, 23:37:06 »
Доброго времени суток, уважаемые. подскажите в чем может быть пробелма...
установил на свою Ubuntu 10.10 vsftpd, настроил на анонимный доступ с аплоадом, чтобы в случае необходимости моно было включить фтп и залить на ноут чего-нить или наоборот - другим дать скачать. устанавливал через sudo aptitude install vsftpd
проблема в том что я не могу заставить фтп не стартовать при запуске системы, планировал запускать его только в случае необходимости.

короче, делал так:
# sudo update-rc.d -f vsftpd remove

# sudo aptitude install sysv-rc-conf
# sysv-rc-conf --level 2345 vsftpd off

# sudo aptitude install bum
# bum
....

не помогло

я даже убрал все стартовые скрипты из /etc/init.d/ и /etc/rc*.d/
всеравно не помогло - эта зарада по прежнему запускается!
# sudo sockstat | grep ftp
root     vsftpd               1883     tcp4   *:21                      *:*                       LISTEN

помогает только:
# sudo service vsftpd stopи
# sudo killall -9 vsftpd
я канешн могу наприсать в кроне что-то типа:
@reboot root killall -9 vsftpdили
@reboot root sleep 60 && service vsftpd stopно вель это не выход.

подскажите кто знает в чем я туплю и как мне сделать то что надо (хочу чтобы он не стартовал автоматом, а запускать его ручками только тогда, когда мне этого захочется).

зы, спасибо!
« Последнее редактирование: 10 Январь 2011, 23:50:14 от daggerok »

Оффлайн vasilisc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2563
  • г.Северодвинск - строим АПЛ
    • Просмотр профиля
    • Авторские статьи об OpenSource
Re: stop deamon autostart problem (vsftpd)
« Ответ #1 : 11 Январь 2011, 09:57:31 »
в конфигурационном файле vsftpd есть параметр listen со значением YES по умолчанию
(Нажмите, чтобы показать/скрыть)

Сделайте его в NO и он не будет работать в standalone режиме.

У вас возможно используется Upstart. Дайте для проверки выводы команд
ls -laF /etc/init|grep ftp

aptitude show upstart
Ускорение http://vasilisc.com/speedup_ubuntu
Железо http://vasilisc.com/hcl/detect.php
Призёр http://vasilisc.com/ubuntu_woman Если помог, то поддержите WM R259039388254

Оффлайн daggerok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: stop deamon autostart problem (vsftpd)
« Ответ #2 : 11 Январь 2011, 11:20:53 »
поставил listen=NO, теперь демон vsftpd не стартует ни при запуске системы ни в ручную

upstart:
mak@kostromin-nb:~$ l /etc/init| grep ftp
-rw-r--r--   1 root root  744 2010-09-03 20:08 vsftpd.conf
mak@kostromin-nb:~$ aptitude show upstart
Пакет: upstart                                   
Состояние: установлен
Автоматически установлен: нет
Версия: 0.6.6-3
Приоритет: необходимый
Раздел: admin
Сопровождающий: Scott James Remnant <scott@ubuntu.com>
Размер в распакованном виде: 655k
Зависимости: libc6 (>= 2.4), libdbus-1-3 (>= 1.2.16), libnih-dbus1 (>= 1.0.0), libnih1 (>= 1.0.0), libudev0 (>= 151-5), sysvinit-utils, sysv-rc, initscripts,
                        mountall, ifupdown (>= 0.6.8ubuntu29)
Конфликтует: startup-tasks, system-services, sysvinit, upstart-compat-sysv, upstart-job
Заменяет: startup-tasks, system-services, sysvinit, upstart-compat-sysv, upstart-job
Предоставляет: startup-tasks, system-services, upstart-compat-sysv, upstart-job
Описание: служба начальной загрузки системы на основе событий
 upstart -- это замена службы /sbin/init, которая организует запуск других служб и задач при запуске системы, их останов при выключении системы, а также
 контролирует их во время работы системы.
Сайт: http://upstart.ubuntu.com/


Оффлайн vasilisc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2563
  • г.Северодвинск - строим АПЛ
    • Просмотр профиля
    • Авторские статьи об OpenSource
Re: stop deamon autostart problem (vsftpd)
« Ответ #3 : 11 Январь 2011, 11:28:51 »
верните listen=YES и удалите /etc/init/vsftpd.conf  так как у вас установлен и используется система Upstart и службы запускает она

Ускорение http://vasilisc.com/speedup_ubuntu
Железо http://vasilisc.com/hcl/detect.php
Призёр http://vasilisc.com/ubuntu_woman Если помог, то поддержите WM R259039388254

Оффлайн daggerok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: stop deamon autostart problem (vsftpd)
« Ответ #4 : 11 Январь 2011, 12:14:26 »
ок, как теперь запускать vsftpd? приведенная ссылка про upstart не помогла.

mak@kostromin-nb:~$ sudo service vsftpd start
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service vsftpd start

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the start(8) utility, e.g. start vsftpd
start: Unknown job: vsftpd
« Последнее редактирование: 11 Январь 2011, 12:51:07 от daggerok »

Оффлайн vasilisc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2563
  • г.Северодвинск - строим АПЛ
    • Просмотр профиля
    • Авторские статьи об OpenSource
Re: stop deamon autostart problem (vsftpd)
« Ответ #5 : 11 Январь 2011, 13:40:47 »
ок, как теперь запускать vsftpd? приведенная ссылка про upstart не помогла.

mak@kostromin-nb:~$ sudo service vsftpd start
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service vsftpd start

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the start(8) utility, e.g. start vsftpd
start: Unknown job: vsftpd
вы удалили конфиг и теперь запускать через Upstart нельзя методом sudo service vsftpd startтеперь просто с Терминале или с ярлыка vsftpd
Ускорение http://vasilisc.com/speedup_ubuntu
Железо http://vasilisc.com/hcl/detect.php
Призёр http://vasilisc.com/ubuntu_woman Если помог, то поддержите WM R259039388254

Оффлайн daggerok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: stop deamon autostart problem (vsftpd)
« Ответ #6 : 11 Январь 2011, 13:51:15 »
что-то типа /usr/sbin/vsftpd &в общем дальше сам разберусь, спасибо за помощь!

Пользователь решил продолжить мысль 11 Январь 2011, 15:17:41:
такс... через /usr/sbin/vsftpd & не работает, походу нужно таки запускать при помощи скрипта, пожскажите как переписать его для запуска через терминал, вот тот который лежал в /etc/init/:
# cat /etc/init/vsftpd.conf
# vsftpd - FTP Daemon
#

description     "vsftpd daemon"
author          "Chuck Short <zulcss@ubuntu.com>"

start on (filesystem
        and net-device-up IFACE!=lo)
stop on runlevel [!2345]
respawn

pre-start script
        check_standalone_mode()
        {
                # Return 1 if vsftpd.conf doesn't have listen yes or listen_ipv6=yes
                CONFFILE="/etc/vsftpd.conf"

                if [ -e  "${CONFFILE}" ] && !egrep -iq "^ *listen(_ipv6)? *= *yes" "${CONFFILE}"
                then
                        echo "${CONFFILE}: listen disabled - service will not start"
                        return 1
                fi
        }
        [ -d /var/run/vsftpd ] || install -m 755 -o root -g root -d /var/run/vsftpd
        [ -d /var/run/vsftpd/empty ] || install -m 755 -o root -g root -d /var/run/vsftpd/empty
        check_standalone_mode || exit 0
end script

exec /usr/sbin/vsftpd

Пользователь решил продолжить мысль 11 Январь 2011, 18:10:42:
установил openssh-server - такая же проблема...
pstree показывает что sshd и vsftpd запускает init а ни какой-то upstart, как же это так?
не пойму, разве это нормально? кто-то сталкивался с такой проблемой?

зы - почему нельзя установить службу буз ее автозапуска?
или все это баг?

и вот еще какой прикол:
mak@kostromin-nb:~$ sudo /etc/init.d/ssh stop
 * Stopping OpenBSD Secure Shell server sshd                                                                                                          [ OK ]
mak@kostromin-nb:~$ sudo /etc/init.d/ssh status
 * sshd is running

Пользователь решил продолжить мысль 12 Январь 2011, 02:33:51:
вы удалили конфиг и теперь запускать через Upstart нельзя методом sudo service vsftpd startтеперь просто с Терминале или с ярлыка vsftpd
в общем разобрался.

1. ничего удалять не нужно
2. чтобы демон не запускался при старте системы, надо просто коментить строку (start on...) в конфигурационном файле init-a /etc/init/*.conf

для запуска приложения, когда это нужно, надо пользоваться командой servise.
« Последнее редактирование: 12 Январь 2011, 02:33:51 от daggerok »

 

Страница сгенерирована за 0.107 секунд. Запросов: 22.