Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: [РЕШЕНО] LAMP блокирует XAMPP?  (Прочитано 1327 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SPolischook

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
[РЕШЕНО] LAMP блокирует XAMPP?
« : 12 Январь 2011, 09:27:47 »
Установил XAMPP, но при перезапуске компьютера его блокирует другой сервер :o
если набираю
sudo invoke-rc.d apache2 stopзатем
sudo /opt/lampp/lampp startТо запускается XAMPP и все работает нормально.
Может кто подскажет что я не так сделал? Устанавливал по инструкции от сюда http://kotoblog.pp.ua/ubuntu/xamppxdebug-na-ubuntu-1010.html
И самое главное, как это исправить!
Заранее благодарен.
« Последнее редактирование: 12 Январь 2011, 21:06:14 от SPolischook »

Оффлайн vasilisc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2563
  • г.Северодвинск - строим АПЛ
    • Просмотр профиля
    • Авторские статьи об OpenSource
Re: LAMP блокирует XAMPP?
« Ответ #1 : 12 Январь 2011, 09:35:45 »
99,99% что используется один и тот же порт
можете проверить, запуская по очереди сначала apache и остановив xampp
sudo netstat -nap4|grep apache
а потом наоборот и проверив
sudo netstat -nap4|grep имя_процесса_xampp
в конфигурационных файлах программ, кому-то придется изменить используемый порт.
думаю лучше изменить xampp
Ускорение http://vasilisc.com/speedup_ubuntu
Железо http://vasilisc.com/hcl/detect.php
Призёр http://vasilisc.com/ubuntu_woman Если помог, то поддержите WM R259039388254

Оффлайн SPolischook

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: LAMP блокирует XAMPP?
« Ответ #2 : 12 Январь 2011, 09:52:24 »
а где порт менять?
здесь?
sudo gedit /opt/lampp/etc/php.ini

Оффлайн vasilisc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2563
  • г.Северодвинск - строим АПЛ
    • Просмотр профиля
    • Авторские статьи об OpenSource
Re: LAMP блокирует XAMPP?
« Ответ #3 : 12 Январь 2011, 10:45:43 »
Только счас прочёл что вы ставите и с чем это едят.
В обоих проектах есть буква А, которая обозначает Apache и естественно оба хотят на один и тот же порт.
Счас нужно курить мануалы и искать где лежат конфиги обоих проектов и искать параметр Listen/Bind/Port и тд и тп и разносить на разные порты
Ускорение http://vasilisc.com/speedup_ubuntu
Железо http://vasilisc.com/hcl/detect.php
Призёр http://vasilisc.com/ubuntu_woman Если помог, то поддержите WM R259039388254

Оффлайн testerka

  • Активист
  • *
  • Сообщений: 408
  • Век живи - век учись.
    • Просмотр профиля
Re: LAMP блокирует XAMPP?
« Ответ #4 : 12 Январь 2011, 12:42:18 »
тож интересно, где настройки у xampp

Пользователь решил продолжить мысль 12 Январь 2011, 12:43:26:
а где порт менять?
здесь?
sudo gedit /opt/lampp/etc/php.ini
точно не тут, конфиг то от пыха
UBUNTU 10.10 + TT-budget S-1401=36Е

Оффлайн SPolischook

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: LAMP блокирует XAMPP?
« Ответ #5 : 12 Январь 2011, 15:59:35 »
Мне два Апача не нужны. Ставил только XAMPP хотя пока туда-сюда дергался мог доставить. Подскажите как удалить LAMP и думаю на этом можно будет закончить :) Огромное спасибо, что не оставили без внимания!  :angel:

Гарри Кашпировский

  • Гость
Re: LAMP блокирует XAMPP?
« Ответ #6 : 12 Январь 2011, 17:59:41 »
Зачем удалять? Не проще просто perl доставить?

Оффлайн testerka

  • Активист
  • *
  • Сообщений: 408
  • Век живи - век учись.
    • Просмотр профиля
Re: LAMP блокирует XAMPP?
« Ответ #7 : 12 Январь 2011, 18:09:31 »
где у xampp порт менять?
UBUNTU 10.10 + TT-budget S-1401=36Е

Оффлайн SPolischook

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: LAMP блокирует XAMPP?
« Ответ #8 : 12 Январь 2011, 21:04:17 »
Для себя решил проблему так.
  • Удалил из авозагрузки Апач
  • Создал скрипт и кнопки для запуска, рестарта, и остановки XAMPP

Скрипт:
#!/bin/bash
foo=`gksudo -u root -k -m "введите пароль root" /bin/echo "А вы рут?"`
if [ "$1" = "stop" ]; then
    sudo /opt/lampp/./lampp stop
fi
if [ "$1" = "restart" ]; then
    sudo /opt/lampp/./lampp restart
fi
if [ "$1" = "start" ]; then
    sudo /opt/lampp/./lampp start
fi
Скопировать в GEdit, сохранил под именем XAMPP в домашний каталог, сделал исполняемым.
На рабочем столе создал кнопку Старт. В свойствах кнопки прописал /home/someuser/xamppscript start (someuser -> заменить на имя пользователя!). По аналогии с остальными. Получилось как в Денвере. :)
Спасибо автору скрипта http://inthecircle.org/forum/thread29-1.html
Также полное руководство по реализации XAMPP + XDebug можно посмотреть здесь  http://kotoblog.pp.ua/ubuntu/xamppxdebug-na-ubuntu-1010.html

Оффлайн vadbars

  • Любитель
  • *
  • Сообщений: 54
  • LinuxMint 13 Mate (u12.04) на ноуте asus k50c
    • Просмотр профиля
Re: [РЕШЕНО] LAMP блокирует XAMPP?
« Ответ #9 : 04 Ноябрь 2012, 22:05:50 »
Напоролся на ту же проблему.

Нашел такие варианты решения:
Вариант 1: sudo update-rc.d apache2 disable
Вариант 2: sudo chkconfig apache2 off

Первый помог, поэтому второй не проверял. :)

Оффлайн vadbars

  • Любитель
  • *
  • Сообщений: 54
  • LinuxMint 13 Mate (u12.04) на ноуте asus k50c
    • Просмотр профиля
Re: [РЕШЕНО] LAMP блокирует XAMPP?
« Ответ #10 : 06 Ноябрь 2012, 08:39:02 »
Второй вариант у меня не работает - не находит chkconfig.

Понадобилось также убрать из автостарта MySQL. Помогло такое:
sudo mv /etc/init/mysql.conf /etc/init.d/mysql.disabled

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.