Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Проблема с NVIDIA Twinview  (Прочитано 1765 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tweakerilla

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Проблема с NVIDIA Twinview
« : 15 Январь 2011, 20:20:24 »
Доброго времени суток, прошу о помощи с настройкой опции twinview. Ситуация следующая:
Имеется компьютер с видеокартой NVIDIA GTS 250 с 1gb видеопамяти, ОС - UBUNTU 10.10 (x86) и WinXP (x86), основной монитор Acer* и телевизор Philips Model № 42PFL9632D/10 (ПО Q581E-0.64.14.22), подключенный к компьютеру по средству кабеля HDMI-HDMI.
При использовании опции twinview на ubuntu периодически пропадает изображение на телевизоре с надписями "Не поддерживаемый формат видео/Нет сигнала". Таким образом просмотр фильма превращается в кучу "позитивных" эмоций. Версия драйвера NVIDIA 260.19.06. Должен заметить что на WinXP такой проблемы нет, но вариант просмотра фильмов на win* не вариант вообще. Так же должен заметить что подобная проблема была с предыдущей версией (10.04) и драйверами версий 256 и предыдущих. Поэтому считаю что дело именно в настройках.
В ubuntu я не уверенный пользователь, поэтому прошу писать понятным языком.
Заранее спасибо

Оффлайн suslikk

  • Старожил
  • *
  • Сообщений: 2457
    • Просмотр профиля
Re: Проблема с NVIDIA Twinview
« Ответ #1 : 15 Январь 2011, 20:34:15 »
покажите вывод в терминале команды:
cat /etc/X11/xorg.conf
Нарисуй свой город на openstreetmap.org

Оффлайн tweakerilla

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Проблема с NVIDIA Twinview
« Ответ #2 : 15 Январь 2011, 20:40:55 »
Section "Screen"
   Identifier   "Default Screen"
   DefaultDepth   24
EndSection

Section "Module"
   Load   "glx"
EndSection

Section "Device"
   Identifier   "Default Device"
   Driver   "nvidia"
   Option   "NoLogo"   "True"
EndSection


Оффлайн tweakerilla

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Проблема с NVIDIA Twinview
« Ответ #4 : 15 Январь 2011, 21:33:43 »
2 stmc:
сделал как там написано, но проблема все равно осталась, сейчас просто при загрузке системы опция twinview сама включается. Теперь вывожу результат "cat etc/X11/xorg.conf" после предложенных изменений

Section "Screen"
Option         "TwinView"
Option         "TVOutFormat" "AUTOSELECT"
Option         "TVStandard" "PAL-B"
   Identifier   "Default Screen"
   DefaultDepth   24
EndSection

Section "Module"
   Load   "glx"
EndSection

Section "Device"
   Identifier   "Default Device"
   Driver   "nvidia"
   Option   "NoLogo"   "True"
EndSection

Править данный файл, насколько я понял, нужно было Gedit'ом.
Проблема осталась.

Оффлайн gaudin

  • Участник
  • *
  • Сообщений: 227
    • Просмотр профиля
Re: Проблема с NVIDIA Twinview
« Ответ #5 : 15 Январь 2011, 22:03:47 »
Как ты настраиваешь видеокарту через х-сервер или Gedit'ом? Вот мои настройки:
Section "Screen"
   Identifier     "Screen0"
   Device         "Device0"
   Monitor        "Monitor0"
   Option         "TwinView" "0"
   Option         "TwinViewXineramaInfoOrder" "CRT-0"
   Option         "metamodes" "CRT: 1360x768 +0+0"
   DefaultDepth   24
   SubSection "Display"
      Depth       24
   EndSubSection

Заходишь в х-сервер, выбираешь конфигурацию дисплея, настраиваешь мониторы под себя.
Потом жмешь сохранить х конфигурацию в файл. Перегружаешься и смотришь.
« Последнее редактирование: 15 Январь 2011, 22:08:55 от gaudin »
Ubuntu 10.04.01 ядро 2.6.37-12

Оффлайн tweakerilla

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Проблема с NVIDIA Twinview
« Ответ #6 : 15 Январь 2011, 22:34:10 »
Спасибо, теперь понял и вот как стал выглядеть "cat /etc/X11/xorg.conf"

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 260.19.06  (buildd@palmer)  Mon Oct  4 16:01:38 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer V203W"
    HorizSync       31.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTS 250"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1680+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Но проблема осталась

Оффлайн gaudin

  • Участник
  • *
  • Сообщений: 227
    • Просмотр профиля
Re: Проблема с NVIDIA Twinview
« Ответ #7 : 15 Январь 2011, 23:18:42 »
У меня version 260.19.29. Подключи репазитарий:
ppa:ubuntu-x-swat/x-updates
и обнови nvidia дрова.
Ubuntu 10.04.01 ядро 2.6.37-12

Оффлайн tweakerilla

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Проблема с NVIDIA Twinview
« Ответ #8 : 16 Январь 2011, 18:18:22 »
Всем большое спасибо.  Драйвера обновил. Весь день гонял, и, вроде, все хорошо. Изображение пропадало, но всего 2 раза и на очень короткий промежуток времени, а не как раньше - по пол часа не мог вернуть изображение. Еще раз спасибо. :)

Оффлайн gaudin

  • Участник
  • *
  • Сообщений: 227
    • Просмотр профиля
Re: Проблема с NVIDIA Twinview
« Ответ #9 : 16 Январь 2011, 22:02:51 »
Всем большое спасибо.  Драйвера обновил. Весь день гонял, и, вроде, все хорошо. Изображение пропадало, но всего 2 раза и на очень короткий промежуток времени, а не как раньше - по пол часа не мог вернуть изображение. Еще раз спасибо. :)
У меня пропадает изображение только во время включения телевизора на 2 секунды, а у тебя когда?
Ubuntu 10.04.01 ядро 2.6.37-12

Оффлайн tweakerilla

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Проблема с NVIDIA Twinview
« Ответ #10 : 17 Январь 2011, 06:45:22 »
У меня при включении сигнал (изображение) не пропадает, в основном при развертывании видео плеера на весь экран, но далеко не всегда, да и может пропасть в процессе просмотра: начало/середина/конец видео файла. Но сейчас стало намного реже и меньше по времени (примерно 2-3 сек) как я уже говорил. Вот например вчера после того как отписался, включил фильмец под сон изображение пропало на 2-3 сек с надписями "Неподдерживаемый формат видео/Нет видеосигнала" и тут же появилось изображение, и все было хорошо около 2-2,5 часов, потом уснул. Так что я думаю проблема решена "тьфу-тьфу-тьфу" :). Еще раз большое спасибо.

 

Страница сгенерирована за 0.215 секунд. Запросов: 23.