Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Ubuntu 7.0.4 и GEForce6100/nForce430  (Прочитано 1871 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн us5qvh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
Ubuntu 7.0.4 и GEForce6100/nForce430
« : 29 Сентябрь 2007, 10:29:37 »
Установил версию для AMD64. Разрешение экрана выше 1024х768 не переключается (а для моего монитора родное - 1280х1024). В xorg.conf прописан драйвер "vesa", как установить то, что нужно? Нужно "nv" или "nvidia"? Если для этого нужно что-то скачать, можно точные ссылки или хотя бы названия пакетов со всеми зависимостями (на той машине Интернета почти нет, а скачанные на работе пакеты можно и поштучно поставить через dpkg --install)? Restricted driver manager не работает: показывает, что драйвер от Nvidia "Не задействован". При попытке его включить (установить галочку) вылазит диалог "Вы точно хотите его включить? Да/Нет", но после нажатия "Да" ничего не происходит.
И вторая проблема - звук. Сразу после загрузки звук очень громкий, и сопровождается громким противным свистом. При попытке регулировки громкости пропадает начисто до перезагрузки. Как это можно исправить?

Оффлайн ardn

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #1 : 29 Сентябрь 2007, 20:21:29 »
Драйвер - nvidia,
еще установи пакет nvidia-config (кажется так называется), проблема с экраном должна решиться

Оффлайн us5qvh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #2 : 30 Сентябрь 2007, 14:14:30 »
Спасибо, скачаю, попробую.

Оффлайн us5qvh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #3 : 08 Октябрь 2007, 10:12:49 »
При попытке прописать драйвер nvidia - "Module not found" и иксы не запускаются. Как называется недостающий пакет? С драйвером nv работает.
И ещё осталась проблема со звуком: звук сопровождается громким противным свистом, при попытке регулировки громкости пропадает до следующей перезагрузки. Уже видел тему  с подобными симптомами на чипсете от Intel, а на этом что делать? Вот что выводит по этому поводу lspci: "00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)"

Оффлайн us5qvh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #4 : 09 Декабрь 2007, 13:01:23 »
После замены винта снова пытаюсь настроить Ubuntu 7.0.4. Вопрос о видеорежимах так и остался. Сейчас стоят пакеты: linux-resricted-modules, nvidia-xconfig, nvidia-settings. Результат: модуль ядра nvidia автоматически не загружается. Вручную (modprobe) загружается, но не используется (lsmod показывает его как неиспользуемый). Видеорежим по прежнему не выше 1024x768. nvidia-settings совсем не работает, пишет, что не найден NV-CONTROL на текущем дисплее. nvidia-xconfig молча, не задавая никаких вопросов, переписывает xorg.conf, после чего иксы вообще не запускаются, потому что он пишет туда "driver "nvidia"", которого, похоже, вообще нет. После замены на "nv" иксы запускаются и всё работает как и было. Попробовал вручную добавить разрешение 1280x1024 (родное для моего монитора) в списки в xorg.conf - ничего не изменилось. "Менеджер проприетарных драйверов" при попытке включить драйвер Nvidia пишет, что надо удалить linux-resricted-modules, nvidia-xconfig, nvidia-settings и установить nvidia-glx. Что ещё нужно установить?

Оффлайн ShPioN

  • Активист
  • *
  • Сообщений: 268
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #5 : 09 Декабрь 2007, 14:31:17 »
После замены винта снова пытаюсь настроить Ubuntu 7.0.4. Вопрос о видеорежимах так и остался. Сейчас стоят пакеты: linux-resricted-modules, nvidia-xconfig, nvidia-settings. Результат: модуль ядра nvidia автоматически не загружается. Вручную (modprobe) загружается, но не используется (lsmod показывает его как неиспользуемый). Видеорежим по прежнему не выше 1024x768. nvidia-settings совсем не работает, пишет, что не найден NV-CONTROL на текущем дисплее. nvidia-xconfig молча, не задавая никаких вопросов, переписывает xorg.conf, после чего иксы вообще не запускаются, потому что он пишет туда "driver "nvidia"", которого, похоже, вообще нет. После замены на "nv" иксы запускаются и всё работает как и было. Попробовал вручную добавить разрешение 1280x1024 (родное для моего монитора) в списки в xorg.conf - ничего не изменилось. "Менеджер проприетарных драйверов" при попытке включить драйвер Nvidia пишет, что надо удалить linux-resricted-modules, nvidia-xconfig, nvidia-settings и установить nvidia-glx. Что ещё нужно установить?
поиском попользоваться не судьба? введите в строку поиска "Установка драйвера nvidia", без кавычек естественно.

Оффлайн us5qvh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #6 : 09 Декабрь 2007, 16:16:53 »
Посмотрел, там про установку драйвера с оф. сайта, чуть ли не ядро пересобирать надо. А в репозитории его разве нет? Чтобы скачать один-два пакета, поставить и всё работало. Как в Debian или ALT.

Оффлайн ShPioN

  • Активист
  • *
  • Сообщений: 268
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #7 : 09 Декабрь 2007, 16:23:43 »
скачай linux-restricted-modules, nvidia-kernel-common, nvidia-glx-new, вроде это и нужно.

Оффлайн us5qvh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #8 : 09 Декабрь 2007, 16:31:24 »
nvidia-kernel-common уже стоит (он же есть в зависимостях linux-restricted-modules). nvidia-glx-new сегодня попробую, утром напишу, что получится (на той машине Интернета нет, вот и качаю пакеты поштучно на работе :)).

Оффлайн Svertal

  • Активист
  • *
  • Сообщений: 893
  • КиберПанк
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #9 : 10 Декабрь 2007, 09:55:59 »
У меня на gf6100 машин 10 стоит с ubuntu 7.04, ни с одной проблем не было, собственно действовал так:

1. После установки и перезагрузки включал эффекты рабочего стола, сразу за этим предлагалось скачать и установить драйвера nvidia, соглашался, после загрузки и установки драйверов предлагалось перезагрузится;
2. После перезагрузки драйвера стояли, и все работало. На тех машинах где стояли мониторы Acer 1916, разрешение на автомате определялось как 1024 на 768, исправлялось либо ручной правкой xorg.conf , либо как ранее в теме советовали, запуском nvidia-settings, графическая утилита позволяющая менять ряд параметров видеокарты, записывающая в  конечном итоге все изменения в тот же xorg.conf.

Абсолютно никаких плясок с правкой nv на nvidia и т.п. не требовалось.

Оффлайн us5qvh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #10 : 10 Декабрь 2007, 10:09:55 »
Так понятно, что если с этой машины есть доступ к Интернету, всё что надо само поставится и будет работать. Не зря же я тут про точные названия пакетов спрашиваю, что их надо вручную скачать и на ту машну отнести.

После установки nvidia-glx-new всё выглядит точно так же, как и с linux-restricted-modules - с драйвером "nvidia" иксы не запускаются (вот забыл посмотреть, что в логе пишет :(). Если же ставить nvidia-glx, которого требует "Менеджер проприетарных драйверов", среди кракозябр удалось разобрать, что не совпадают версии модулей в ядре (9755) и в иксах (9631).

Оффлайн ShPioN

  • Активист
  • *
  • Сообщений: 268
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #11 : 10 Декабрь 2007, 15:13:01 »
nvidia-glx несовместим с вашей видеокартой. только nvidia-glx-new. у вас случаем не стоят проприетарные дрова от нвидия? т.е. вы может еще вручную ставили дрова?

Оффлайн us5qvh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #12 : 13 Декабрь 2007, 12:45:35 »
Нет, вручную никаких драйверов не ставил. Вчера после удаления nvidia-glx и установки nvidia-glx-new всё заработало. После перезагрузки тоже работает, в xorg.conf прописан драйвер "nvidia", модуль ядра nvidia загружается и задействован, в общем, всё нормально. Непонятно только почему тогда сразу не работало, когда я его ставил?

Оффлайн andre

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #13 : 27 Январь 2008, 20:57:37 »
У меня точно такая мать с видео. Правда стоит Рунту 2.0. Так вот после установки системы подшаманил менеджер проприетарных драйверов и через него поставил драйвер. После перезагрузки заработало и 3Д и эффекты раб.стола. Какие дрова менеджер ставил не знаю, единственное что он выдал - "драйвер для новых видеокарт NVIDIA"

Оффлайн udaffkaa

  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: Ubuntu 7.0.4 и GEForce6100/nForce430
« Ответ #14 : 29 Апрель 2009, 18:28:55 »
У меня на gf6100 машин 10 стоит с ubuntu 7.04, ни с одной проблем не было, собственно действовал так:

1. После установки и перезагрузки включал эффекты рабочего стола, сразу за этим предлагалось скачать и установить драйвера nvidia, соглашался, после загрузки и установки драйверов предлагалось перезагрузится;
2. После перезагрузки драйвера стояли, и все работало. На тех машинах где стояли мониторы Acer 1916, разрешение на автомате определялось как 1024 на 768, исправлялось либо ручной правкой xorg.conf , либо как ранее в теме советовали, запуском nvidia-settings, графическая утилита позволяющая менять ряд параметров видеокарты, записывающая в  конечном итоге все изменения в тот же xorg.conf.

Абсолютно никаких плясок с правкой nv на nvidia и т.п. не требовалось.

Подтверждаю. Похоже на баг.
На материнской плате NF61S Micro AM2 SE, чипсет от NVIDIA MCP61S ( GeForce 6100-405 ) + монитор ЖК Samsung SyncMaster 723n.
После установки ubuntu 9.0.4 максимальное разрешение экрана 800 на 600 при 60 герц. Правка/допись  в xorg.conf не помогала.
При вызове установки драйверов через Система-Параметры-Драйверы устройств выводило три драйвера от NVIDIA (Последний по версии и верхний по списку - 180 версия). Драйвер не активирован. При нажатии "Активировать" - "Скачиваю/установливаю" - 0% и зависало. Через 10-15 минут писало что обнаружена ошибка, отправить отчёт... Повторная активация драйвера становилось не доступно до следующей перезагрузки системы:(

Вариант предложенный Svertal прошол "на ура"!!! Драйвер тут же скачался и установился. После перезагрузки стали активны все режимы. В установленных драйвер от NVIDIA версии 180 значиться как активный....

Огромное спасибо Svertal:)


 

Страница сгенерирована за 0.058 секунд. Запросов: 22.