Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Подключение Sony Ericsson M600i  (Прочитано 1144 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн matiq

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Подключение Sony Ericsson M600i
« : 05 Октябрь 2007, 02:06:18 »
Такая ситуация:
Подключаю телефон к компьютеру. Выскакивает на телефоне окошко с выбором типа подключения. Выбираю режим передачи файлов (в этом режиме телефон распознается системой как флешка, и работа идет только с флэшкой на телефоне). Все монтируется автоматически, читает, копирует, вставляет. Но, при попытке отмонтировать, выскакивает сообщение, что идет запись, и нельзя извлекать устройство. И через долгое время выскакивает сообщение об ошибке. Соответственно файлы не записываются на телефон, или записываются, но их размер = 0 мб. А если подключаю телефон, и отмонтирую его, при этом файлы не записывая, все-равно выскакивает то сообщение, и минут через 5 пишет, что можно безопасно извлечь устройство.
Подскажите мне, пожалуйста, в чем может быть проблема.
Система - Ubuntu 7.04
Телефон рапознается, как dev/sdb.

Оффлайн Lolka

  • Участник
  • *
  • Сообщений: 162
  • Адепт высшей магии по Убунтизму
    • Просмотр профиля
Re: Подключение Sony Ericsson M600i
« Ответ #1 : 05 Октябрь 2007, 04:06:48 »
Надо добавить опцию sync монтирования. man mount на предмет sync (c)

Оффлайн matiq

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Подключение Sony Ericsson M600i
« Ответ #2 : 05 Октябрь 2007, 13:11:45 »
А как ее дописывать? Нету такого у меня в man mount. Эта опция ставить запись как в винде, или просто исправляет ошибку?

Оффлайн andruxa

  • Любитель
  • *
  • Сообщений: 84
    • Просмотр профиля
Re: Подключение Sony Ericsson M600i
« Ответ #3 : 05 Октябрь 2007, 14:07:07 »
как делаете umount? у меня все пишется нормально

Оффлайн matiq

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Подключение Sony Ericsson M600i
« Ответ #4 : 05 Октябрь 2007, 14:58:13 »
Правой кнопкой на пиктограмме -> Eject. А также umount /media/MATIQ (MATIQ - моя флэшка).
Я поставил на обычной флэшке опцию sync, так на нее теперь нельзя записывать. И в man mount написано, что sync работает не со всеми фаловыми системами, среди которых фат нет.

Оффлайн matiq

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Подключение Sony Ericsson M600i
« Ответ #5 : 05 Октябрь 2007, 15:09:26 »
Может у меня система какая-то не такая?! Просто я установил  Ubuntu с диска, которы мне по почте прислали! А брал у знакомого загруженный им dvd и установил. Попытался на него установить драйвер nVidia (не с репозитория, т.к. с репозитория у меня глючит при включении эффектов рабочего стола - пропадает, если я не ошибаюсь метасити. Короче пропадает то, где кнопки закрыть, свернуть развернуть) таким же образом, как я устанавливаю на Ubuntu со своего диска, так не работает так. Ошибку выдает после перезагрузки.

Оффлайн maniak

  • Активист
  • *
  • Сообщений: 489
    • Просмотр профиля
Re: Подключение Sony Ericsson M600i
« Ответ #6 : 05 Октябрь 2007, 15:36:41 »
Цитировать
Короче пропадает то, где кнопки закрыть, свернуть развернуть) таким же образом, как я устанавливаю на Ubuntu со своего диска, так не работает так. Ошибку выдает после перезагрузки.
Обсуждалось уже много раз.
Например, тут.

Пользуйся поиском и будет тебе счастье ;-)
« Последнее редактирование: 07 Октябрь 2007, 13:52:14 от maniak »

Оффлайн yaromir

  • Активист
  • *
  • Сообщений: 670
    • Просмотр профиля
Re: Подключение Sony Ericsson M600i
« Ответ #7 : 05 Октябрь 2007, 15:45:41 »
А что с опцией flush:
sudo mount -o flush -t vfat /dev/sdb /media/MATIQsync - сбрасывает кеш после каждого сектора
flush - сбрасывает кеш после каждого файла

Оффлайн matiq

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Подключение Sony Ericsson M600i
« Ответ #8 : 05 Октябрь 2007, 21:44:32 »
На счет поиска - спасибо, помогло! Учту в будущем :)

На счет sync, flush - оказывается работает! Все превосходно работает, только вот т.к. монтирование под рутом идет, то и вставлять, и отмонтировать надо тоже под рутом. Можно ли это как-то прописать, чтоб оно по умолчанию с такими опциями подключалось? И с обычными правами работать с флэшкой можно было бы?
« Последнее редактирование: 05 Октябрь 2007, 21:46:16 от matiq »

Оффлайн matiq

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Подключение Sony Ericsson M600i
« Ответ #9 : 06 Октябрь 2007, 00:08:58 »
Не, все-равно тот же бок. Короче, забиваю, пользуюсь виндой, жду 7.10 и буду пробовать.

 

Страница сгенерирована за 0.054 секунд. Запросов: 22.