Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Apache - скачиваются php файлы вместо интерпретации  (Прочитано 16558 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн avi9526

  • Автор темы
  • Активист
  • *
  • Сообщений: 618
  • ахтыжъёшкинкот
    • Просмотр профиля
    • Блог av9526
Установлено:
Apache2.2
Wordpress

Собственно проблема: файлы php скачиваются (т.е. открывается диалог сохранения файла в браузере) вместо интерпретации содержимого. Как можно исправить?
Ubuntu 14.10

Оффлайн Protopopulus

  • Старожил
  • *
  • Сообщений: 1686
  • ちのう の きょうかん
    • Просмотр профиля
Установить интерпретатор PHP и перезапустить Apache :D
Если ты владеешь знаниями, то и знания владеют тобой. (с) Protopopulus

Оффлайн avi9526

  • Автор темы
  • Активист
  • *
  • Сообщений: 618
  • ахтыжъёшкинкот
    • Просмотр профиля
    • Блог av9526
Установить интерпретатор PHP и перезапустить Apache :D
установлен пакет:
php5 (metapackage)
все перезапускал, и даже пытался удалить и заново поставить, до лампочки(
Ubuntu 14.10

Оффлайн Protopopulus

  • Старожил
  • *
  • Сообщений: 1686
  • ちのう の きょうかん
    • Просмотр профиля
sudo apt-get install libapache2-mod-php5Не?
Если ты владеешь знаниями, то и знания владеют тобой. (с) Protopopulus

Оффлайн avi9526

  • Автор темы
  • Активист
  • *
  • Сообщений: 618
  • ахтыжъёшкинкот
    • Просмотр профиля
    • Блог av9526
Не?
установлено при установке wordpress
Ubuntu 14.10

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Попробуй переустановить его таким способом:
sudo aptitude -o DPkg::Options::="--force-confask" reinstall libapache2-mod-php5
и рестартнуть апач. Если не поможет, то выкладывай нам в виде tar (!!) архива каталог /etc/apache2, будем вместе думать.

Оффлайн Protopopulus

  • Старожил
  • *
  • Сообщений: 1686
  • ちのう の きょうかん
    • Просмотр профиля
Мне как-то раз помог рестарт системы...
Если ты владеешь знаниями, то и знания владеют тобой. (с) Protopopulus

Оффлайн avi9526

  • Автор темы
  • Активист
  • *
  • Сообщений: 618
  • ахтыжъёшкинкот
    • Просмотр профиля
    • Блог av9526
Попробовал команду с переустановкой пакета, не помогло.
Единственный файл из настроек апача который я редактировал:
/etc/apache2/sites-available/default
wordpress с апачем "женил" по инструкции:
(Нажмите, чтобы показать/скрыть)
Ubuntu 14.10

Оффлайн Romon

  • Участник
  • *
  • Сообщений: 216
  • destructive creation
    • Просмотр профиля
Включи "ПХП" в "Апече"  8)

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Всё в конфиге хорошо. Я твоим каталогом с конфигом тупо заменил свой и перезапустил апач - пых нормально отрабатывает.

Я пока вижу две возможных вариации проблем. Первое - это чудит кеш браузера. Второе - это то, что ты запускаешь апач не дистрибутивный, а левую сбору, например от какого-нибудь очередного xamppа, который юзает совершенно другой конфиг.

Оффлайн Romon

  • Участник
  • *
  • Сообщений: 216
  • destructive creation
    • Просмотр профиля
Mam(O)n кстати очень вероятную причину проблемы подсказал. ОЧИСТИ КЭШ БРАУЗЕРА.

Оффлайн avi9526

  • Автор темы
  • Активист
  • *
  • Сообщений: 618
  • ахтыжъёшкинкот
    • Просмотр профиля
    • Блог av9526
спс, это кеша шалил)
СПАСИБО мужики (поставил бы + если бы знал как))

[РЕШЕНО]
Ubuntu 14.10

 

Страница сгенерирована за 0.055 секунд. Запросов: 24.