Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: настройка поведения сетевых интерфейсов  (Прочитано 952 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vetal

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
На ноуте (dell D520 Latitude) есть сетевуха и wifi плата, соответственно есть интерфейсы eth0, wifi0, ath0.

При загрузке и при выходе из спящего режима ВСЕГДА все интерфейсы оказываются поднятыми. Нашлось железо - поднялись интерфесы. При этом wifi еще и сканирует окрестности, т.е. жрет батарею. Если убрать auto в interfaces для ath0, то сканирования не происходит (интерфейсы подняты), но и апплет сети тоже становится для wifi бесполезен. Хотя может, оно и сканирует, но апплет KNetworkManager просто этого не видит.

Если выключать сетевой режим в апплете, то он выключается только до засыпания, при чем после выхода из сна интерфейсы подняты, но апплет этого не видит.

Нужно:
1) чтобы после загрузки все сетевые интерфесы, кроме lo были выключены
2) чтобы после выхода из засыпания интерфесы были выключены, если они были выключены до засыпания и были включены, если они были включены до засыпаения соответственно.

Да, функциональная кнопка переключения wifi не работает. Выфы на нее просто не реагирует. Это не столь важно, важнее, чтобы каждый раз не приходилось после включения опускать eth0, wifi0, ath0 вручную.

Кто-нибудь что-то посоветует?

Kbuntu 7.04

Оффлайн xmig

  • Любитель
  • *
  • Сообщений: 98
    • Просмотр профиля
Re: настройка поведения сетевых интерфейсов
« Ответ #1 : 05 Октябрь 2007, 15:49:54 »
откорректируй /etc/network/interfaces, или вставь в автозагрузку скрипт, который будет опускать не нужные тебе интерфейсы.

Оффлайн Vetal

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: настройка поведения сетевых интерфейсов
« Ответ #2 : 06 Октябрь 2007, 15:29:43 »
Так, сделал домашнее заданее:
/etc/network/interfaces
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0
iface ath0 inet dhcp
iface eth0 inet dhcp
auto ath0

В etc/init.d положил скрипт такого содержания:
#! /bin/sh
N=/etc/init.d/stopifaces
PATH=/sbin
ifconfig eth0 down
ifconfig ath0 down

после этого сделал символьную ссылку в /etc/rc2.d @S99stopifaces

Работает, как мне надо. НО рационально ли я это сделал? Или можно было как-то изящнее?
И еще, после загрузки оно рабоате, а вот после выхода из stand-by все равно интерфейсы остаются запущенными. Как это решить?

Оффлайн xmig

  • Любитель
  • *
  • Сообщений: 98
    • Просмотр профиля
Re: настройка поведения сетевых интерфейсов
« Ответ #3 : 07 Октябрь 2007, 11:27:58 »
Интерфейсы можно отключить в /etc/network/interfaces, посмотри примеры в /usr/share/doc/ifupdown/examples/network-interfaces.gz

А скрипт проще было бы засунуть в /etc/rc.local, по сути это и есть автозагрузочный файл для всех уровней.
Или же выбрать в меню System->Preferences->Sessions, и прописать скрипт туда для автозапуска в твоей сессии.
Вот, что я имел ввиду.

Оффлайн Vetal

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: настройка поведения сетевых интерфейсов
« Ответ #4 : 07 Октябрь 2007, 21:38:27 »
Спасибо за помощь, буду учить матчасть.

А пока до лучших времен, еще запихнул этот же скрипт в /etc/networt/if-pre-up.d/. В результате, интерфейсы включены только тогда, когда я их сам включаю вручную или через апплет. Правка rc.local пока ничего не дала, т.к. эффекта не наблюдается и машинка при просыпании виснет намертво. Ясно, что не то я туда пишу, но пока и так работает, как мне надо было :)

 

Страница сгенерирована за 0.072 секунд. Запросов: 22.