Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: QT SDK - Ошибка сегментирования.  (Прочитано 1906 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн HouK

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
QT SDK - Ошибка сегментирования.
« : 07 Февраль 2011, 21:54:33 »
Скачал с офф. сайта qt-sdk-linux-x86_64-opensource-2010.05.1.bin сделал все по инструкции, но после запуска окна, и нажатия кнопки далее, в терминале пишет что произошла "ошибка сегментирования"

Подскажите куда смотреть хотя бы, а то гугл что то не особо помог.  Пробывал качать через wget(нашел инструкцию по этой ошибке) тоже не помогло. Из репозитариев ставится, но там такая штука, когда допустим пишешь

#include < то должно появлятся выпадающее меню, то что из репов там это есть, но нету стандартных С++ т.е.
#include <iostream>
Я конечно понимаю, что это скорее всего нужно настраивать библиотеки и т.д. Но когда в прошлый раз ставил с офф сайта такое уже было настроено. А щас даже не хочет от туда устанавливатся.

П.С.: Да я и на лине и в програмирование пока что очень слаб, но прошу не пинать меня. Я учусь быстро.
« Последнее редактирование: 08 Февраль 2011, 00:23:56 от HouK »


Оффлайн HouK

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: QT SDK - Ошибка сегментирования.
« Ответ #2 : 07 Февраль 2011, 23:10:03 »
Создание нового пользователя не помогло, больше решений не нашел. Если знаете рабочее решение ткните в него носом. Думаете я гугл не шерстил пока сам пытался найти решение проблемы???
Обновления более 3 мб пока не ставились(всмысле при установке OS поставилось 300-500 мб обновлений и далее по 3-5 мб максимум)

Оффлайн RazrFalcon

  • O_o
  • Старожил
  • *
  • Сообщений: 3144
  • Zombie Mod
    • Просмотр профиля
    • Я на GitHub
Re: QT SDK - Ошибка сегментирования.
« Ответ #3 : 07 Февраль 2011, 23:21:27 »
У многих проблемы при установке. (кроме меня =/)
Ставьте из реп и не мучайтесь.
А гугл, на всякий случай.
sudo apt-get install qt4-doc libqt4-dev libqt4-core libqt4-gui qt4-demos qtcreator qt4-qmlviever -y
Gentoo + KDE, Official Windows Hater
Хотите помочь нашей вики: http://help.ubuntu.ru/wiki/fixme

Оффлайн GonZaleZ

  • Активист
  • *
  • Сообщений: 628
  • Нет, не включат
    • Просмотр профиля
Re: QT SDK - Ошибка сегментирования.
« Ответ #4 : 07 Февраль 2011, 23:39:04 »
Я ставил из репов, т.к. обычный постоянно падал. Даже не знал, что есть фишка с выпадающим меню при include о_О Может, настраивается как-то?

З.Ы. А зачем вам iostream, в qt же, вроде, свой ввод-вывод есть...
HP Pavilion dv6 1317-er | Ubuntu 11.04
Intel Core 2 Duo 2,2 ГГц | 3 Gb RAM | ATI Mobility Radeon 4650 HD 1Gb
У меня есть айфон и айпад - тролльте, господа...

Оффлайн HouK

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: QT SDK - Ошибка сегментирования.
« Ответ #5 : 07 Февраль 2011, 23:42:31 »
я только учусь, и учусь по обычному С++ :) а там в примерах iostream cmath и т.д. вот из-за этого и нужны. Т.к. постоянно их писать вручную лень, видимо надо дополнительные библиотеки качать и настраивать будет. Жалко что с офф сайта не встает, придется видимо и правда из репов ставить.

У меня раньше тоже проблем небыло, когда основой стоял win xp а ubuntu 10.10 стояла второй осью, хотя врядли из-за этого все было норм и спервого раза :)
« Последнее редактирование: 07 Февраль 2011, 23:44:07 от HouK »

Оффлайн RazrFalcon

  • O_o
  • Старожил
  • *
  • Сообщений: 3144
  • Zombie Mod
    • Просмотр профиля
    • Я на GitHub
Re: QT SDK - Ошибка сегментирования.
« Ответ #6 : 07 Февраль 2011, 23:45:22 »
iostream есть =/
sudo apt-get install build-essential -y
Gentoo + KDE, Official Windows Hater
Хотите помочь нашей вики: http://help.ubuntu.ru/wiki/fixme

Оффлайн GonZaleZ

  • Активист
  • *
  • Сообщений: 628
  • Нет, не включат
    • Просмотр профиля
Re: QT SDK - Ошибка сегментирования.
« Ответ #7 : 07 Февраль 2011, 23:56:19 »
Да ладно, уж iosteam, 7 букв написать можно) В остальном я отличий между реповским и тем, что выложено на сайте, не заметил, кроме того, что реповский у меня ещё никогда не падал в то время, когда сайтовский падал при любой попытке что-то удалить, а значит, и при создании проекта с существующим именем и при компиляции и одновременном запуске в релиз-режиме и просто при удалении файлов через встроенный браузер...
HP Pavilion dv6 1317-er | Ubuntu 11.04
Intel Core 2 Duo 2,2 ГГц | 3 Gb RAM | ATI Mobility Radeon 4650 HD 1Gb
У меня есть айфон и айпад - тролльте, господа...

Оффлайн HouK

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: QT SDK - Ошибка сегментирования.
« Ответ #8 : 08 Февраль 2011, 00:23:13 »
Спасибо за ответы :) и за помощь, тогда буду регулировать из репов и т.д. и т.п. :)

 

Страница сгенерирована за 0.186 секунд. Запросов: 22.