Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Проблема с php в связке LAMP  (Прочитано 700 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ru55ian

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
  • Иду на вы!
    • Просмотр профиля
    • http://ru55ian.livejournal.com/
Проблема с php в связке LAMP
« : 10 Февраль 2011, 14:20:55 »
Установил LAMP, запускаю в браузере тест:
http://localhost/
всё нормально - it works!
Но вот с php какой-то глюк - при попытке зайти в phpmyadmin по ссылке http://localhost/phpmyadmin/ выдаёт 404.

При попытке перезапустить апач, тоже ругается:



И файлы из /var/www в адресной строке браузера почему-то отображаются как file:///var/www/index.html
а не как http://localhost/index.html

Не могу понять, что я делаю неправильно.
« Последнее редактирование: 10 Февраль 2011, 15:43:47 от ru55ian »

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Проблема с php в связке LAMP
« Ответ #1 : 10 Февраль 2011, 14:46:55 »
запускать и перезапускать апач через sudo
sudo /etc/init.d/apache2 restartконфиг апача выложи

Оффлайн ru55ian

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
  • Иду на вы!
    • Просмотр профиля
    • http://ru55ian.livejournal.com/
Re: Проблема с php в связке LAMP
« Ответ #2 : 10 Февраль 2011, 14:48:41 »
конфиг апача выложи

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 10 Февраль 2011, 15:07:24 от ru55ian »

Оффлайн xdemon

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Проблема с php в связке LAMP
« Ответ #3 : 10 Февраль 2011, 15:04:47 »
Можно было под спойлер прятать..
Перезапускать надо так:
sudo /etc/init.d/apache2 restart
тоесть с правами рута.

Оффлайн ru55ian

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
  • Иду на вы!
    • Просмотр профиля
    • http://ru55ian.livejournal.com/
Re: Проблема с php в связке LAMP
« Ответ #4 : 10 Февраль 2011, 15:05:41 »
Можно было под спойлер прятать..
Сделал.

запускать и перезапускать апач через sudo
sudo /etc/init.d/apache2 restart

Так и делаю. Вот чё пишет:

« Последнее редактирование: 10 Февраль 2011, 15:08:28 от ru55ian »

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Проблема с php в связке LAMP
« Ответ #5 : 10 Февраль 2011, 15:18:56 »
эти ошибки к твоим проблемам отношения не имеют, это во-первых, во-вторых содержимое какого файла выложил ты?  и в третьих выложи содержимое файлов из этой директории /etc/apache2/sites-enabled/
нужно выложить пользовательский конфиг на который указывает эта директива
 # Include all the user configurations:
Include /etc/apache2/httpd.conf
« Последнее редактирование: 10 Февраль 2011, 15:25:04 от xeon_greg »

Оффлайн ru55ian

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
  • Иду на вы!
    • Просмотр профиля
    • http://ru55ian.livejournal.com/
Re: Проблема с php в связке LAMP
« Ответ #6 : 10 Февраль 2011, 15:28:40 »
во-первых, эти ошибки к твоим проблемам отношения не имеют
То есть, просто не обращать на них внимания?

во-вторых, содержимое какого файла выложил ты?
Файл-конфиг апача под именем apache2.conf
Он у меня лежит в папке /etc/apache2

в-третьих, выложи содержимое файлов из этой директории /etc/apache2/sites-enabled/

Там в этой папке только линк на файл mysite
Сам файл такого содержания:

(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль 10 Февраль 2011, 15:44:55:
нужно выложить пользовательский конфиг на который указывает эта директива
 # Include all the user configurations:
Include /etc/apache2/httpd.conf

Файл httpd.conf пуст. Вместо него в качестве файла-конфига, как я понял, используется apache2.conf
« Последнее редактирование: 10 Февраль 2011, 15:55:03 от ru55ian »

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Проблема с php в связке LAMP
« Ответ #7 : 10 Февраль 2011, 16:19:03 »
Цитировать
<Directory /> /var/www
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
   </Directory>
вот это полная чепуха, посмотри на примере вот этого что есть в твоем же конфиге :
Цитировать
<Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>
как задается конфигурация директории. внеси необходимые изменения и перезапусти апач. а еще лучше найди в гугле русский мануал по кофигурации апача и хорошенько почитай

Пользователь решил продолжить мысль 10 Февраль 2011, 16:24:32:
Цитировать
То есть, просто не обращать на них внимания?
если твой сервер используется только локально тогда не обращай внимание,  это сервер говорит о том что ты ему не присвоил имя (FQDN) , что это такое гугл поможет узнать.


« Последнее редактирование: 10 Февраль 2011, 16:24:32 от xeon_greg »

Оффлайн ru55ian

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
  • Иду на вы!
    • Просмотр профиля
    • http://ru55ian.livejournal.com/
Re: Проблема с php в связке LAMP
« Ответ #8 : 10 Февраль 2011, 17:36:49 »
посмотри как задается конфигурация директории. внеси необходимые изменения и перезапусти апач. а еще лучше найди в гугле русский мануал по кофигурации апача и хорошенько почитай

Я так понял, у меня апач неправильно сконфигурирован, надо внести изменения в конфиг-файл?
С этими конфигами вообще труба - мало того надо знать где какую строчку поменять, так надо ещё и синтаксис не напутать.
Попробую разобраться.

Пользователь решил продолжить мысль 10 Февраль 2011, 17:54:09:
Во многих манах вижу такое предупреждение:
Цитировать
Отредактируйте httpd.conf или srm.conf и проверьте, что эти строки имеются и не закомментированы:
AddType application/x-httpd-php .php
LoadModule php4_module        libexec/libphp4.so
По поводу второй строчки - нашёл, у меня отдельный файл есть с такой командой. А вот первая строчка где должна быть? Куда надо прописывать вот это:
AddType application/x-httpd-php .php
?
« Последнее редактирование: 10 Февраль 2011, 18:00:25 от ru55ian »

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Проблема с php в связке LAMP
« Ответ #9 : 10 Февраль 2011, 19:22:36 »
в httpd.conf .  эта директива  говорит твоему серверу чтобы он знал что делать с файлами php

Пользователь решил продолжить мысль 10 Февраль 2011, 19:28:17:
Цитировать
LoadModule php4_module        libexec/libphp4.so
кстати это уже старая тема, 5 php  уже давно используется так что там же поищи где-то должна быть похожая на это строка
LoadModule php5_module        libexec/libphp5.so
если ее нет то надо также добавить, при условии что у тебя установлен 5 php
« Последнее редактирование: 10 Февраль 2011, 19:28:17 от xeon_greg »

Оффлайн nomeron

  • Новичок
  • *
  • Сообщений: 30
    • Просмотр профиля
Re: Проблема с php в связке LAMP
« Ответ #10 : 10 Февраль 2011, 22:59:22 »
Строчка AddType application/x-httpd-php .php живет в конфигурациях под виндой
в Ubuntu 10.4 конфигурация  php подключается как модуль директивами apache2.conf
# Include module configuration:
Include /etc/apache2/mods-enabled/*.load
Include /etc/apache2/mods-enabled/*.conf
Ну и соответственно должен быть файл
/etc/apache2/mods-available/php5.conf
и ссылка на него в /etc/apache2/mods-enabled/
Чтобы попробовать достаточно
<VirtualHost *:80>
   ServerAdmin webmaster@localhost
   DocumentRoot /var/www
   <Directory />
      AllowOverride All
      DirectoryIndex index.php index.html index.htm
      Order allow,deny
      allow from all
   </Directory>
</VirtualHost >

 

Страница сгенерирована за 0.067 секунд. Запросов: 24.