Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: ubuntu 10.10 -> dlink dwa-131 -> dir-300  (Прочитано 2097 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MAKAPOH

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
ubuntu 10.10 -> dlink dwa-131 -> dir-300
« : 12 Февраль 2011, 02:05:13 »
Имеется компьютер с ubuntu 10.10 на борту, usb dongle d-link dwa-131 на базе realtek 8192SU и маршрутизатор d-link dir-300
Маршрутизатор включен в режиме Access Point.
Есть отдельный сервер который раздает ip-адреса, dns и интернет

Подключаемся к точке - инет то работает то нет :) в результате выяснилось что когда "инета нет" недоступны только адреса 192.168.1.0/24 (локальная сеть в которой находятся компьютер, маршрутизатор и сервер), 8.8.8.8 например исправно пингуется и обрабатывает dns-запросы, что странно, ведь запросы идут через 192.168.1.100.. Если прописать в resolv.conf nameserver 8.8.8.8 то адреса резолвятся, но страницы открываются очень и очень долго. Появляется проблема абсолютно спонтанно, то работает то нет :) при проводном подключении к тому же dir-300 все работает как часы :)

Куда можно покопать и где может быть проблема? :) В дополнение скажу что заставить этот модуль dwa-131 работать на двух компьютерах под windows 7 дома не удалось, принес на работу - на буке с семеркой и компе с убунтой все без проблем тут же поднялось :) правда не проверял как вобще инет работает :)
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 12 Февраль 2011, 02:12:06 от MAKAPOH »

Оффлайн shumtest

  • Активист
  • *
  • Сообщений: 731
  • Это вам просто кажется...
    • Просмотр профиля
    • Блог Шумомера
Re: ubuntu 10.10 -> dlink dwa-131 -> dir-300
« Ответ #1 : 12 Февраль 2011, 03:40:37 »
RX packets:3441 errors:0 dropped:14258 overruns:0 frame:0

Симптом известной болезни реалтековских драйверов. Надо принудительно понизить мту на маршрутизаторе.

Оффлайн MAKAPOH

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: ubuntu 10.10 -> dlink dwa-131 -> dir-300
« Ответ #2 : 12 Февраль 2011, 12:00:46 »
ну в нем mtu вроде настраивается только для pptp :)
Нашел в расширенных настройках беспроводной сети параметр фрагментация, оно? :) (диапазон: 1500~2346, по умолчанию:2346, только целое число)
« Последнее редактирование: 12 Февраль 2011, 12:03:36 от MAKAPOH »

Оффлайн Fimir

  • Участник
  • *
  • Сообщений: 225
    • Просмотр профиля
Re: ubuntu 10.10 -> dlink dwa-131 -> dir-300
« Ответ #3 : 24 Май 2011, 02:27:41 »
В точности то же самое!
Только рутеры ZyXEL и DIR-320.
На двух  Win7 x64, Ubuntu 11.04 и LMDE (2.6.38) работать отказался. То есть сеть вижу, подключаюсь, но ни в рутеры ни в тырнет попасть не могу.
При этом ещё недавно без проблем работал с этого же компа через DIR-615.
Принёс к техникам Д-линка -- они без проблем запустили на двух своих компах.
Как это возможно -- не понимаю ни разу.
Что делать?
« Последнее редактирование: 24 Май 2011, 10:24:05 от Fimir »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: ubuntu 10.10 -> dlink dwa-131 -> dir-300
« Ответ #4 : 24 Май 2011, 08:05:19 »
Что делать?
Выше же уже предложили вариант решения? Или Вы писатель, а не читатель?
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Fimir

  • Участник
  • *
  • Сообщений: 225
    • Просмотр профиля
Re: ubuntu 10.10 -> dlink dwa-131 -> dir-300
« Ответ #5 : 24 Май 2011, 08:58:09 »
Во-первых чуть пониже обороты.
А во-вторых, в рутере MTU не настраивается для отдельной сети. Изменение MTU для адаптера ничего не дало.

Пользователь решил продолжить мысль 25 Май 2011, 01:02:12:
Собственно, проблему решил.
Как ни странно, связь появлялась при отключении аппаратного NAT на рутере.
Поведение свистка "там работает, тут не работает" связано по всей видимости с действием NAT по умолчанию в разных рутерах или даже его там отсутствием.
Примечательно, что проблема присуща только этому свистку -- интеловский адаптер из того же ноута в то же самое время преспокойно на рутер цеплялся.
В общем как-то всё интересно :)
« Последнее редактирование: 25 Май 2011, 01:03:16 от Fimir »

Оффлайн nickomax

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: ubuntu 10.10 -> dlink dwa-131 -> dir-300
« Ответ #6 : 29 Май 2011, 08:10:32 »
Я только начал общаться с данной операционкой, но столкнулся с такой же проблемой. решил проблему заменой свистка на netgear WNA-1000. дрова взял из репозитория debian. про dlink этот гдето читал что с имено с ним гемора очень много. в общем не советую я его.

 

Страница сгенерирована за 0.232 секунд. Запросов: 24.