Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Нет доступа на localhost  (Прочитано 6229 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DoublePain

  • Автор темы
  • Активист
  • *
  • Сообщений: 574
    • Просмотр профиля
Нет доступа на localhost
« : 16 Февраль 2011, 05:31:47 »
Вообщем, всё работает, mysql сервер, phpmyadmin его обслуживает, всё создаётся и удаляется, НО:
у меня есть виртуальный хост main, на него через http://localhost/main не зайти
(Нажмите, чтобы показать/скрыть)

В apache2.conf дописан "ServerName localhost"

В хостах всё указано вроде как верно
(Нажмите, чтобы показать/скрыть)

Права на Dev/php выданы правильно, даже пытался пользователя поставить www-data, не помогло.


Вот только странно что httpd.conf пуст.

В чём может быть проблема?
pain projection
Athlon II 620 x4 2.66GHz,4gb,Radeon HD4670 + Ubuntu 12.04 x64
Получено 2 845 kБ за 4с (666 kБ/c)

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5085
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #1 : 16 Февраль 2011, 05:50:54 »
Я конечно не особо то тут и советчик, но apache2.conf для виртуальных серверов не используется (к тому же записи вроде как с ошибками \ неполны в части директории и указания / в конце) вместо юзается sites-available в котором и должен лежать конфиг и httpd.conf как бы тоже не используется от того и пуст
Лучше почитай мануал какой нибудь по настройке, у меня иначе выглядит это дело, настраивал через вебмин простым тыканьем галочек, ну кое, что и ручками (в части листнига портов)
А так я только учусь и не факт что сказаное верно, но если у мну всё пашет отлично, то значит мыслю верно?  :D

p.s. вот почитай простенький мануальчик http://kubuntu.ru/apache2-drupal
« Последнее редактирование: 16 Февраль 2011, 06:40:50 от gregory5 »

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #2 : 16 Февраль 2011, 10:17:51 »
Цитировать
<Directory /home/voodoo/Dev/php/>
это указывается так :
<Directory "/home/voodoo/Dev/php">
Пользователь решил продолжить мысль 16 Февраль 2011, 10:19:16:
исправь и перезапусти апач

Пользователь решил продолжить мысль 16 Февраль 2011, 10:24:45:
Цитировать
у меня есть виртуальный хост main
а где это у тебя указано что он есть? покажи ту часть конфига
« Последнее редактирование: 16 Февраль 2011, 10:24:45 от xeon_greg »

Оффлайн Ost

  • Активист
  • *
  • Сообщений: 292
  • Ушёл на Arch. Тут по привычке.
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #3 : 16 Февраль 2011, 10:49:33 »
А на сам хомяк права выставляли?

chmod o+x ~
chmod o+x ~/Dev/php/
Archlinux

Оффлайн DoublePain

  • Автор темы
  • Активист
  • *
  • Сообщений: 574
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #4 : 16 Февраль 2011, 11:35:13 »
Цитировать
<Directory /home/voodoo/Dev/php/>
это указывается так :
<Directory "/home/voodoo/Dev/php">
Пользователь решил продолжить мысль 16 Февраль 2011, 10:19:16:
исправь и перезапусти апач

Пользователь решил продолжить мысль 16 Февраль 2011, 10:24:45:
Цитировать
у меня есть виртуальный хост main
а где это у тебя указано что он есть? покажи ту часть конфига
sudo a2ensite main создал хост
директорию в кавычках указал-не помогло

Раньше без проблем ставил сервер, пару кликов и всё окок, а щас чёт знает что %)
pain projection
Athlon II 620 x4 2.66GHz,4gb,Radeon HD4670 + Ubuntu 12.04 x64
Получено 2 845 kБ за 4с (666 kБ/c)

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #5 : 16 Февраль 2011, 13:26:10 »
покажи результат комманд
ls -la /etc/apache2/sites-enabled
cat /etc/hosts

Пользователь решил продолжить мысль 16 Февраль 2011, 13:29:30:
Цитировать
sudo a2ensite main создал хост
эта комманда не создает хост она включает доступный хост из папки sites-available. это немного разные вещи
« Последнее редактирование: 16 Февраль 2011, 13:29:30 от xeon_greg »

Оффлайн DoublePain

  • Автор темы
  • Активист
  • *
  • Сообщений: 574
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #6 : 16 Февраль 2011, 16:24:24 »
drwxr-xr-x 2 root root 4096 2011-02-16 04:15 .
drwxr-xr-x 7 root root 4096 2011-02-16 04:23 ..
lrwxrwxrwx 1 root root   23 2011-02-16 03:57 main -> ../sites-available/main
127.0.0.1 localhost
127.0.1.1 box

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
pain projection
Athlon II 620 x4 2.66GHz,4gb,Radeon HD4670 + Ubuntu 12.04 x64
Получено 2 845 kБ за 4с (666 kБ/c)

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #7 : 16 Февраль 2011, 16:51:36 »
значит так в конфиге после этих строк
Цитировать
<VirtualHost *:80>
   ServerAdmin webmaster@localhost
пишешь
ServerName mainа в /etc/hosts
добавить
127.0.0.1 main
и заходить на твой main так
http://main


Оффлайн DoublePain

  • Автор темы
  • Активист
  • *
  • Сообщений: 574
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #8 : 16 Февраль 2011, 22:31:31 »
Снова
Forbidden

You don't have permission to access / on this server.

Apache/2.2.14 (Ubuntu) Server at main Port 80

+ phpmyadmin после переустановки всего lamp сервера начал предлагать загрузку navigation.php. Уже и удалил полностью phpmyadmin - не помогает.
pain projection
Athlon II 620 x4 2.66GHz,4gb,Radeon HD4670 + Ubuntu 12.04 x64
Получено 2 845 kБ за 4с (666 kБ/c)

Оффлайн Ost

  • Активист
  • *
  • Сообщений: 292
  • Ушёл на Arch. Тут по привычке.
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #9 : 16 Февраль 2011, 23:04:02 »
<Directory "/home/voodoo/Dev/php">
Тогда и DocumentRoot тоже в кавычки забрать: DocumentRoot "/home/voodoo/Dev/php"
Archlinux

Оффлайн DoublePain

  • Автор темы
  • Активист
  • *
  • Сообщений: 574
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #10 : 17 Февраль 2011, 00:35:23 »
Всё в кавычки поставил.

Уже раза 3 переустановил всё, с удалением конфигов. phpmyadmin творит непонятно что, dpkg-reconfigure phpmyadmin не помогает, выдаёт загрузку файла %)
pain projection
Athlon II 620 x4 2.66GHz,4gb,Radeon HD4670 + Ubuntu 12.04 x64
Получено 2 845 kБ за 4с (666 kБ/c)

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27310
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #11 : 17 Февраль 2011, 01:35:26 »
Развелось советчиков, плюнуть некуда...
Кавычки нужны только если путь содержит пробелы.
В /etc/hosts убрать то что насоветовали, написать
127.0.1.1   box main

Сделать
chown -R :www-data /где/там/твой/сайт
chmod -R g+rX /где/там/твой/сайт
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн DoublePain

  • Автор темы
  • Активист
  • *
  • Сообщений: 574
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #12 : 17 Февраль 2011, 02:47:06 »
Всё равно не работает. не localhost/, не main/

pain projection
Athlon II 620 x4 2.66GHz,4gb,Radeon HD4670 + Ubuntu 12.04 x64
Получено 2 845 kБ за 4с (666 kБ/c)

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27310
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #13 : 17 Февраль 2011, 02:51:49 »
Как именно не работает...
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Нет доступа на localhost
« Ответ #14 : 17 Февраль 2011, 10:11:27 »
покажи текущее состояние конфига
cat /etc/apache2/sites-enabled/mainвроде этот сейчас у тебя
и покажи
ls -la /home/voodoo/Dev/phpну и еще покажи
cat /etc/apache2/apache2.conf  | egrep -v '^#|^$'

 

Страница сгенерирована за 0.197 секунд. Запросов: 24.