Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: устанавливаю Wiki (moinMoin) Apache не понимает WSGI  (Прочитано 998 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nwolf

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Приветствую!
помогите решить проблему.
устанавливаю Wiki в конфиг апача прописывается
WSGIScriptAlias /   /usr/local/share/moin/moin.wsgi

# create some wsgi daemons - use these parameters for a simple setup
WSGIDaemonProcess moin user=www-data group=www-data processes=5 threads=10 maximum-requests=1000 umask=0007

# use the daemons we defined above to process requests!
WSGIProcessGroup moin
---
апач не стартует
ругается на WSGIScriptAlias
libapache2-mod-wsgi - пакет установлен.
но походу в апач не подгружается
помогите решить проблему

Оффлайн drako

  • Старожил
  • *
  • Сообщений: 1422
    • Просмотр профиля
Re: устанавливаю Wiki (moinMoin) Apache не понимает WSGI
« Ответ #1 : 18 Февраль 2011, 23:52:48 »
Что говорят:
ls /etc/apache2/mods-available | grep -i wsgi
ls /etc/apache2/mods-enabled | grep -i wsgi

Оффлайн nwolf

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: устанавливаю Wiki (moinMoin) Apache не понимает WSGI
« Ответ #2 : 19 Февраль 2011, 06:33:30 »
Что говорят:
ls /etc/apache2/mods-available | grep -i wsgi
ls /etc/apache2/mods-enabled | grep -i wsgi
ls /etc/apache2/mods-available | grep -i wsgi
wsgi.conf
wsgi.load
ls /etc/apache2/mods-enabled | grep -i wsgi - молчит

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26258
    • Просмотр профиля
Re: устанавливаю Wiki (moinMoin) Apache не понимает WSGI
« Ответ #3 : 19 Февраль 2011, 07:30:15 »
Тогда a2enmod, наверно?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн nwolf

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: устанавливаю Wiki (moinMoin) Apache не понимает WSGI
« Ответ #4 : 19 Февраль 2011, 14:26:42 »
Тогда a2enmod, наверно?
Your choices are: actions alias asis auth_basic auth_digest authn_alias authn_anon authn_dbd authn_dbm authn_default authn_file authnz_ldap authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta cgi cgid charset_lite dav dav_fs dav_lock dbd deflate dir disk_cache dump_io env expires ext_filter file_cache filter headers ident imagemap include info ldap log_forensic mem_cache mime mime_magic negotiation php5 proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi reqtimeout rewrite setenvif speling ssl status substitute suexec unique_id userdir usertrack version vhost_alias wsgi

Which module(s) do you want to enable (wildcards ok)?
y
ERROR: Module y does not exist!


Пользователь решил продолжить мысль 19 Февраль 2011, 14:47:17:
сенкс! полазил по данной (в интернете почитал) команде и запустил!
УРЯ! УРЯ!
« Последнее редактирование: 19 Февраль 2011, 14:47:17 от nwolf »

 

Страница сгенерирована за 0.055 секунд. Запросов: 24.