Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: настройка l2tpd сервер  (Прочитано 2906 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tosh17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
настройка l2tpd сервер
« : 20 Февраль 2011, 16:14:19 »
Пытался поднять l2tpd server , но как то не вышло

с линуксовой машины конект есть но держит не долго, рвет
а с вин машины вообще не заходит
Понимаю что проблема скорей всего в /etc/ppp/options.l2tpd


cat /etc/xl2tpd/xl2tpd.conf
(Нажмите, чтобы показать/скрыть)

 cat /etc/ppp/options.l2tpd
(Нажмите, чтобы показать/скрыть)

Оффлайн drako

  • Старожил
  • *
  • Сообщений: 1422
    • Просмотр профиля
Re: настройка l2tpd сервер
« Ответ #1 : 20 Февраль 2011, 20:29:54 »
Как это два явно противоположных по значению параметра имеют одно и то же значение (refuse authentication = no require authentication = no)?
MTU и MRU было бы неплохо до 1460 спустить.

Оффлайн tosh17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: настройка l2tpd сервер
« Ответ #2 : 20 Февраль 2011, 21:15:28 »
Ну так было в хаутушки
(а с мту я игрался изначально было 1410)

Отключение одного или двух этих параметров как то не помогло

вот лог от попытки соединения вин машины 
(Нажмите, чтобы показать/скрыть)


а это линух машина
(Нажмите, чтобы показать/скрыть)

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27319
    • Просмотр профиля
Re: настройка l2tpd сервер
« Ответ #3 : 21 Февраль 2011, 11:12:59 »
А где отладка pppd ?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн tosh17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: настройка l2tpd сервер
« Ответ #4 : 21 Февраль 2011, 13:49:06 »
не понял, что надо сделать
где что смотреть

я запускал l2tpd -D

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27319
    • Просмотр профиля
Re: настройка l2tpd сервер
« Ответ #5 : 21 Февраль 2011, 14:17:44 »
/facepalm
Ты лог ВООБЩЕ ЧИТАЕШЬ ГЛАЗАМИ ИЛИ ЧЕМ?

xl2tpd[11867]: start_pppd: I'm running:
xl2tpd[11867]: "/usr/sbin/pppd"
xl2tpd[11867]: "passive"
xl2tpd[11867]: "nodetach"
xl2tpd[11867]: "172.16.0.1:0.0.0.0"
xl2tpd[11867]: "refuse-pap"
xl2tpd[11867]: "debug"
xl2tpd[11867]: "file"
xl2tpd[11867]: "/etc/ppp/options.l2tpd"
xl2tpd[11867]: "/dev/pts/38"
xl2tpd[11867]: Call established with 192.168.23.168, Local: 12247, Remote: 65503, Serial: 1366
xl2tpd[11867]: child_handler : pppd exited for call 65503 with code 15

Вот между "Call established" и "pppd exited" твоя проблема.
Отладка включается в xl2tpd[11867]: "/etc/ppp/options.l2tpd"
Вперёд!...
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.178 секунд. Запросов: 24.