Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Проблема с настройкой Wi-fi  (Прочитано 668 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dinozavr51

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Проблема с настройкой Wi-fi
« : 02 Март 2011, 16:50:36 »
Привет всем!!! Недавно установил Ubuntu(интересно попробовать что-нибудь новое :) ). Сразу же после установки решил настроить интернет-соединение, ввел данные, система пишет то, что Wi-fi подключен... Захожу в браузер, а интернета нет... С Windows у меня возникала такая же проблема, но я её решал простым добавление DNS-серверов в свойствах подключения. Не могли бы вы помочь решить эту проблему, сам пытался все настроить в network manager, но может быть делал что-то не так  ???  Желательно все поподробнее, в первый раз общаюсь с Linux. Заранее спасибо!

Доп. информация: роутер D-link dir-300, wi-fi приемник Linksys wmp54g. На компьютере установлена Windows 7 и Ubuntu, могу предоставить скриншоты из любой из этих двух ОС.

Оффлайн vasilisc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2563
  • г.Северодвинск - строим АПЛ
    • Просмотр профиля
    • Авторские статьи об OpenSource
Re: Проблема с настройкой Wi-fi
« Ответ #1 : 02 Март 2011, 17:02:07 »
извините, что наступил на больную мозоль, но дома так же Dlink dir-300 и ноут подруги вай-фай юзает через NetworkManager нормально.
дайте вывод
iwconfig
ifconfig -a
cat /etc/resolv.conf
route
Ускорение http://vasilisc.com/speedup_ubuntu
Железо http://vasilisc.com/hcl/detect.php
Призёр http://vasilisc.com/ubuntu_woman Если помог, то поддержите WM R259039388254

Оффлайн Dinozavr51

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с настройкой Wi-fi
« Ответ #2 : 02 Март 2011, 17:32:28 »
Сделал, вот результат:
dinozavr51@ubuntu:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"d_vit" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:1C:F0:E2:A2:9D   
          Bit Rate=48 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=56/70  Signal level=-54 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

dinozavr51@ubuntu:~$
dinozavr51@ubuntu:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:22:15:79:f8:3f 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:45

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:960 (960.0 B)  TX bytes:960 (960.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:21:29:6d:f1:44 
          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::221:29ff:fe6d:f144/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:398 errors:0 dropped:0 overruns:0 frame:0
          TX packets:434 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:32742 (32.7 KB)  TX bytes:46513 (46.5 KB)

dinozavr51@ubuntu:~$
dinozavr51@ubuntu:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.0.1
dinozavr51@ubuntu:~$
dinozavr51@ubuntu:~$ route

Оффлайн vasilisc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2563
  • г.Северодвинск - строим АПЛ
    • Просмотр профиля
    • Авторские статьи об OpenSource
Re: Проблема с настройкой Wi-fi
« Ответ #3 : 02 Март 2011, 17:41:55 »
у нас с подругой также =( и всё робит
и днс у вас прописан правильно - адрес роутера по умолчанию
покажите вывод
nslookup ya.ru
nslookup rambler.ru 192.168.0.1
Ускорение http://vasilisc.com/speedup_ubuntu
Железо http://vasilisc.com/hcl/detect.php
Призёр http://vasilisc.com/ubuntu_woman Если помог, то поддержите WM R259039388254

Оффлайн Dinozavr51

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с настройкой Wi-fi
« Ответ #4 : 02 Март 2011, 17:49:49 »
Вот то, что выдала консоль:
To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

dinozavr51@ubuntu:~$ nslookup ya.ru
Server: 192.168.0.1
Address: 192.168.0.1#53

** server can't find ya.ru: REFUSED

dinozavr51@ubuntu:~$
dinozavr51@ubuntu:~$ nslookup rambler.ru 192.168.0.1
Server: 192.168.0.1
Address: 192.168.0.1#53

** server can't find rambler.ru: REFUSED

dinozavr51@ubuntu:~$

Оффлайн vasilisc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2563
  • г.Северодвинск - строим АПЛ
    • Просмотр профиля
    • Авторские статьи об OpenSource
Re: Проблема с настройкой Wi-fi
« Ответ #5 : 02 Март 2011, 17:58:23 »
Вот то, что выдала консоль:
To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

dinozavr51@ubuntu:~$ nslookup ya.ru
Server: 192.168.0.1
Address: 192.168.0.1#53

** server can't find ya.ru: REFUSED

dinozavr51@ubuntu:~$
dinozavr51@ubuntu:~$ nslookup rambler.ru 192.168.0.1
Server: 192.168.0.1
Address: 192.168.0.1#53

** server can't find rambler.ru: REFUSED

dinozavr51@ubuntu:~$
да вас посылает собственный роутер! вам пишет REFUSED
я бы залез в админку роутера и посмотрел что там не так! у вас в LAN Setup -> ROUTER SETTINGS
Enable DNS Relay поставлена галочка?
Какой DNS сервер вы прописывали в винде?
Ускорение http://vasilisc.com/speedup_ubuntu
Железо http://vasilisc.com/hcl/detect.php
Призёр http://vasilisc.com/ubuntu_woman Если помог, то поддержите WM R259039388254

Оффлайн Deni$

  • Активист
  • *
  • Сообщений: 823
    • Просмотр профиля
Re: Проблема с настройкой Wi-fi
« Ответ #6 : 02 Март 2011, 18:03:34 »
Убери Enable DNS Relay  галочку, в настройках Ipv.4 в networkmanager выбери профиль "Автоматически DHCP только адрес" и там же пропиши DNS провайдера + 8.8.8.8
А перед этим попробуй nslookup ya.ru 8.8.8.8
« Последнее редактирование: 02 Март 2011, 18:06:42 от Deni$ »
Acer Ext. 5635ZG: Intel Pentium Dual Core T4400 / DDR3 2048 Mb / NV G105M / SATA 160 Gb // Kubuntu 16.10

Оффлайн Dinozavr51

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с настройкой Wi-fi
« Ответ #7 : 02 Март 2011, 18:07:30 »
Спасибо всем за советы! Сейчас залезу в админку  роутера, попозже отпишусь о результатах =)

Оффлайн Deni$

  • Активист
  • *
  • Сообщений: 823
    • Просмотр профиля
Re: Проблема с настройкой Wi-fi
« Ответ #8 : 02 Март 2011, 18:12:56 »
И вообще как-то из головы вылетело ping есть.
Например ping 8.8.8.8
Acer Ext. 5635ZG: Intel Pentium Dual Core T4400 / DDR3 2048 Mb / NV G105M / SATA 160 Gb // Kubuntu 16.10

Оффлайн Dinozavr51

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с настройкой Wi-fi
« Ответ #9 : 02 Март 2011, 18:28:30 »
Спасибо! Все наладил. У роутера убрал Enable DNS Relay , в DNS написал гугловский 8.8.8.8 и все заработало!!! :)
vasilisc до этого момента прописывал при помощи программки для Windows(Extra DNS) сразу несколько DNS. DNS провайдера, гугловские и пару других, которые нашел при помощи namebench.

Оффлайн Deni$

  • Активист
  • *
  • Сообщений: 823
    • Просмотр профиля
Re: Проблема с настройкой Wi-fi
« Ответ #10 : 02 Март 2011, 18:34:28 »
Что заработало это хорошо. Но ты узнай DNS провайдера и пропиши их приоритетными перед гугловскими. У меня пинг с DNS провайдера в 2 раза меньше, чем с гугловскими.
Acer Ext. 5635ZG: Intel Pentium Dual Core T4400 / DDR3 2048 Mb / NV G105M / SATA 160 Gb // Kubuntu 16.10

 

Страница сгенерирована за 0.07 секунд. Запросов: 25.