Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Загрузка + sata-винт  (Прочитано 2900 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн stan

  • Автор темы
  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Загрузка + sata-винт
« : 22 Декабрь 2005, 15:11:52 »
здравствуйте,
ста тема уже обсуждалась на форуме, но из тех советов ничего не помогло...

fstab пишу
/dev/sda1   /mnt/muzik      vfat   umask=000,iocharset=utf8   0   0
/dev/sda5   /mnt/soft    vfat    umask=000, iocharset=utf8   0   0

но при загузке не маунтстсс - пишет что utf-8 не желательнас кодировка для FAT,
 а после "#mount -a"   все ok...

как написать правильный fstab?

и еще вопросик:
 есть у меня ftp сервер proftpd, настроен на анонимный доступ в папочке public лежат папки с названиями типа music, video.... которые биндсться к реальным папкам системы, т.е. #mount --bind /mnt/win/video /var/ftp/public/video,  как сделать чтоб эти папочки биндились при загрузке?
Kubuntu

Оффлайн cargo

  • Roman Kalashnikov
  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #1 : 22 Декабрь 2005, 15:40:52 »
например так:
/dev/sda1    /mnt/muzik    vfat    auto,quiet,showexec,codepage=866,iocharset=utf8,uid=1000,gid=1000,umask=022,rw,nouser        0    0

Оффлайн Salmir

  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #2 : 22 Декабрь 2005, 16:00:20 »
здравствуйте,
ста тема уже обсуждалась на форуме, но из тех советов ничего не помогло...

fstab пишу
/dev/sda1   /mnt/muzik      vfat   umask=000,iocharset=utf8   0   0
/dev/sda5   /mnt/soft    vfat    umask=000, iocharset=utf8   0   0

но при загузке не маунтстсс - пишет что utf-8 не желательнас кодировка для FAT,
 а после "#mount -a"   все ok...

как написать правильный fstab?

и еще вопросик:
 есть у меня ftp сервер proftpd, настроен на анонимный доступ в папочке public лежат папки с названиями типа music, video.... которые биндсться к реальным папкам системы, т.е. #mount --bind /mnt/win/video /var/ftp/public/video,  как сделать чтоб эти папочки биндились при загрузке?

для fstab попробуй utf8=true вместо iocharset=utf8

а про mount --bind самому интересно!
Хуже дурака только  дурак с инициативой..

Оффлайн cargo

  • Roman Kalashnikov
  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #3 : 22 Декабрь 2005, 16:27:43 »
...
и еще вопросик:
 есть у меня ftp сервер proftpd, настроен на анонимный доступ в папочке public лежат папки с названиями типа music, video.... которые биндсться к реальным папкам системы, т.е. #mount --bind /mnt/win/video /var/ftp/public/video,  как сделать чтоб эти папочки биндились при загрузке?
а почему нельзя просто сделать ln -s /var/ftp/public/video /mnt/win/video???

Оффлайн Salmir

  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #4 : 22 Декабрь 2005, 17:42:03 »
proftpd не воспринимает ссылки (
Хуже дурака только  дурак с инициативой..

Оффлайн cargo

  • Roman Kalashnikov
  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля

Оффлайн Salmir

  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #6 : 22 Декабрь 2005, 20:02:32 »
Как разрешить анонимным пользователсм FTP доступ к папкам вне /home/ftp/? не помогает?

Я канешн все понимаю но если у меня на fat32 100 гигов фильмов зачем мне их копировать в /home/ftp?
не проще туда просто подмонтировать --bindом папку video в /home/ftp/downloads/video
Хуже дурака только  дурак с инициативой..

Оффлайн stan

  • Автор темы
  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #7 : 23 Декабрь 2005, 02:10:13 »
/dev/sda1    /mnt/muzik    vfat    auto,quiet,showexec,codepage=866,iocharset=utf8,uid=1000,gid=1000,umask=022,rw,nouser        0    0

так не помогло


 utf8=true,  вместо  iocharset=utf8

  - тоже не помогло...

Cкорее всего проблема в ubuntu 5.04, посколько 5.10 такой проблемы не наблюдается как мне сказали.


А насчет как сделать при загузке несколько команд типа mount --bind, кто-нибудь все-же подскажет?
Kubuntu

Оффлайн sorib

  • Участник
  • *
  • Сообщений: 159
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #8 : 24 Декабрь 2005, 09:41:14 »
под рукой Ubuntu нет, постому имена файлов могу перепутать
Попробуй написать mount -- bind в /etc/.profile
или прописать в директорию с загрузочными скриптами smth like /etc/init.d/... Shell script с правами 777.

Оффлайн Denis Konstantinov

  • Активист
  • *
  • Сообщений: 864
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #9 : 29 Декабрь 2005, 17:52:26 »
Как разрешить анонимным пользователсм FTP доступ к папкам вне /home/ftp/? не помогает?

Я канешн все понимаю но если у меня на fat32 100 гигов фильмов зачем мне их копировать в /home/ftp?
не проще туда просто подмонтировать --bindом папку video в /home/ftp/downloads/video
Здарофф! iMp!

Я для того чтобы создавать бинды правил proftp стартовый скрипт, прям туда прописывал :)
Да линки он не понимает потомушта работает через chroot.
AltYo консоль для Gtk3 в стиле консоли quake https://forum.ubuntu.ru/index.php?topic=198594.0

Оффлайн stan

  • Автор темы
  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #10 : 29 Декабрь 2005, 18:13:50 »
Здарофф! iMp!

Я для того чтобы создавать бинды правил proftp стартовый скрипт, прям туда прописывал :)
Да линки он не понимает потомушта работает через chroot.


О идес, надо будет попробовать. Думаю работать точно должно. 8)
Kubuntu

Оффлайн stan

  • Автор темы
  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #11 : 11 Январь 2006, 21:16:43 »
/dev/sda1    /mnt/muzik    vfat    auto,quiet,showexec,codepage=866,iocharset=utf8,uid=1000,gid=1000,umask=022,rw,nouser        0    0

так не помогло


 utf8=true,  вместо  iocharset=utf8

  - тоже не помогло...

Cкорее всего проблема в ubuntu 5.04, посколько 5.10 такой проблемы не наблюдается как мне сказали.


Так и есть поставил 5.10 - все просто в ажуре, винты подхватываються на ура, хоть sata, хоть ata  :D
Kubuntu

Оффлайн yaa13

  • Активист
  • *
  • Сообщений: 311
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #12 : 14 Июнь 2006, 20:49:44 »
Цитировать
Я для того чтобы создавать бинды правил proftp стартовый скрипт, прям туда прописывал :)
Хым... Зачем такие сложности с ковырянием стартовых скриптов? У меня в fstab это делают строки:
/home/lamer/Music     /srv/ftp/Music        none       bind                  0 0
/home/lamer/Winsoft  /srv/ftp/WinSoft    none       bind                  0 0
/home/lamer/ISO       /srv/ftp/ISO           none       bind                  0 0
« Последнее редактирование: 22 Март 2007, 22:39:16 от yaa13 »

Оффлайн light.nur

  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #13 : 21 Сентябрь 2008, 13:18:51 »
а что можно придумать, если на винте ntfs, но к нему требуется админу доступ полный (по самбе) а юзерам read-only по фтп?
я пробовал вот так -

root@ftp:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=b948776c-850a-46f9-bfe9-9a6eab049cf5 /               ext3    acl,relatime,errors=remount-ro 0       1
# /dev/sda5
UUID=6da1c9da-1bf5-486b-8996-29a5bdebc268 none            swap    sw              0       0

# подключаем два диска ntfs с игрушками и фильмами,
# сюда разрешен доступ админу по самбе:
/dev/sdb1 /home/ftp/games ntfs-3g defaults,codepage=сp1251,iocharset=utf8,force 0 0
/dev/sde1 /home/ftp/media ntfs-3g defaults,codepage=сp1251,iocharset=utf8,force 0 0

# диск с каталогом инкоминг, открытый на запись анонимусу:
/dev/sda1 /home/ftp/ftp/incoming ext3 rw 0  1

# линкуем те же диски ntfs уже в папку фтп и без права записи:
/home/ftp/games     /home/ftp/ftp/games        none       ro,bind                  0 0
/home/ftp/media     /home/ftp/ftp/media        none       ro,bind                  0 0
root@ftp:~#
(каталог фтп - /home/ftp/ftp)

последние две строки, как я быстро понял, не работают, право записи через фтп все равно почему то остается

как сделать чтоб самбе осталось rw а для фтп чисто ro ?
« Последнее редактирование: 21 Сентябрь 2008, 22:48:42 от light.nur »

Оффлайн light.nur

  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Re: Загрузка + sata-винт
« Ответ #14 : 07 Ноябрь 2008, 12:27:56 »
вопщем запарился искать, купил еще один винт на терабайт, слил туда все и форматнул в ext3...

теперь заодно и проц меньше загружается процессом ntfs3g

 

Страница сгенерирована за 0.06 секунд. Запросов: 22.