Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Почему не включилось 3D ускорение и виснет?  (Прочитано 1445 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WithHeld

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Привет всем! Поставил Ubuntu 7.04 несколько проблем:

С видяхой АТИ - поставил себе прогу которая сама дрова скачала поставила все ок, только все равно 3д ускорение не включилось - заставки лагают + когда захожу в режим консоли а потом обратно (ctrl + alt + F7) комп виснет

может кто сталкивался ((
Kenaya Division

Оффлайн Psy[H[]

  • Активист
  • *
  • Сообщений: 883
  • Маньяк. Ставлю Линух на все что попадется под руку
    • Просмотр профиля
Re: Почему не включилось 3D ускорение и виснет?
« Ответ #1 : 21 Октябрь 2007, 21:27:34 »
какая конкретнее видюха и какие дрова?

сюда для справки:
https://forum.ubuntu.ru/index.php?topic=13730.msg98943#msg98943

что прописано в xorg.conf в секции Device, в параметре Driver?

Есть карты, которые закрытым драйвером не поддерживаются.
Я знаю только то, что ничего не знаю.
                                     

Оффлайн WithHeld

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Почему не включилось 3D ускорение и виснет?
« Ответ #2 : 21 Октябрь 2007, 22:02:19 »
дрова ставил самые свежие программой ENVY
сначала не работал директ рендеринг - сейчас включил
fglrxinfo:

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9500
OpenGL version string: 2.0.6747 (8.40.4)

glxinfo | grep rende:

direct rendering: Yes
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
OpenGL renderer string: RADEON 9500

но при этом заставки лагают ужасть!
видяха 9500 радеон
Kenaya Division

Оффлайн Fliker-09

  • Активист
  • *
  • Сообщений: 338
  • Linux rocks and KDE too!
    • Просмотр профиля
Re: Почему не включилось 3D ускорение и виснет?
« Ответ #3 : 22 Октябрь 2007, 21:19:02 »
Крайне рекомендую сменить дрова на Mesa 7.0 (ни в коем случае старее!) потому что в этой версий была добавлена поддержка самый современных технологий и код дров для семейства r300 (ваша видюха к нему относится) был прочищен. Эти дрова ОпенСоурс и расчитанны для старых семейств Радеонов. А нынешняя версия fglrx дров страдает низкой производительностью (скоро должна поспеть новая заметно улучшенная но когда это будет - фиг его знает) так что советую всё-таки сменить дровишки и удалить Енви :).

Оффлайн WithHeld

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Почему не включилось 3D ускорение и виснет?
« Ответ #4 : 22 Октябрь 2007, 23:03:42 »
ах вот оно в чем дело! :-) а где взять эти меса и удалить старые?
Kenaya Division

Оффлайн Fliker-09

  • Активист
  • *
  • Сообщений: 338
  • Linux rocks and KDE too!
    • Просмотр профиля
Re: Почему не включилось 3D ускорение и виснет?
« Ответ #5 : 23 Октябрь 2007, 21:55:33 »
Для начала читай это - http://www.mesa3d.org/download.html. Далее вот это - http://www.mesa3d.org/install.html. Это конечно не так просто как Енви но это стоит того ;). Если что-то пойдёт не так пиши.

Оффлайн WithHeld

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Почему не включилось 3D ускорение и виснет?
« Ответ #6 : 24 Октябрь 2007, 21:23:31 »
оу жесть
на выходных с пивом посижу попробую сообразить
Kenaya Division

Оффлайн WithHeld

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Почему не включилось 3D ускорение и виснет?
« Ответ #7 : 25 Октябрь 2007, 20:45:41 »
ну вот как раз непонятно - скачал - куда распаковать и как ставить - файл компиляшн вообще не понял ((
открыл отдельную тему - https://forum.ubuntu.ru/index.php?board=25.0 - надеюсь на поддержку!
Kenaya Division

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.