Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: CAPTCHA поле отката PHP с 5.3 на 5.2. перестала работать  (Прочитано 1357 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн admin4ek

  • Автор темы
  • Участник
  • *
  • Сообщений: 105
    • Просмотр профиля
и вот что выдает
root@tk-net:~# php -v
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/imap.so' - /usr/lib/php5/20060613+lfs/imap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/mcrypt.so' - /usr/lib/php5/20060613+lfs/mcrypt.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.2.10-2ubuntu6 with Suhosin-Patch 0.9.7 (cli) (built: Oct 23 2009 16:30:10)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
откат делал по ману   http://www.sablog.ru/ubuntu-10-04-php-5-3-php-5-2/

Пользователь решил продолжить мысль 16 Март 2011, 21:12:12:
Help!! Хостинг не работает как положено(((((

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Попробуй, авось прокатит:
sudo apt-get purge php5-gd php5-imap php5-mcrypt
sudo apt-get install php5-gd

Оффлайн admin4ek

  • Автор темы
  • Участник
  • *
  • Сообщений: 105
    • Просмотр профиля
уже пробовал(((

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Ну а пакетный менеджер какую версию показывает пакета php5-gd? Сам файл /usr/lib/php5/20060613+lfs/gd.so присутствует?

Оффлайн admin4ek

  • Автор темы
  • Участник
  • *
  • Сообщений: 105
    • Просмотр профиля
mysqli.so  mysql.so  pdo_mysql.so  pdo.so
вот все что есть в папке

Пользователь решил продолжить мысль 16 Март 2011, 22:46:15:
Решил проблему повторной переуствновкой apt-get install php5-gd
« Последнее редактирование: 16 Март 2011, 22:46:15 от admin4ek »

Оффлайн ANtlord

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Добрый день. У меня та же проблема но переустановка не спасла. Так же откатил и перестала работать эта штука + к этому после установки Zend Optimizer сайты ИНОГДА выдают 324 ошибка, а firefox просто предлагает скачать php-файл. А логах Apache2 пишет [notice] child pid 13102 exit signal Segmentation fault (11)

P..S. в phpinfo() не показывается табличка mcrypt. Хотя все установлено. Версия mcrypt 5.2.6 (в synaptic посмотрел). И synaptic говорит, что mcrypt установлен с ошибками.
« Последнее редактирование: 04 Июль 2011, 20:42:30 от ANtlord »

 

Страница сгенерирована за 0.054 секунд. Запросов: 25.