Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: (Новичок) Срочно нужна помощь в установке программы S-3  (Прочитано 543 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн timka288

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Понадобилось для работы установить одну программу, начал читать инструкцию сделал как там написано ничего не выходит.. Помогите пожалуйста я пока очень зелен в Ubuntu! Ниже привожу  текст инструкции:
Инсталляция S3-IDE в Linux и Solaris

Скачайте скрипт s3-ide-X.X.X.XXXX-linux.sh где XXX - номер версии, отсюда:

 S3-IDE для Linux (92.27 Мбайт 2010-11-06 00:21:50)

Установите флаг выполнения командой

chmod a+x ./s3-ide-X.X.X.XXXX-linux.sh

Запустите скрипт командой

./s3-ide-X.X.X.XXXX-linux.sh

В зависимости от установленной локали, инсталлятор запустится на русском или на английском языке

Нажмите Далее.


Все попытки проделать выше описанное за недостаточностью опыта успехом не увенчались :( :'(

timka@timka-Aspire-5670:~$  sudo chmod a+x ./s3-ide-1.5.0.3315-linux.sh
[sudo] password for timka:
chmod: невозможно получить доступ к `./s3-ide-1.5.0.3315-linux.sh': Нет такого файла или каталога
Хотя сам файл точно есть и находится в папке Downloads постарался на сколько смог пояснить в чем проблема, жду вашей помощи :-[

track

  • Гость
"./" это уберите

Пользователь решил продолжить мысль 22 Март 2011, 22:05:04:
и судо ненадо ... если файл вам принадлежит.
« Последнее редактирование: 22 Март 2011, 22:05:04 от track »

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Думаю сначала нужно зайти в эту папку ;)
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн xuser73

  • Активист
  • *
  • Сообщений: 562
    • Просмотр профиля
... timka@timka-Aspire-5670:~$  sudo chmod a+x ./s3-ide-1.5.0.3315-linux.sh
[sudo] password for timka:
chmod: невозможно получить доступ к `./s3-ide-1.5.0.3315-linux.sh': Нет такого файла или каталога
Хотя сам файл точно есть и находится в папке Downloads постарался на сколько смог пояснить в чем проблема, жду вашей помощи :-
У Вас файл находится в папке Downloads, а команде говорите, что находится он в Вашей домашней папке. Перенесите s3-ide-1.5.0.3315-linux.sh в домашнюю папку и выполните действия из инструкции.
Настоящему коту всегда март.

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
Цитировать
sudo chmod a+x ./s3-ide-1.5.0.3315-linux.sh
В терминале нужно убедиться, что находитесь в нужной папке
pwdЕсли это не так выполняем
cd путь_к_папке
Второй способ: в файловом менеджере кликаем правой кнопкой по файлу выбираем СВОЙСТВА затем вкладку ПРАВА и внизу ставим галочку на ПОЗВОЛИТЬ ВЫПОЛНЕНИЕ ФАЙЛА КАК ПРОГРАММЫ
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

Оффлайн timka288

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
зашел в терминале в каталог содержащий файл попробовал оба варианта без судо и "./ " результат получил следующий

timka@timka-Aspire-5670:~/Downloads$ chmod a+x ./s3-ide-1.5.0.3315-linux.sh
timka@timka-Aspire-5670:~/Downloads$  ./s3-ide-1.5.0.3315-linux.sh
Configuring the installer...

Installer file /home/timka/Downloads/s3-ide-1.5.0.3315-linux.sh seems to be corrupted


timka@timka-Aspire-5670:~/Downloads$ chmod a+x s3-ide-1.5.0.3315-linux.sh
timka@timka-Aspire-5670:~/Downloads$ s3-ide-1.5.0.3315-linux.sh
s3-ide-1.5.0.3315-linux.sh: команда не найдена


Пользователь решил продолжить мысль 22 Март 2011, 22:16:52:
... timka@timka-Aspire-5670:~$  sudo chmod a+x ./s3-ide-1.5.0.3315-linux.sh
[sudo] password for timka:
chmod: невозможно получить доступ к `./s3-ide-1.5.0.3315-linux.sh': Нет такого файла или каталога
Хотя сам файл точно есть и находится в папке Downloads постарался на сколько смог пояснить в чем проблема, жду вашей помощи :-
У Вас файл находится в папке Downloads, а команде говорите, что находится он в Вашей домашней папке. Перенесите s3-ide-1.5.0.3315-linux.sh в домашнюю папку и выполните действия из инструкции.
пробовал не помогло(((
« Последнее редактирование: 22 Март 2011, 22:16:52 от timka288 »

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
... timka@timka-Aspire-5670:~$  sudo chmod a+x ./s3-ide-1.5.0.3315-linux.sh
[sudo] password for timka:
chmod: невозможно получить доступ к `./s3-ide-1.5.0.3315-linux.sh': Нет такого файла или каталога
Хотя сам файл точно есть и находится в папке Downloads постарался на сколько смог пояснить в чем проблема, жду вашей помощи :-
У Вас файл находится в папке Downloads, а команде говорите, что находится он в Вашей домашней папке. Перенесите s3-ide-1.5.0.3315-linux.sh в домашнюю папку и выполните действия из инструкции.

Чтобы было понятнее - поясню:
timka@timka-Aspire-5670:~$  sudo chmod a+x ./s3-ide-1.5.0.3315-linux.shПеред знаком $ пишется текущее положение в дереве каталогов. Знаком ~ (тильда) сокращенно обзывается домашний каталог. Пример:
gadd@gadd-desktop:~$ pwd
/home/gadd
gadd@gadd-desktop:~$ cd tmp
gadd@gadd-desktop:~/tmp$ pwd
/home/gadd/tmp
gadd@gadd-desktop:~/tmp$
Поэтому Вы пытаетесь выполнить операции над файлом, который находится в другой папке

Выполните команду (предполагается, что папка Downloads находится в домашней директории)
cd Downoadsи затем lsВ появившемся списке Вы должны увидеть нужные Вам файлы, с которыми планируете работать. Далее по инструкции

Пользователь решил продолжить мысль 22 Март 2011, 22:30:57:
Информация с сайта:
Цитировать
Для работы S3 необходима виртуальная машина Java Runtime Environment (JRE) версии не ниже 1.6.22.
У Вас стоит JRE?
Также может быть, что инсталлятор был поврежден при скачивании, или был таким

./s3-ide-X.X.X.XXXX-linux.sh выполнять именно с ./ , если запуск происходит из текущей директории
chmod a+x s3-ide-1.5.0.3315-linux.sh можно делать только один раз (дает права на исполнение файлу)
« Последнее редактирование: 22 Март 2011, 22:30:57 от Gadd »
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

Оффлайн timka288

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
как это проверить установлен ли JRE?

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
как это проверить установлен ли JRE?

Почитайте официальную инструкцию более внимательно. Во второй половине - об установке в юниксах.
Цитировать
S3 не будет работать с открытыми/свободными реализациями Java, которые можно найти во многих Linux-дистрибутивах (например, в Ubuntu, Debian), поскольку они либо устарели, либо неполны. Скачайте и установите последнюю версию Sun's Java Runtime Environment c сайта http://www.java.com, либо используйте идущую с инсталлятором S3.

После инсталляции проверьте, что java runtime имеет нужную версию, не ниже 1.6.22, набрав в окне терминала
java -version
« Последнее редактирование: 22 Март 2011, 22:49:44 от Gadd »
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

Оффлайн timka288

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
проверил как написано в инструкции вот что получилось:

timka@timka-Aspire-5670:~$ java -version
Приложение 'java' может быть найдено в следующих пакетах:
 * gcj-4.4-jre-headless
 * gcj-4.5-jre-headless
 * openjdk-6-jre-headless
Попробуйте: sudo apt-get install <выбранный пакет>
 
на всякий случай удалил старый файл решил заново скачать чтоб исключить вариант с повреждением..
« Последнее редактирование: 22 Март 2011, 22:58:08 от timka288 »

track

  • Гость
sudo apt-get install openjdk

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
sudo apt-get install openjdk


Я бы сказал, что не openjdk, а sun-java6-jre, как рекомендуется на сайте, чтобы не было у новичка сюрпризов. Поэтому
sudo apt-get install sun-java6-jreили выбрать пакет sun-java6-jre в Синаптике
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

track

  • Гость
>>Я бы сказал, что не openjdk, а sun-java6-jre, как рекомендуется на сайте
на каком сайте? а репа с сановской явой подключена?

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
>>Я бы сказал, что не openjdk, а sun-java6-jre, как рекомендуется на сайте
на каком сайте? а репа с сановской явой подключена?

Сайт
Сановская ява есть в убунтовских репах. Версия 6.24-1build0.10.04.1
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

track

  • Гость
>>Сановская ява есть в убунтовских репах. Версия 6.24-1build0.10.04.1
сомневаюсь скорее в партнерской есть, но её еще надо суметь подключить :)

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.