Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Как принудительно ставить модули из синаптика на python 2.7, а НЕ 2.6?  (Прочитано 2064 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн elderkrab

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
По умолчанию в 10.10 кубунте шёл уже установленный python 2.6.
Мне для разработки нужен python 2.7.

Но проблема в том, что различные дополнительные либы из synaptic (как уже установленные, так и те, которые я только хочу поставить) ставятся на python 2.6, который где-то прописан по умолчанию.

Вопрос: как корректно и самым идеологически верным способом сменить в системе версию по умолчанию python с 2.6 на 2.7 и, что важно, не порушит ли это рабочесть программ в системе, которые сейчас интерпретируются питоном 2.6?

Если же есть риск порушить их рабочесть (хотя 2.6 -> 2.7 это всё-таки не переход на третью ветку, по идее ничего страшного не должно произойти), то как сделать, чтобы нужные мне модули ставились на 2.7, но по умолчанию все программы в системе продолжали работать на 2.6? (лично меня для запуска  собственных программ устраивает запуск через команду python2.7 [с указанием версии], а не просто python, который ведёт на 2.6)
« Последнее редактирование: 24 Март 2011, 18:11:56 от elderkrab »

Оффлайн Мангуст

  • Любитель
  • *
  • Сообщений: 98
    • Просмотр профиля
Просто заменить Питон 2.6 на 2.7 нельзя - полетит сразу, допустим, PyGTK - судоку перестанет работать :) Ну, конечно, и более важные программы.

Выхода 2 - компилировать самому, только последняя команда должна быть sudo make altinstall (лучше sudo checkinstall make altinstall)  или скачать готовый ActiveState Python, установить куда хош, переименовать python в python2.7 (ну и остальное, idle, допустим). Потом в .bashrc добавить путь к папке bin к $PATH. А модули устанавливать самому - скачиваешь и sudo python2.7 setup.py install и установятся куда надо.

Вопрос на засыпку - а чем так НУ ОЧЕНЬ нужен python2.7? Поработай с 2.6, подожди Natty, там он будет по умолчанию.
« Последнее редактирование: 24 Март 2011, 19:40:57 от Мангуст »

Оффлайн elderkrab

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Цитировать
компилировать самому
Питон? Что это даст?

Цитировать
или скачать готовый ActiveState Python
Это альтернативная реализация интерпретатора? Меня интересует стандартный CPython.

Цитировать
переименовать python в python2.7
Не совсем понятно, где это сделать и к чему это приведёт.

Сразу вопрос: а если во всей системе просто поменять настройку (не знаю правда где), чтобы python вёл не на 2.6, а на 2.7, программы. использующие 2.6 отвалятся? Иными словами они тягают интерпретатор по команде "python" или "python2.6"? (или об этом нельзя судить достоверно, может быть и так и так?)

Цитировать
Вопрос на засыпку - а чем так НУ ОЧЕНЬ нужен python2.7? Поработай с 2.6, подожди Natty, там он будет по умолчанию.
Вообще-то хотелось бы даже третий питон :) Но огорчает, что под него не все нужные либы портированы :(

Цитировать
А модули устанавливать - python2.7 setup.py install и установятся куда надо.
В том то и дело, что хотелось бы ставить синаптиком, чтобы сохранить возможность автообновления модулей. Я начал ставить PIL для питона именно таким, ручным способом, а он попросил за собой поставить несколько либ по работе с картинками... я так посмотрел и вздохнул :) не хотелось бы всё это ставить вручную, а потом при каждом обновлении ещё и вручную обновлять. Тем более у меня в системе, согласно синаптику, все эти либы уже установлены, проблема в том, что они поставлены для 2.6, а 2.7 их просто не видит.

Итак, идеальный по моему мнению вариант: добиться того, чтобы команда python вела по-старинке к 2.6 версии (уже есть), модули синаптиком тоже ставились по умолчанию для 2.6 (есть), НО ПРИ ЭТОМ также чтобы была возможность вызвать 2.7 с помощью python2.7 (есть) и также ставить модули синаптиком для 2.7, сказав про это как-то синаптику отдельно (нету, как добиться?).

updated: пожалуй я заблуждался насчёт того, что модули ставятся под определённую версию питона. На самом деле модули ставятся в свою отдельную папку, а каждая версия питона уже самостоятельно мониторит её на предмет дополнений. Так или иначе, похоже одна проблема исчерпана.


Однако остаётся один вопрос: кто отвечает за то, чтобы команда python вела к версии 2.6, а не 2.7, сам питон или это где-то в системе прописано?
« Последнее редактирование: 25 Март 2011, 11:37:15 от elderkrab »

Оффлайн kpako396p

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Подниму тему, т.к. этот вопрос так же интересует. Только Python 2.7 поменять на 3.2?

Оффлайн sash23

  • Участник
  • *
  • Сообщений: 130
    • Просмотр профиля
Подниму тему, т.к. этот вопрос так же интересует. Только Python 2.7 поменять на 3.2?
для ubuntu 12.04
sudo apt-get install python3и после этого использовать python3

 

Страница сгенерирована за 0.063 секунд. Запросов: 24.