Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Странный запуск grub а потом и burg  (Прочитано 616 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pasha_r

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Уважаемые знатоки!!! Помогите понять, что происходит и где копать.
Мой нетбук Samsung проявляет странности при загрузке.

Установлены в системы: WinXP SP32 и Ubuntu 10.10 на разных разделах.
Сначало был загрузчик GRUB в MBR а потом поставил BURG.

При запуске нетбук помнит, что загружалось в прошлый раз.
Если при очередном запуске выбирается система, отличная от предыдущего раза, то
в процессе загрузки происходит Reset. Но он уже успевает запомнить, что грузилось.
Поэтому со второго раза загружается успешно.

Таким образом, перезагрузка в другую систему получается со второго раза.

Я пытался настраивать GRUB. Потом установил BURG. Но все то же самое(

Хочется понять, откуда ноги растут.
Если кто знает, подскажите, пожалуйста!!!

Оффлайн GonZaleZ

  • Активист
  • *
  • Сообщений: 628
  • Нет, не включат
    • Просмотр профиля
Re: Странный запуск grub а потом и burg
« Ответ #1 : 25 Март 2011, 06:27:56 »
Хмм... У вас 2 загрузчика? - Зря...

А на самом деле: при наличии двух систем, чем эта функция удобнее, чем просто настройка стандартного пункта загрузки?
HP Pavilion dv6 1317-er | Ubuntu 11.04
Intel Core 2 Duo 2,2 ГГц | 3 Gb RAM | ATI Mobility Radeon 4650 HD 1Gb
У меня есть айфон и айпад - тролльте, господа...

Оффлайн Pasha_r

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Странный запуск grub а потом и burg
« Ответ #2 : 25 Март 2011, 13:26:24 »
Сначала был один загрузчик GRUB. Думал в нем дело и поставил BURG, там кстати при установке BURGа есть возможность отключить GRUB.

>чем эта функция удобнее, чем просто настройка стандартного пункта загрузки?
Так как у меня нетбук, то в стандартном загрузчике буквы меню маленькие, приходится всматриваться.......в BURGе же наоборот иконки, что гораздо удобнее.

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4360
  • Все по палатам!
    • Просмотр профиля
Re: Странный запуск grub а потом и burg
« Ответ #3 : 25 Март 2011, 13:33:47 »
Таким образом, перезагрузка в другую систему получается со второго раза.
То же самое (и не у меня одного). Из любого линукса в вин и обратно. Линукс-линукс (разные) проблем нет.
Забил...  ;)
А какой бук?
Извините, я все еще учусь

Оффлайн Pasha_r

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Странный запуск grub а потом и burg
« Ответ #4 : 25 Март 2011, 13:45:28 »
Нетбук Samsung NC110!

Значит дело в загрузчике?
Мне тут посоветовали попробовать поставить загрузчик LILO, но боюсь тут этим проблему не решить. :-\
Может из форумчан кто то сталкивался с такой проблемой и нашел решение??? :(

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4360
  • Все по палатам!
    • Просмотр профиля
Re: Странный запуск grub а потом и burg
« Ответ #5 : 25 Март 2011, 13:51:22 »
Значит дело в загрузчике?
В прошивке или биосе видимо... У меня последняя стоит (N210).
Извините, я все еще учусь

Оффлайн Pasha_r

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Странный запуск grub а потом и burg
« Ответ #6 : 25 Март 2011, 13:58:09 »
Значит дело в загрузчике?
В прошивке или биосе видимо... У меня последняя стоит (N210).

Так если, как уже говорилось, Linux - Linux все грузится нормально, а Win - Linux с таким багом, то может вовсе и не в биосе......думаю нужно пробовать  загрузчик допиливать для таких случаев, только как? :-\

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4360
  • Все по палатам!
    • Просмотр профиля
Re: Странный запуск grub а потом и burg
« Ответ #7 : 25 Март 2011, 14:24:58 »
думаю нужно пробовать  загрузчик допиливать для таких случаев
Пробовал разные линуксы с разными загрузчиками - проблем нет, и с лайвСД (то есть без загрузчика с диска) тоже. Проблема похоже с загрузчиком Вин.
Извините, я все еще учусь

 

Страница сгенерирована за 0.054 секунд. Запросов: 22.