Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: [РЕШЕНО] Проблема с пакетами  (Прочитано 22939 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Bionicman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
[РЕШЕНО] Проблема с пакетами
« : 28 Марта 2011, 10:33:18 »
Приветствую.

В своё время поставил на нетбук Ubuntu Netbook 10.10 (новая установка, не обновление). Поразившись, как изгадили Unity, установил пакет ubuntu-desktop и стал жить на нормальном Гноме. Система какое-то время жила нормально, постоянно обновлялась и использовалась более чем активно. Но в последнее время при обновлении пакетов aptitude рапортует о пакетах, которые не возможно обновить. И их становится всё больше. Дошло до того, что таким "невозможным" пакетом стал tzdata, который и сам не обновляется, и не даёт другим пакетам обновляться и даже устанавливаться.

В source list примерно такое:
[root@telesto ~]# cat /etc/apt/sources.list | grep -v "^$" | grep -v "^#"
deb http://ru.archive.ubuntu.com/ubuntu/ maverick main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ maverick main restricted
deb http://ru.archive.ubuntu.com/ubuntu/ maverick-updates main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ maverick-updates main restricted
deb http://ru.archive.ubuntu.com/ubuntu/ maverick universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ maverick universe
deb http://ru.archive.ubuntu.com/ubuntu/ maverick-updates universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ maverick-updates universe
deb http://ru.archive.ubuntu.com/ubuntu/ maverick multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ maverick multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ maverick-updates multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ maverick-updates multiverse
deb http://archive.canonical.com/ubuntu maverick partner
deb-src http://archive.canonical.com/ubuntu maverick partner
deb http://extras.ubuntu.com/ubuntu maverick main
deb-src http://extras.ubuntu.com/ubuntu maverick main
deb http://security.ubuntu.com/ubuntu maverick-security main restricted
deb-src http://security.ubuntu.com/ubuntu maverick-security main restricted
deb http://security.ubuntu.com/ubuntu maverick-security universe
deb-src http://security.ubuntu.com/ubuntu maverick-security universe
deb http://security.ubuntu.com/ubuntu maverick-security multiverse
deb-src http://security.ubuntu.com/ubuntu maverick-security multiverse

Если я хочу поставить, к примеру, mplayer, я получаю следующее:
[root@telesto ~]# apt-get install mplayer
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Будут установлены следующие дополнительные пакеты:
  libmp3lame0 libsvga1 libvdpau1 libxvidcore4
Предлагаемые пакеты:
  nvidia-vdpau-driver vdpau-driver mplayer-doc netselect fping
НОВЫЕ пакеты, которые будут установлены:
  libmp3lame0 libsvga1 libvdpau1 libxvidcore4 mplayer
обновлено 0, установлено 5 новых пакетов, для удаления отмечено 0 пакетов, и 91 пакетов не обновлено.
не установлено до конца или удалено 9 пакетов.
Необходимо скачать 0B/3 744kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 7 541kB.
Хотите продолжить [Д/н]? y
Настраивается пакет tzdata (2011d-0ubuntu0.10.10) ...
dpkg: не удалось обработать параметр tzdata (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
При обработке следующих пакетов произошли ошибки:
 tzdata
E: Sub-process /usr/bin/dpkg returned an error code (1)

Опция -f не помогает, aptitude upgrade выдаёт следующий листинг:
[root@telesto ~]# aptitude upgrade                                                                                                            
Следующие пакеты будут обновлены:                                                                                                              
  adobe-flashplugin aptdaemon avahi-autoipd avahi-daemon avahi-utils bash-completion bind9-host brasero brasero-cdrkit brasero-common dbus    
  dbus-x11 dnsutils firefox firefox-branding firefox-gnome-support fuse-utils gnome-screensaver icedtea-6-jre-cacao libavahi-core7            
  libavahi-glib1 libavahi-gobject0 libavahi-qt3-1 libavahi-ui0 libbind9-60 libbrasero-media1 libdbi0 libdns66 libfuse2 libglib2.0-0            
  libglib2.0-data libisc60 libisccc60 libisccfg60 liblwres60 libpango1.0-0 libpango1.0-common libpoppler-glib5 libpoppler-qt4-3                
  libsmbclient libsyncdaemon-1.0-1 libtiff4 libvlc5 libvlccore4 libvpx0 libwbclient0 libwxbase2.8-0 libwxgtk2.8-0 linux-firmware              
  linux-generic linux-image-generic linux-libc-dev mozilla-plugin-vlc openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib                  
  openssh-client openssh-server openssl pm-utils python-aptdaemon python-aptdaemon-gtk python-avahi python-ubuntuone-client                    
  python-wxgtk2.8 python-wxversion rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugin-coherence rhythmbox-plugins software-center          
  telepathy-gabble thunderbird thunderbird-gnome-support transmission-common transmission-gtk ubuntuone-client ubuntuone-client-gnome vlc      
  vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse xkb-data xserver-xorg-video-geode xserver-xorg-video-intel xulrunner-1.9.2              
Следующие частично установленные пакеты будут настроены:                                                                                      
  cups cups-bsd hplip hplip-cups man-db tzdata tzdata-java wine wine1.2                                                                        
87 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 4 пакетов не обновлено.                                          
Необходимо получить 0Б/126MБ архивов. После распаковки освободится 2 114kБ.                                                                    
Хотите продолжить? [Y/n/?] y                                                                                                                  
Извлечение шаблонов из пакетов: 100%                                                                                                          
Предварительная настройка пакетов ...                                                                                                          
Настраивается пакет tzdata (2011d-0ubuntu0.10.10) ...                                                                                          
dpkg: не удалось обработать параметр tzdata (--configure):                                                                                    
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10                                                                      
При обработке следующих пакетов произошли ошибки:                                                                                              
 tzdata                                                                                                                                        
E: Sub-process /usr/bin/dpkg returned an error code (1)                                                                                        
Не удалось установить пакет.  Попытка восстановить:                                                                                            
Настраивается пакет man-db (2.5.7-4) ...                                                                                                      
dpkg: не удалось обработать параметр man-db (--configure):                                                                                    
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10                                                                      
Настраивается пакет wine1.2 (1.2.2-0ubuntu2~maverick2) ...                                                                                    
dpkg: не удалось обработать параметр wine1.2 (--configure):                                                                                    
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10                                                                      
Настраивается пакет tzdata (2011d-0ubuntu0.10.10) ...                                                                                          
dpkg: не удалось обработать параметр tzdata (--configure):                                                                                    
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10                                                                      
dpkg: зависимости пакетов не позволяют настроить пакет wine:                                                                                  
 wine зависит от wine1.2, однако:                                                                                                              
  Пакет wine1.2 пока не настроен.                                                                                                              
dpkg: не удалось обработать параметр wine (--configure):                                                                                      
 проблемы зависимостей -- оставляем не настроенным                                                                                            
Настраивается пакет cups-bsd (1.4.4-6ubuntu2.3) ...                                                                                            
dpkg: не удалось обработать параметр cups-bsd (--configure):                                                                                  
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10                                                                      
Настраивается пакет cups (1.4.4-6ubuntu2.3) ...                                                                                                
dpkg: не удалось обработать параметр cups (--configure):                                                                                      
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10                                                                      
dpkg: зависимости пакетов не позволяют настроить пакет tzdata-java:                                                                            
 tzdata-java зависит от tzdata (= 2011d-0ubuntu0.10.10), однако:                                                                              
  Пакет tzdata пока не настроен.                                                                                                              
dpkg: не удалось обработать параметр tzdata-java (--configure):                                                                                
 проблемы зависимостей -- оставляем не настроенным                                                                                            
dpkg: зависимости пакетов не позволяют настроить пакет hplip-cups:                                                                            
 hplip-cups зависит от cups, однако:                                                                                                          
  Пакет cups пока не настроен.                                                                                                                
dpkg: не удалось обработать параметр hplip-cups (--configure):                                                                                
 проблемы зависимостей -- оставляем не настроенным                                                                                            
dpkg: зависимости пакетов не позволяют настроить пакет hplip:                                                                                  
 hplip зависит от cups (>= 1.1.20), однако:                                                                                                    
  Пакет cups пока не настроен.                                                                                                                
dpkg: не удалось обработать параметр hplip (--configure):                                                                                      
 проблемы зависимостей -- оставляем не настроенным                                                                                            
При обработке следующих пакетов произошли ошибки:                                                                                              
 man-db                                                                                                                                        
 wine1.2                                                                                                                                      
 tzdata                                                                                                                                        
 wine                                                                                                                                          
 cups-bsd                                                                                                                                      
 cups                                                                                                                                          
 tzdata-java                                                                                                                                  
 hplip-cups                                                                                                                                    
 hplip

Как от такого избавиться и от чего это могло возниктуть?
« Последнее редактирование: 28 Марта 2011, 21:43:33 от RazrFalcon »

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6127
    • Просмотр профиля
Re: Проблема с пакетами
« Ответ #1 : 28 Марта 2011, 10:40:55 »
1. Перейти на основной сервер в источниках приложений,
2. выполнить
sudo aptitude update
sudo dpkg --configure -a
sudo aptitude full-upgrade

Оффлайн Bionicman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Проблема с пакетами
« Ответ #2 : 28 Марта 2011, 13:42:23 »
1. Перейти на основной сервер в источниках приложений,
2. выполнить
sudo aptitude update
sudo dpkg --configure -a
sudo aptitude full-upgrade


(Нажмите, чтобы показать/скрыть)

aptitude full-upgrade тоже ничего нового не принёс.
« Последнее редактирование: 28 Марта 2011, 21:44:03 от RazrFalcon »

Оффлайн keepiledar

  • Любитель
  • *
  • Сообщений: 92
  • I'am the LameR
    • Просмотр профиля
Re: Проблема с пакетами
« Ответ #3 : 28 Марта 2011, 15:05:16 »
На ЛОРе
эрэм эрэф /var/cache/debconf/* dpkg-reconfigure debconf apt-get update && apt-get upgradeМожет, поможет?
Взято отсюда
http://www.linux.org.ru/forum/general/5159539

Оффлайн Bionicman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Проблема с пакетами
« Ответ #4 : 28 Марта 2011, 21:28:02 »
На ЛОРе
эрэм эрэф /var/cache/debconf/* dpkg-reconfigure debconf apt-get update && apt-get upgradeМожет, поможет?
Взято отсюда
http://www.linux.org.ru/forum/general/5159539

Вот, то что нужно. Это помогло.

Однозначно в мемориз.

 

Страница сгенерирована за 0.114 секунд. Запросов: 23.