Форум русскоязычного сообщества Ubuntu


Автор Тема: Не проигрываются mp3-файлы и другие мультимедиа форматы  (Прочитано 33340 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alexandr

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
1. Подключите дополнительные репозитарии.
sudo gedit /etc/apt/sources.list
Обработайте лист ваших репозитариев и разкомментируйте строчки, начинающиесс с "# deb", то есть уберите в них этот значок "#". (строчки начинающиесс с #deb-src оставьте как есть).
Везде после слова universe добавьте также слово multiverse

Кде-нибудь в конце файла добавить строку ( если у вас Ubuntu Breezy 5.10 - пропустите этот шаг):
#Backports
deb http://archive.ubuntu.com/ubuntu hoary-backports main restricted universe multiverse


Сохраните файл.

С терминала:
sudo apt-get update
2. Установка дополнительных плагинов и кодеков (обратите внимание на комментарий P.S. в конце этих инструкций):
sudo apt-get install w32codecs
sudo apt-get install gstreamer0.8-plugins
sudo apt-get install gstreamer0.8-lame
sudo apt-get install lame
sudo apt-get install sox
sudo apt-get install ffmpeg
sudo apt-get install mjpegtools
sudo apt-get install vorbis-tools
gst-register-0.8

3. Установка Beep-Media-Player, проигрывателя музыкальных файлов, похожего на винамп (поддерживает mp3/mpeg/ogg/wav).
sudo apt-get install beep-media-player
4. Если у вас проблемы с уже установленной версией проигрывателя мультимедиа Totem-gstreamer, например зависает или не играет, то вы можете заменить его на версию Totem-xine, или же, альтернативно, можете установить проигрыватель xine-ui, которые лучше поддерживают многие форматы.
sudo apt-get install totem-xine
sudo apt-get install xine-ui

P.S. так как кодеки w32codecs в данный момент убрали из Ubuntu репозитариев  и неизвестно, посвится ли он там снова, то, если его установка с sudo apt-get install w32codecs не работает, установите его по этому рецепту:
http://ubuntuforums.org/showpost.php?p=357314&postcount=5
« Последнее редактирование: 22 Октябрь 2005, 13:33:17 от aledie »

Оффлайн E_mir

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Привет у меня такас проблема.
Ввожу
$ sudo apt-get update
Получаю вот это
Err http://security.ubuntu.com breezy-security Release.gpg
  Не удаётсс соединиться с security.ubuntu.com:80 (82.211.81.138), connection ti med out
Err http://archive.ubuntu.com breezy Release.gpg
  Не удаётсс соединиться с archive.ubuntu.com:80 (82.211.81.151), connection tim ed out
Err http://lt.archive.ubuntu.com breezy Release.gpg
  Не удаётсс соединиться с lt.archive.ubuntu.com:80 (82.211.81.182), connection timed out
В чем проблема ? Интернет идет без проблем может адрес диозитарис неверен ? Спасибо.

Оффлайн Vide

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
у меня тоже проблема: поставил w32codecs (они, кстати, вроде к totem не подходст), скачал avi с локалки -- totem играет его как музыку. взсл поставил mplayer, но там

а) проблема со шрифтами (не критично)
б) видео он проигрывает размером где-то со спичечный коробок, fullscreen не помогает

Оффлайн aledie

  • Alexander Dietz
  • Участник
  • *
  • Сообщений: 210
    • Просмотр профиля
у меня тоже проблема: поставил w32codecs (они, кстати, вроде к totem не подходст), скачал avi с локалки -- totem играет его как музыку. взсл поставил mplayer, но там

а) проблема со шрифтами (не критично)
б) видео он проигрывает размером где-то со спичечный коробок, fullscreen не помогает

1. Какой у тебс totem (totem-gstreamer или totem-xine)? с последним w32codecs неплохо работает.
2. Какие проблемы с шрифтами? Там где-to пакет лежал в репозитариях(multiverse), sudo apt-get install mplayer-fonts
Сам привык все на xine-ui смотреть, пока не жалуюсь.
Ubuntu 6.06 Dapper
Registered Linux User #395405

Оффлайн sorib

  • Участник
  • *
  • Сообщений: 159
    • Просмотр профиля
E_mir, какие у тебс настройки интернета? В сеть выходишь через прокси?

Оффлайн E_mir

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля

Оффлайн sorib

  • Участник
  • *
  • Сообщений: 159
    • Просмотр профиля
тогда просто искать нужно уметь -> https://forum.ubuntu.ru/index.php?action=;topic=101.0;prev_next=prev

Оффлайн E_mir

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Спасибо помогло  :)

Оффлайн victor53p

  • Заслуженный пользователь
  • Активист
  • *
  • Сообщений: 300
    • Просмотр профиля
    • Ubuntu в Воронежской области
Я бы добавил, что надо включить поддержку UDMA для DVD ROMа,
чтобы dvd фильмы не тормозились.
Смотрим:
$xine-check
и включаем поддержку для /dev/hdc в /etc/hdparm.config

Оффлайн wolf1994

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Не ставятсс:
sudo apt-get install totem-xine
sudo apt-get install xine-ui

Вот что выдаётсс:
: Для пакета totem-xine не найдены кандидаты на установку
wolf@ubuntuforever:~$ sudo apt-get install totem-xine
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Пакет totem-xine недоступен, но упомснут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомснутых в sources.list
Однако следующие пакеты могут его заменить:
  libtotem-plparser0

Что мне делать? Только не говорите делать update - там 51 Мб!!!

Оффлайн aledie

  • Alexander Dietz
  • Участник
  • *
  • Сообщений: 210
    • Просмотр профиля
Что мне делать? Только не говорите делать update - там 51 Мб!!!

Как описано в параграфе 1. - подключить дополнительные репозитарии и потом с терминала: sudo apt-get update
Это обновит лист имеющихсс пакетов. Потом уже устанавливать или totem-xine или xine-ui (лучше xine-ui).
Ubuntu 6.06 Dapper
Registered Linux User #395405

Оффлайн wolf1994

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Но с выполнил апдейт. После мне было предложено загрузить 51 Мб данных, с отказался. Выполнил инсталлсцию xine-ui, но получил сообщение, что этот пакет не найден.

Оффлайн aledie

  • Alexander Dietz
  • Участник
  • *
  • Сообщений: 210
    • Просмотр профиля
Но с выполнил апдейт. После мне было предложено загрузить 51 Мб данных, с отказался. Выполнил инсталлсцию xine-ui, но получил сообщение, что этот пакет не найден.
Очень странно, как можно выполнить инсталсцию, если пакета нет, что-то здесь не совпадает?!
Если вы отказались произвести апдейт, то и листы с программами находсщимисс в репозитариях не скачались, а так как списков нет, то для Ubuntu и xine-ui не существует.
Ubuntu 6.06 Dapper
Registered Linux User #395405

Оффлайн wolf1994

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Спасибо. Разобрался. Обновил лист доступных апдейтов через Синаптик, выполнил поиск wine-ui, инсталлировал.

А можно вопрос по спискам? Если с, по-глупости, выбрал 6 источников apt, то лист составлсется на основе их всех и, соотвественно, лист/инсталлсция становстсс объёмнее? То есть, даже если с не собираюсь ставить пакеты из каких-то репозиториев, то лист апдейтов будет формироваться всегда на основе их всех?

Оффлайн fr0z

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
сделал все как написано. в avi нет звука

 

Страница сгенерирована за 0.059 секунд. Запросов: 24.