Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Как узнать зависимости, нужные при сборке (deb)?  (Прочитано 5144 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн igorsub

  • Автор темы
  • Новичок
  • *
  • Сообщений: 48
    • Просмотр профиля
Пытаюсь собрать бинарный файл (deb). Не могу понять, как узнать, какие пакеты нужно указывать в файле control в строке «Build-Depends». Сейчас там стандартно всего две позиции: debhelper (>= 7) и autotools-dev. Но это же не все. В основном руководстве (Packaging Guide) об этом сказана всего пара общих фраз. Нашел на полезном сайте webupd8.org прошлогоднюю статью по сборке, там предлагают воспользоваться такой командой:
dpkg-depcheck -d ./configure
Проблема в том, что у меня она не работает. Считывание заканчивается ошибкой:
...@myUbuntu:~/pkg/gtkpod-2.0.0$ dpkg-depcheck -d ./configure
...
checking for GTK... no
configure: error: in `/home/igorsub/pkg/gtkpod-2.0.0':
configure: error: *** No package 'gtk+-2.0' found
See `config.log' for more details.
Running strace failed (command line:
strace -e trace=open,execve -f -q -o /tmp/depche9ONIA ./configure

Есть еще способ это узнать? Очень странно, что в Packaging Guide об этом ни слова.

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 17 Апрель 2011, 03:36:41 от igorsub »

Оффлайн sanb

  • Активист
  • *
  • Сообщений: 404
    • Просмотр профиля
ldd <бинарник>

Оффлайн igorsub

  • Автор темы
  • Новичок
  • *
  • Сообщений: 48
    • Просмотр профиля
Так бинарного файла-то нет. Его собрать и нужно.

Пользователь решил продолжить мысль 17 Апрель 2011, 03:35:48:
Попробовал ldd на готовых бинарниках, получил «не является динамическим исполняемым файлом».
« Последнее редактирование: 17 Апрель 2011, 03:35:48 от igorsub »

chemtech

  • Гость
aptitude install apt-file
apt-file update
apt-file search gtk+-2.0

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2465
    • Просмотр профиля
Нашел на полезном сайте webupd8.org прошлогоднюю статью по сборке, там предлагают воспользоваться такой командой:
dpkg-depcheck -d ./configure
Проблема в том, что у меня она не работает. Считывание заканчивается ошибкой:
...@myUbuntu:~/pkg/gtkpod-2.0.0$ dpkg-depcheck -d ./configure
...
checking for GTK... no
configure: error: in `/home/igorsub/pkg/gtkpod-2.0.0':
configure: error: *** No package 'gtk+-2.0' found
See `config.log' for more details.
Running strace failed (command line:
strace -e trace=open,execve -f -q -o /tmp/depche9ONIA ./configure


Одну зависимость, считай, нашел: libgtk2.0. Ты вообще хоть немного в курсе сборки из исходников?
Я никого не сторожил!

delovoy

  • Гость
apt-get build-dep [пакет] - настраивает все необходимое для сборки [пакета] из исходников

Оффлайн alsoijw

  • Старожил
  • *
  • Сообщений: 4073
  • Fedora 25 GNOME 3 amd64
    • Просмотр профиля
А какие библиотеки нужны для компиляции?
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?

Оффлайн koshev

  • Старожил
  • *
  • Сообщений: 1671
  • חתול המדען
    • Просмотр профиля
apt-get build-dep [пакет] - настраивает все необходимое для сборки [пакета] из исходников
Только в том случае, если подключён deb-src и у пакета есть исходики в репазитарии.
А какие библиотеки нужны для компиляции?
Читайте README или INSTALL в корневой папке с исходными текстами, обычно это указывается.
« Последнее редактирование: 21 Июнь 2014, 12:49:01 от koshev »
Debian GNU\Linux 7.11; ICH7; r8169; Linux 4.14.32-atomd525mv-imq-ja1 (i686)
Ubuntu GNU\Linux 18.04; MCP61; forcedeth; 4.15.0-20-generic (x86_64)

Krjd

  • Гость
могу ошибаться, но по моему dpkg-buildpackage, при нехватке зависимостей, выводит чего не хватает

 

Страница сгенерирована за 0.069 секунд. Запросов: 24.