Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: qt-x11-opensource-4.4.3 на Ubuntu 10.10.  (Прочитано 877 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rellanium

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
qt-x11-opensource-4.4.3 на Ubuntu 10.10.
« : 19 Апрель 2011, 17:52:08 »
Здравствуйте, уважаемые!! Помогите нубасу.  :-[  На работе срочно надо поставить QT 4.4.3 на Ubuntu 10.10.

делал так.

$ sudo apt-get install build-essential
$ sudo apt-get install libx11-dev

$./configure
$ make

при линковке вылетает ошибка.

.........qt-x11-opensource-src-4.4.3/lib -L/usr/X11R6/lib -lXext -lX11 -lQtCore -lm -lrt -ldl -lpthread

 /usr/bin/ld: cannot find -lXext
collect2: ld returned 1 exit status

когда в makefile убираю -lXext  и занова make то всё идёт дальше. Думал, что прокатит без -lXext, но он почти в каждом makefile.
Поск "Xext" по всей файловой системе практически ничего не даёт.

вот нарыл кое-что по этому поводу, но нет соображений http://linux.about.com/cs/linux101/g/xext.htm

Помогите, братцы!  :D Спасибоооооо!!!!!!!!!!

Оффлайн solint

  • Активист
  • *
  • Сообщений: 673
    • Просмотр профиля
Re: qt-x11-opensource-4.4.3 на Ubuntu 10.10.
« Ответ #1 : 19 Апрель 2011, 18:38:19 »
Чего-то неясно. Ubuntu 10.04. Из Синаптика стоит qt 4.6.2
Чем не устраивает? Или надо именно старую версию?

Оффлайн Мангуст

  • Любитель
  • *
  • Сообщений: 98
    • Просмотр профиля
Re: qt-x11-opensource-4.4.3 на Ubuntu 10.10.
« Ответ #2 : 19 Апрель 2011, 19:32:26 »
sudo apt-get install libxext-dev

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
Re: qt-x11-opensource-4.4.3 на Ubuntu 10.10.
« Ответ #3 : 20 Апрель 2011, 05:45:03 »
при чем здесь libx11-dev libxext-dev если тебе надо поставить qt4-dev которая потянет все нужные ей зависимости?
топик не о программировании а о "я не асислил установку софта на Ubuntu"

Оффлайн rellanium

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: qt-x11-opensource-4.4.3 на Ubuntu 10.10.
« Ответ #4 : 20 Апрель 2011, 09:16:39 »
Мангуст! Спасибо! помогло.

Yurror, libx11-dev libxext-dev именно для того,что при сборке нужны эти библиотеки. Извини, если топик был не по адресу, но мне помогли!)) УРА!!!

 

Страница сгенерирована за 0.051 секунд. Запросов: 22.