Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: проблема с зависимостями  (Прочитано 4806 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн to0n1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
проблема с зависимостями
« : 19 Апреля 2011, 21:32:34 »
вообщем чтото у меня худо стал запускаться Open Office решил я его снести
написал sudo apt-get remove openoffice.org
все чудненько снеслось
решил поставить libre office пушу
sudo apt-get install libreoffice
все установилось работает.
позже попытался установить другие проги мне пишет вот такую весчь:
sudo apt-get install cmake
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
  cmake: Зависит: cmake-data (= 2.8.0-5ubuntu1) но он не будет установлен                                                                                                             
  libreoffice-core: Зависит: libreoffice-common (> 1:3.3.2) но он не будет установлен                                                                                                 
  libreoffice-java-common: Зависит: libreoffice-common но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).
пишу ему sudo apt-get -f install
тение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-backports-modules-alsa-2.6.32-29-generic
Для их удаления используйте 'apt-get autoremove'.
Будут установлены следующие дополнительные пакеты:
  libreoffice-common
Предлагаемые пакеты:
  libreoffice-style-hicontrast libreoffice-style-tango libreoffice-style-crystal libreoffice-style-oxygen
НОВЫЕ пакеты, которые будут установлены:
  libreoffice-common
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 3 пакетов не обновлено.
не установлено до конца или удалено 13 пакетов.
Необходимо скачать 0B/17,0MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 44,1MB.
Хотите продолжить [Д/н]? д
(Чтение базы данных ... на данный момент установлено 171159 файлов и каталогов.)
Распаковывается пакет libreoffice-common (из файла .../libreoffice-common_1%3a3.3.2-1ubuntu2~lucid1_all.deb)...
/var/lib/dpkg/tmp.ci/preinst: 80: dpkg-maintscript-helper: not found
/var/lib/dpkg/tmp.ci/preinst: 80: dpkg-maintscript-helper: not found
dpkg: не удалось обработать параметр /var/cache/apt/archives/libreoffice-common_1%3a3.3.2-1ubuntu2~lucid1_all.deb (--unpack):
 попытка перезаписи '/usr/bin/unopkg', котор(ый)ая также находится в пакете openoffice.org-common 2:3.1.1-2infra3~intrepid1
/var/lib/dpkg/tmp.ci/postrm: 22: dpkg-maintscript-helper: not found
/var/lib/dpkg/tmp.ci/postrm: 22: dpkg-maintscript-helper: not found
dpkg-deb: подпроцесс вставка завершён по сигналу (Обрыв канала)
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libreoffice-common_1%3a3.3.2-1ubuntu2~lucid1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Помогите люди добрые !! очень не хочеться мносить систему .....

Оффлайн Smytjan

  • Участник
  • *
  • Сообщений: 118
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #1 : 19 Апреля 2011, 21:40:52 »
попробуй через синаптик Правка→Исправить пакеты с ошибками.
Ubuntu 10.04.4 x64 & Win7

Оффлайн to0n1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #2 : 19 Апреля 2011, 21:48:37 »
у меня KDE4 так что синаптика нету ... есть KPackageKit

Оффлайн vasyl

  • Старожил
  • *
  • Сообщений: 1724
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #3 : 19 Апреля 2011, 21:57:17 »
Удалить полностью все пакеты openoffice?
Ubuntu Mate 16.04 + Windows 10

Оффлайн to0n1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #4 : 19 Апреля 2011, 22:01:29 »
не могу ....
sudo apt-get remove openoffice.org
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Пакет openoffice.org не установлен, поэтому не может быть удалён
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
  libreoffice-core: Зависит: libreoffice-common (> 1:3.3.2) но он не будет установлен
  libreoffice-java-common: Зависит: libreoffice-common но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).

Оффлайн vasyl

  • Старожил
  • *
  • Сообщений: 1724
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #5 : 20 Апреля 2011, 20:23:56 »
sudo apt-get purge openoffice*?
sudo apt-get autoremove
sudo apt-get check
« Последнее редактирование: 20 Апреля 2011, 20:35:51 от vasyl »
Ubuntu Mate 16.04 + Windows 10

Оффлайн to0n1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #6 : 20 Апреля 2011, 23:42:10 »
Заметьте, выбирается openoffice.org-l10n-ku из-за регулярного выражения openoffice*?
Заметьте, выбирается openoffice.org-l10n-ml из-за регулярного выражения openoffice*?
Заметьте, выбирается openoffice.org-l10n-oc из-за регулярного выражения openoffice*?
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
  aspell: Зависит: dictionaries-common (> 0.40) но он не будет установлен
  aspell-en: Зависит: dictionaries-common (>= 0.49.2) но он не будет установлен
  hunspell-en-ca: Зависит: dictionaries-common (>= 0.10) но он не будет установлен или
                                  openoffice.org-updatedicts
  hunspell-en-us: Зависит: dictionaries-common (>= 0.10) но он не будет установлен
  language-support-writing-ru: Зависит: myspell-ru но он не будет установлен
  libreoffice-core: Зависит: libreoffice-common (> 1:3.3.2) но он не будет установлен
  libreoffice-java-common: Зависит: libreoffice-common но он не будет установлен
  myspell-en-au: Зависит: dictionaries-common (>= 1.0) но он не будет установлен
  myspell-en-gb: Зависит: dictionaries-common (>= 0.10) но он не будет установлен или
                                 openoffice.org-updatedicts
  myspell-en-za: Зависит: dictionaries-common (>= 0.10) но он не будет установлен или
                                 openoffice.org-updatedicts
  wbritish: Зависит: dictionaries-common (>= 0.20) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).
alex@to0n1kub:~$

Оффлайн vasyl

  • Старожил
  • *
  • Сообщений: 1724
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #7 : 20 Апреля 2011, 23:45:33 »
sudo apt-get purge openoffice.org-l10n-ku
sudo apt-get purge openoffice.org-l10n-ml
sudo apt-get purge openoffice.org-l10n-oc
sudo apt-get purge openoffice.org
Ubuntu Mate 16.04 + Windows 10

Оффлайн to0n1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #8 : 21 Апреля 2011, 00:10:39 »
да что бы я не писал связаное с apt-get или с aptitude мне выдет одно и тоже
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
  libreoffice-core: Зависит: libreoffice-common (> 1:3.3.2) но он не будет установлен
  libreoffice-java-common: Зависит: libreoffice-common но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #9 : 21 Апреля 2011, 00:12:57 »
Показывай:
$ cat /etc/lsb-release
$ grep -v '^#\|^$' /etc/apt/sources.list{,.d/*.list}
« Последнее редактирование: 21 Апреля 2011, 09:13:22 от фирэфохэ »
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

Оффлайн to0n1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #10 : 21 Апреля 2011, 08:11:35 »
lex@to0n1kub:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.2 LTS"
alex@to0n1kub:~$ grep -v '^#|^$' /etc/apt/sources.list{,.d/*.list}
/etc/apt/sources.list:# deb cdrom:[Kubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)]/ karmic main restricted
/etc/apt/sources.list:# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
/etc/apt/sources.list:# newer versions of the distribution.
/etc/apt/sources.list:
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ lucid main restricted
/etc/apt/sources.list:deb-src http://ua.archive.ubuntu.com/ubuntu/ lucid main restricted
/etc/apt/sources.list:
/etc/apt/sources.list:## Major bug fix updates produced after the final release of the
/etc/apt/sources.list:## distribution.
/etc/apt/sources.list:
/etc/apt/sources.list:## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
/etc/apt/sources.list:## team. Also, please note that software in universe WILL NOT receive any
/etc/apt/sources.list:## review or updates from the Ubuntu security team.
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ lucid universe
/etc/apt/sources.list:deb-src http://ua.archive.ubuntu.com/ubuntu/ lucid universe
/etc/apt/sources.list:
/etc/apt/sources.list:## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
/etc/apt/sources.list:## team, and may not be under a free licence. Please satisfy yourself as to
/etc/apt/sources.list:## your rights to use the software. Also, please note that software in
/etc/apt/sources.list:## multiverse WILL NOT receive any review or updates from the Ubuntu
/etc/apt/sources.list:## security team.
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ lucid multiverse
/etc/apt/sources.list:deb-src http://ua.archive.ubuntu.com/ubuntu/ lucid multiverse
/etc/apt/sources.list:
/etc/apt/sources.list:## Uncomment the following two lines to add software from the 'backports'
/etc/apt/sources.list:## repository.
/etc/apt/sources.list:## N.B. software from this repository may not have been tested as
/etc/apt/sources.list:## extensively as that contained in the main release, although it includes
/etc/apt/sources.list:## newer versions of some applications which may provide useful features.
/etc/apt/sources.list:## Also, please note that software in backports WILL NOT receive any review
/etc/apt/sources.list:## or updates from the Ubuntu security team.
/etc/apt/sources.list:# deb http://ua.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
/etc/apt/sources.list:# deb-src http://ua.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
/etc/apt/sources.list:
/etc/apt/sources.list:## Uncomment the following two lines to add software from Canonical's
/etc/apt/sources.list:## 'partner' repository.
/etc/apt/sources.list:## This software is not part of Ubuntu, but is offered by Canonical and the
/etc/apt/sources.list:## respective vendors as a service to Ubuntu users.
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu karmic partner
/etc/apt/sources.list:deb-src http://archive.canonical.com/ubuntu karmic partner
/etc/apt/sources.list:
/etc/apt/sources.list.d/dtl131-ppa-lucid.list:deb http://ppa.launchpad.net/dtl131/ppa/ubuntu lucid main
/etc/apt/sources.list.d/infralinux.list:deb http://archive.infralinux.org/infralinux intrepid main restricted
/etc/apt/sources.list.d/infralinux.list:deb-src http://archive.infralinux.org/infralinux intrepid main restricted
/etc/apt/sources.list.d/infralinux.list:deb http://archive.infralinux.org/infralinux intrepid-security main restricted
/etc/apt/sources.list.d/infralinux.list:deb-src http://archive.infralinux.org/infralinux intrepid-security main restricted
/etc/apt/sources.list.d/infralinux.list:deb http://archive.infralinux.org/infralinux intrepid-updates main restricted
/etc/apt/sources.list.d/infralinux.list:deb-src http://archive.infralinux.org/infralinux intrepid-updates main restricted
/etc/apt/sources.list.d/libreoffice-ppa-lucid.list:deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu lucid main
/etc/apt/sources.list.d/opera.list:# This file makes sure that Opera Browser is kept up-to-date
/etc/apt/sources.list.d/opera.list:# as part of regular system upgrades
/etc/apt/sources.list.d/opera.list:
/etc/apt/sources.list.d/opera.list:deb http://deb.opera.com/opera/ stable non-free #Opera Browser (final releases)
/etc/apt/sources.list.d/opera.list:
/etc/apt/sources.list.d/opera.list:# The line above will make sure you get all final public releases.
/etc/apt/sources.list.d/opera.list:# Uncomment the following line if you want to get alpha and beta
/etc/apt/sources.list.d/opera.list:# releases, too.
/etc/apt/sources.list.d/opera.list:
/etc/apt/sources.list.d/opera.list:# deb http://deb.opera.com/opera-beta/ stable non-free #Opera Browser (beta releases)
/etc/apt/sources.list.d/ubuntu-audio-dev-ppa-lucid.list:deb http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu lucid main
/etc/apt/sources.list.d/ubuntu-wine-ppa-lucid.list:deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu lucid main
alex@to0n1kub:~$

Оффлайн vasyl

  • Старожил
  • *
  • Сообщений: 1724
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #11 : 21 Апреля 2011, 12:15:48 »
"deb http://ua.archive.ubuntu.com/ubuntu/ karmic(?) -backports main restricted universe multiverse"
Ubuntu Mate 16.04 + Windows 10

Оффлайн to0n1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #12 : 21 Апреля 2011, 20:25:32 »
Цитировать
deb http://ua.archive.ubuntu.com/ubuntu/ karmic(?) -backports main restricted universe multiverse"
что с эти делать ?? в соурсес добавить ?? почему кармик если у меня lucid вроде ...

Пользователь решил продолжить мысль 21 Апреля 2011, 20:29:23:
в общем там уже были такие строки только закоментированые... раскоментировал и ничего не изменилось :(
« Последнее редактирование: 21 Апреля 2011, 20:29:23 от to0n1 »

Оффлайн to0n1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #13 : 24 Апреля 2011, 08:39:48 »
Ну что никто не поможет ???

Оффлайн vasyl

  • Старожил
  • *
  • Сообщений: 1724
    • Просмотр профиля
Re: проблема с зависимостями
« Ответ #14 : 24 Апреля 2011, 08:49:12 »
"почему кармик если у меня lucid вроде ..."- убрать кармик?
Ubuntu Mate 16.04 + Windows 10

 

Страница сгенерирована за 0.032 секунд. Запросов: 23.