Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: что за пакеты  (Прочитано 522 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Explode

  • Автор темы
  • Гость
что за пакеты
« : 19 Апрель 2011, 21:43:06 »
Где найти вот эти пакеты?
Цитировать
- ERROR: SDL (2.2.5) is installed, but we need version >= 2.526
 - ERROR: Alien::SDL is not installed
Первый это libsdl-perl, только вот нужную версию найти не могу. А второй даже не знаю что такое.

Оффлайн Root-Boot

  • Старожил
  • *
  • Сообщений: 1814
    • Просмотр профиля
Re: что за пакеты
« Ответ #1 : 19 Апрель 2011, 21:49:24 »
Первый это libsdl-perl, только вот нужную версию найти не могу.
Понятно почему. Такой версии пакета .deb не существует, есть только .rpm

Explode

  • Автор темы
  • Гость
Re: что за пакеты
« Ответ #2 : 19 Апрель 2011, 21:52:52 »
ну а его как нибудь можно поставить в систему?

Оффлайн Root-Boot

  • Старожил
  • *
  • Сообщений: 1814
    • Просмотр профиля
Re: что за пакеты
« Ответ #3 : 19 Апрель 2011, 21:57:27 »
ну а его как нибудь можно поставить в систему?
RPM? Это по сути невозможно, строение систем совершенно разное. Надо искать исходники.

Оффлайн Psy[H[]

  • Активист
  • *
  • Сообщений: 883
  • Маньяк. Ставлю Линух на все что попадется под руку
    • Просмотр профиля
Re: что за пакеты
« Ответ #4 : 19 Апрель 2011, 22:01:26 »
конвертнуть rpm в deb через alien, но не факт что прямо встанет.

А чем оно требуется?
Я знаю только то, что ничего не знаю.
                                     

Explode

  • Автор темы
  • Гость
Re: что за пакеты
« Ответ #5 : 19 Апрель 2011, 22:04:43 »
вот, захотелось вспомнить былое =)
http://www.nixp.ru/news/%D0%9B%D0%B5%D0%B3%D0%B5%D0%BD%D0%B4%D0%B0%D1%80%D0%BD%D1%8B%D0%B9-%D0%BA%D0%B2%D0%B5%D1%81%D1%82-The-Neverhood-%D0%BF%D0%B5%D1%80%D0%B5%D0%BF%D0%B8%D1%81%D0%B0%D0%BB%D0%B8-%D0%BD%D0%B0-Perl.html

Пользователь решил продолжить мысль 19 Апрель 2011, 22:10:15:
а что на счет второго пакета?
« Последнее редактирование: 19 Апрель 2011, 22:10:15 от Explode »

Оффлайн Root-Boot

  • Старожил
  • *
  • Сообщений: 1814
    • Просмотр профиля
Re: что за пакеты
« Ответ #6 : 19 Апрель 2011, 22:17:54 »

Цитировать
- ERROR: Alien::SDL is not installed
Цитировать
alien
Такое ощущение что нужен этот самый alien. Возможно я ошибаюсь. Попробуйте.
sudo apt-get install alien

Оффлайн RazrFalcon

  • O_o
  • Старожил
  • *
  • Сообщений: 3144
  • Zombie Mod
    • Просмотр профиля
    • Я на GitHub
Re: что за пакеты
« Ответ #7 : 19 Апрель 2011, 22:19:28 »
ООО неверьвхудо!
Gentoo + KDE, Official Windows Hater
Хотите помочь нашей вики: http://help.ubuntu.ru/wiki/fixme

Explode

  • Автор темы
  • Гость
Re: что за пакеты
« Ответ #8 : 19 Апрель 2011, 22:25:32 »

Цитировать
- ERROR: Alien::SDL is not installed
Цитировать
alien
Такое ощущение что нужен этот самый alien. Возможно я ошибаюсь. Попробуйте.
sudo apt-get install alien
Цитировать
explode@explode-laptop:~$ sudo apt-get install alien
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Уже установлена самая новая версия alien.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.

Оффлайн Root-Boot

  • Старожил
  • *
  • Сообщений: 1814
    • Просмотр профиля
Re: что за пакеты
« Ответ #9 : 19 Апрель 2011, 22:32:29 »
Цитировать
libsdl-perl
Вот по моему этот пакет, только .rpm
wget http://distro.ibiblio.org/pub/linux/distributions/unity/repo/current/i586/main/perl-SDL-2.526.0-1-unity2011.i586.rpm
Цитировать
explode@explode-laptop:~$ sudo apt-get install alien
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Уже установлена самая новая версия alien.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Тогда трудно сказать что ему нужно. Все это тайна покрытая мраком  :)

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
Re: что за пакеты
« Ответ #10 : 19 Апрель 2011, 22:41:58 »
вот, захотелось вспомнить былое =)
http://www.nixp.ru/news/%D0%9B%D0%B5%D0%B3%D0%B5%D0%BD%D0%B4%D0%B0%D1%80%D0%BD%D1%8B%D0%B9-%D0%BA%D0%B2%D0%B5%D1%81%D1%82-The-Neverhood-%D0%BF%D0%B5%D1%80%D0%B5%D0%BF%D0%B8%D1%81%D0%B0%D0%BB%D0%B8-%D0%BD%D0%B0-Perl.html

А здесь говорят, что качать пока рано
Цитировать
Сейчас доступна версия 0.001. Работает меню и самый первый экран игры
Хотя, конечно, качать никто не запрещает
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

Explode

  • Автор темы
  • Гость
Re: что за пакеты
« Ответ #11 : 19 Апрель 2011, 22:45:27 »
я знаю это, читал. однако планирую следить за развитием проекта

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
Re: что за пакеты
« Ответ #12 : 19 Апрель 2011, 22:50:26 »
Neverhood на решете, да ну нафиг, надо скачать.
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

Explode

  • Автор темы
  • Гость
Re: что за пакеты
« Ответ #13 : 19 Апрель 2011, 23:30:45 »
ну что, кто пробовал устанавливать?

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
Re: что за пакеты
« Ответ #14 : 20 Апрель 2011, 00:19:11 »
Попробовал, ну его нафиг. Одну библиотеку скомпилить нужно, в той по зависимостям ещё одну, в этой ещё штук пять компилить, так как версий нужных нет в репах. Ай, лень.
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

 

Страница сгенерирована за 0.19 секунд. Запросов: 22.